P: Identity plate module picker buttons font size not working

5 Votes
LEGEND ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

I am working under the Edit menu to change the identity plate setup.  I have selected personalized and custom plate, and Show Status and Activity is selected.  I have typed the custom text I want to display and selected the typeface and font size.

The issue starts when I select the complementary typeface for the module picker buttons and font size.  The font size starts off as if it's a multiple of the selected size, not the selected font size.  Regardless of typeface, it behaves similarly.

It gets better.  Regardless of the size selected in the button picker, each time a different typeface is selected, the size gets bigger by what looks like the same multiple.  The size returns to the original (wrong) font size when the size is manually selected.

Here's my machine:
Refurbished and nearly new (two months old to me): Dell XPS 13.3" QHD+ TOUCH Laptop 7th Gen Intel Core i7-7560U at 2.4GHz with Turbo Boost to 3.8GHz, 16GB RAM, 512GB SSD using the Intel HD graphics card with  3200 x 1800 resolution.  Running Windows 10 64-bit.  (Seriously - this little thing is a beast!)

No worries on getting back to me - I'm sure this'll be fixed when you get to it.  I understand this is low priority, and I've figured out how to set my ID plate and move on.  I was really amused playing with this particular bug and watching the fonts grow out of control.  Have fun squishing it.

KD

Bug Investigating
TOPICS
macOS , Windows

Views

8

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 09, 2018 Feb 09, 2018
Hi Kevin, I was able to reproduce the issue on my Dell XPS 15" 4K Touch laptop. I have logged a bug on the same. Thanks, Smit Keniya Lightroom Classic Team

Votes

Translate

Translate
7 Comments
Adobe Employee ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Hi Kevin,

I was able to reproduce the issue on my Dell XPS 15" 4K Touch laptop. I have logged a bug on the same.

Thanks,
Smit Keniya
Lightroom Classic Team

Smit | Lightroom Classic Team

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

I don't see this problem on a standard resolution display, 24" 1900 x 1200. So I suspect it has something to do with both OS and LR interface scaling to bring the font sizes up to something you can actually read without a magnifying glass

Votes

Translate

Translate

Report

Report
New Here ,
Jun 25, 2018 Jun 25, 2018

Copy link to clipboard

Copied

Yep, XPS 15 4k. Same issue with custom identity plate. I'm reduced font size to 5 - 7 and it became workable, but with font switching it resets to huge sizes.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 19, 2019 Jan 19, 2019

Copy link to clipboard

Copied

I’m having the very same problem on a desktop that I’ve had for over 6 years and a 24” monitor at 1900 x 1200. I’ve used the same identity plate for years and only tried editing it recently.

I’m on Classic CC 8.1 and Windows 10.

Mickey

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 11, 2019 Jul 11, 2019

Copy link to clipboard

Copied

Is there any movement on this? I'm using LR on a Mac, and having a similar problem. I set the Identity Plate type size to 22, but only get that at some undetermined text length. If the text runs longer, the type shrinks. If the text runs shorter, it's bigger. The tool completely does not respect the selected text size, but instead dynamically scales based on the length of what's in the text box. Kind of maddening.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 21, 2019 Sep 21, 2019

Copy link to clipboard

Copied

Some more specific observations on Windows 10 Pro (also submitted via chat with Adobe tech this week): For screens with resolutions higher than 1920x1080, windows has a scaling mechanism for fonts and other UI elements so that menu text doesn't become unreadably small. For a UHD screen (3840 x 2160), Windows recommends scaling of 200%. In these conditions, if you set the font size for the right-hand side of the identity plate to 9pt, close the modal window, then reopen to edit the identity plate again: the font size has become 36pt. And the displayed size is much too large. You can't set the font size to less than 9pt, so you are stuck with it. Changing fonts doesn't help (system fonts, TypeKit fonts, etc., both .TTF and .OTF containers, etc., matching the left-hand-side or not).

Change the font scaling of the screen to 100% (at whatever resolution), and you are OK. (You need to restart LR when you change the screen scaling.) The left-hand side of the identity badge is also OK at whatever scaling. Set scaling to 150% and 9pt becomes 21pt.

I theorize that font scaling is happening twice. 9pt * 200% * 200% = 36pt. 9pt * 150% * 150% = 20.25, round up is 21pt. On the other hand, the simple pattern breaks down, so there's something more complicated than simple duplication. At 300%, 9pt * 300% * 300% = 81pt, but actually it's 58pt.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 31, 2021 Jul 31, 2021

Copy link to clipboard

Copied

LATEST

Any update on this issue.  It's still a problem and very frustrating.

Votes

Translate

Translate

Report

Report