P: Message: "The catalog could not be opened due to an unexpected error."

3 Votes
Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

This issue has returned.

 

The catalog opened ONCE (and only once) after updating to LrC 10.2; I do this as a test everytime I update LrC.

 

Now, a few days later, I get the pop-up with the error text: "The catalog could not be opened due to an unexpected error."

Bug Fixed
TOPICS
macOS , Windows

Views

1.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 08, 2021 Jun 08, 2021
We have fixed this issue in 10.3

Votes

Translate

Translate
replies 113 Replies 113
113 Comments
Adobe Employee ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

The team needs to collect additional information from those of you still affected by this issue. 

Please download the linked config.lua.zip file

Place in the Lightroom Classic Preset folder as mentioned below:

In Lightroom Classic:
On Windows: Select Edit > Preferences > Preset. Then select Show All Other Presets.
On Mac: Select Lightroom Classic > Preferences > Preset. Then select Show All Other Presets.

This will open the Lightroom Classic Preset folder mentioned earlier.

Copy the config.lua file into the Lightroom folder.

Open Lightroom Classic 10.2

When the catalog opening fails quit Lightroom.
Collect the Logs that are generated in the Documents/LrClassicLogs folder

Reply when you have logs ready to send. 

Thanks for your continued assistance.

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Hi Rikk, thank you!

Ready!

However, please know I can't open lightroom at all!

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

@ Rikk

Same problem here. The error does not allow me to get to Lightroom preferences. 

Where on a Mac can I find the folder for presets?

Thanks,

PintorMX

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

When I look in "Macintosh HD > Applications > Adobe Lightroom Classic" there is no "Presets" folder like those that exist in Photoshop and Bridge.

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

@ rikk

I created a "Presets" folder in Applications > Lightroom Classic. I placed the config.lua in there. 

I launched LRC 10.2. 

Catalog failed to load.

I quit LRC. 

I looked in Macintosh > Users > [me] > Documents where there was no LrClassicLogs folder. 

What now?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

@PintorMX If you cannot open Lightroom due to the catalog error,  you will need to use the [Opt/Alt]+[Click LR Icon] to create a blank catalog. Then follow the instructions to locate and place the config.lua file. 

Afterwards: Open Lightroom with your original catalog and obtain the log files. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

I have had repeated corrupt catalog errors with Lightroom 10.2.  I have not been able to open a catalog a second time for over a month.  I uninstalled 10.2 and went back to 10.  This appears to have solved the problem.  I can now create catalogs, edit, exit and reopen without the catalogs corrupting.

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

That also doesn't work. Not possible to create a new catalog. 

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Good short term solution! But I guess there needs to be a longterm fix 😞

Votes

Translate

Translate

Report

Report
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

How did you save your presets if you had any if you weren't able to open the program? I would also go back to an older version but want to make sure I don't loose anything since you have to uninstall and reinstall. 

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Just an update from me, the thread starter. (May 19)

For unknown reasons, LrC 10.2 has been behaving quite normally for me for the last couple of weeks.

I have not been doing anything out of the ordinary, except just using and testing LrC daily.

Votes

Translate

Translate

Report

Report
LEGEND ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

I did the procedure but
I cannot find the logs that should be generated in the Documents / LrClassicLogs folder
LrClassicLogs is nowhere on my imac

I went back to version 10.1.1

Votes

Translate

Translate

Report

Report
New Here ,
May 22, 2021 May 22, 2021

Copy link to clipboard

Copied

Having the issue with 10.2, but it returns normal after I rolling back to 10.1.1. I remember there was the same issue when I update to 10.1, adobe you're really bad at making updates, aren't you?

Votes

Translate

Translate

Report

Report
LEGEND ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

I am also having this same problem - tried all recommendations in this thread and nothing helped!  

Votes

Translate

Translate

Report

Report
Participant ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Same Problem here. Suddendly from one day to the other, LR stopped working between closing and opening it, even with backup catalogs. Also get the "Unexpected Error" messages and can't use the program anymore.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Has anyone tested the June 2021 update, LrC 10.3?

If so, does LrC 10.3 fix the issue with "The catalog could not be opened due to an unexpected error" ?

I realize that this is an intermittent issue for many folks, and we won't know for a week or more if it really is fixed.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

@JPEG

Hi, I have been lucky enough to be able to test the 10.3 version for some time now to see if it fixes the issue and it did for me. So hopefully with the release ( I was actually able to update to 10.3 today) this problem might be fixed for many people! Fingers crossed! 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

We have fixed this issue in 10.3

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

A month lost with this rotten 10.2 version.

Thanks Adobe !!
The automatic bank debit has never broken down.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Updated to 10.3 and the same problem persists.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Bummer. I had the vibe that Adobe was a bit overconfident in their assertion that this has been fixed.

I have not updated to 10.3 myself, taking a wait-and-see-approach.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

@ragrawal Well, we now have at least one report that this has not been fixed in 10.3.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

By my count on this thread we have two customer reporting fixed and one who is not fixed.  Can anyone else chime in with whether or not the 10.3 update has fixed it for them?

I realize that it might take a day or two with an intermittent issue like this to provide a confident answer.  

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Participant ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Maybe the 10.2 just corrupted the catalogs unrecoverably when saving (because first time opening it with the new 10.2 version always seemed to work).

So if you already have a corrupted catalog from 10.2, maybe even version 10.3 cannot undo that corruption.

I rolled back to 10.1 and recovered a backup-catalog. Maybe I'll try 10.3 later. But right now 10.1 works just fine.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Very positive test for version 10.3
Several openings and closings and catalog change in 3 days and no problem.

A month lost with this rotten 10.2 version.

Thanks Adobe !!

Votes

Translate

Translate

Report

Report