P: Message: "The catalog could not be opened due to an unexpected error."

3 Votes
Community Beginner ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

This issue has returned.

 

The catalog opened ONCE (and only once) after updating to LrC 10.2; I do this as a test everytime I update LrC.

 

Now, a few days later, I get the pop-up with the error text: "The catalog could not be opened due to an unexpected error."

Bug Fixed
TOPICS
macOS , Windows

Views

1.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 08, 2021 Jun 08, 2021
We have fixed this issue in 10.3

Votes

Translate

Translate
replies 113 Replies 113
113 Comments
Community Beginner ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I should add that 10.2 is still behaving well for me personally, and has been doing so for about a month. I haven’t done anything “special” to address this condition — it seems to have “fixed itself.”

LrC Mac 10.2, 2019 iMac 27-inch, 10.15.7

Votes

Translate

Translate

Report

Report
New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

I know it is individual, but at least for me:

LrC 10.2 - If I just rebooted, I could usually start up LrC with no issues, and I could change to another Library as well. If I shut down LrC entirely, and then tried to open it up again, it would come up with errors. If I then rebooted my Mac, it would usually work again.

LrC 10.3 - Having updated a few days ago, all has worked fine since. I can open up LrC, change Libraries, shut it down, and open it up later...

Votes

Translate

Translate

Report

Report
New Here ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

I just updated to LrC 10.3 from LrC 10.1.1 after many failed attempts with 10.2.  I only updated, opened the catalog successfully, browsed some images, closed and then successfully reopened. 

Although I was never able to open 10.2, at least 10.3 updated the catalog and allowed me to open.  So far, so good.  I will not be able to test any more for several days due to other obligations.  I will continue to monitor this thread and report back anything pertinent.

macOS Big Sur 11.4

iMac (Retina 5K, 27-inch, 2017)

4.2 GHz Quad-Core Intel Core i7

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 13, 2021 Jun 13, 2021

Copy link to clipboard

Copied

So far so good!

(June 13)

Just updated to Mac LrC 10.3. After multiple catalog open/closings and light Develop testing, everything is looking good. I plan to test ~daily for the next few weeks.

LrC Mac 10.3, 2019 iMac 27-inch, i9, 40 GB RAM, 10.15.7

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Update (June 25)

I have not seen this problem return.

I believe this is "solved" in 10.3 -- for my personal set-up at least.

LrC Mac 10.3, 2019 iMac 27-inch, i9, 40 GB RAM, 10.15.7

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hello!

I am having this very same issue today.

Since there is people reporting this until 17 days ago, can anybody suggest what's the best way to proceed?

Thank you

macOS Big Sur 11.4

iMac (Retina 5K, 27-inch, 2019)

3,7 GHz 6-Core Intel Core i5

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

*Giuliana Succo Please go to Help>System Info… and get us the exact installed version number of your software.

-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

I just uninstalled LrC 10.3 and reinstalled LrC 10.2. I opened the catalog and everything is working!

I had the same issue last night, I have a wedding to deliver this weekend!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 18, 2021 Jul 18, 2021

Copy link to clipboard

Copied

Hi. I have LrC 10.3. My Catalog currently resides on an external drive. In order to speed things up, I moved a copy of the Catalog and associated files to the SSD in my Mac Mini. I get this message the first time I try to open Lr from either finder or directly. When I press 'Try again', it works. I have no such issue on the external drive (also an SSD). 

I tried to create a new Catalog on the system drive and it wouldn't work either.

Originally, I thought it might be a Permissions issue, but I have reset them and the problem persists.

Any thoughts?

Votes

Translate

Translate

Report

Report
New Here ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

@ragrawal

I just upgraded to 10.3, and half my catalog is gone.  Same thing happened when I upgraded last time.  What a mess.  It happens when I get forced into upgrading.  I skip the reminders long enough that it no longer gives me the option to skip.  And now all my edits from 2017 til today are gone.

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

That sounds like you have inadvertantly opened an old backup catalog or an older version of your primary catalog. 

Search your hard drive for *.LRCAT and see if you can find a recent file that contains your missing edits.  You can double click on an LRCAT to launch it. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

@sunil_bhaskaran I have issues upgrading when promoted to.  No issues if I upgrade on my own, not through the prompt.  Has happened the last two upgrades.  It does not backup my whole catalog, only about half of it.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 22, 2022 Feb 22, 2022

Copy link to clipboard

Copied

LATEST

False...

Votes

Translate

Translate

Report

Report