Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Opening multiple images as layers from Lightroom

7 Votes
Community Beginner ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

When I select multiple images in lightroom and hit "open as layers in photoshop", photoshop launches and opens the first couple images and then stops opening the remaining images. It leaves a layer called "load images" at the bottom of the image stack.

 

Often if I close the file, and try again, it will work the second time. This has been a repeated issue for several years. I manage a facebook group for architectural photographers with 3.5k members and this issue is regularly brought up.

 

I'm currently using PS 22.5.0 and lightroom Classic 10.4 on a iMac running Big Sur 11.5.2.

 

Please address this issue!!!!

Bug Investigating
TOPICS
macOS

Views

580

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 09, 2021 Sep 09, 2021
Investigating
Status Investigating

Votes

Translate

Translate
37 Comments
Adobe Community Professional ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Works as it should on this end, Big Sur, latest version of LR and Photoshop. But this WAS a bug in the past and was fixed. You may want to try using the CC app to uninstall both (keep preferences), then install Photoshop first, followed by Lightroom Classic. 

Author “Color Management for Photographers" & "Photoshop CC Color Management"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

The issue Andrew mentions is here: https://community.adobe.com/t5/camera-raw-bugs/lightroom-classic-quot-open-as-layers-in-photoshop-qu... 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

This is such a workflow issue - I have to do this for every single image with my real estate shoots. Instead, I load each one individually, and have to manually copy over each image. Why not update this? It's been this way as long as I've been using Adobe.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Is this resolved if you restore both the preference files in LrC AND PS? Perhaps the one for PS first.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I recently updated to latest versions for LR Classic and PS 2021 as listed above.  Since then, when I try to "Open as Layers in Photoshop" of any more than 20 LR images, the process just stops, the layers that had opened in PS during the process go away, and PS goes to the "Welcome to Photoshop, Daniel" screen.  I know in the past I've opened 100s of layers from LR to PS.  I did the updates a few weeks ago and this is the first time I've tryied to open layers in PS and it's the first time the process has behaved this way.

 

I run LR and PS on Windows 10, ver. 20H2 (up to date) and I use a Nikon D7500 camera so the files loaded into LR are ".NEF" files.

 

Thoughts?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Thanks John, merged.

-------------------------------------
The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit Like a Pro books.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Based on other comments I've seen I uninstalled PS2021 and then LR Classic.  The layers still topped loading after about 20 images.

 

I tried a work around this morning.  I exported my LR images as .dng files and then tried to use Bridge 2021 to open these .dng files as layers in PS.  Same thing.  Maybe about 20+ were entered as layers into PS but the whole thing just stopped, the layers gone, and PS took me back to its Welcome screen.

 

As a result, I'm wondering if this is a PS2021 issue?  Is there some setting that needs be adjusted to add more layers?

 

BTW I'm trying to put 459 images as layers into PS.  I've done more in the past.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Rikk Flohr, I'm a little confused. Based on your link (as well as searching the forums) It seems like this has been an issue going back years. Wondering why it is that it hasnt been fixed yet? Do you guys need more information from us to help pinpoint the cause of the issue?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

What I can tell you from my experience is that there was this bug several versions back. Then there was a fix that I can confirm as of yesterday is still working on my latest version of both products. That isn't to say you have found a new bug or issue. But yes, it was broken and later fixed for me on MacOs

Author “Color Management for Photographers" & "Photoshop CC Color Management"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

To build on thedigitaldog, there was a bug report from June 2020 about Open As Layers:

https://community.adobe.com/t5/camera-raw-bugs/lightroom-classic-quot-open-as-layers-in-photoshop-qu... 

 

Adobe reported this as fixed in March 2021, and that bug report was closed as "Fixed".  Some users reported the problem was resolved (e.g. Bob Somrak), but there were also a couple of reports of continued problems.  This thread constitutes a new bug report.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

While waiting for Adobe to fix this, see here for a workaround that helped others before:

https://community.adobe.com/t5/camera-raw-bugs/lightroom-classic-quot-open-as-layers-in-photoshop-qu...

 

[Updated link]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Based upon the past state of the reported and fixed bug referenced here, this is what needs to happen going forward. 

If you can reproduce this bug at will, we need repeatable - reproducible steps to invoke the failure. These need to be detailed and step-by-step. Included with those steps we need complete OS, Hardware and PS/LR version number information.  With that we can attempt to reproduce and get a new bug logged with the team. 

That said if multiple persons on this thread can reproduce following the same recipe, we can open an investigation bug and get the information in front of the developers. 

I can relate that during the first go-around on this issue (fixed earlier this year), I was never able to sucessfully fail (is that a legal expression) using the supplied instructions in spite of many trials. It may be some work to coax out the details necessary to expose the issue. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Thanks Rikk Flohr.  In my initial post, I belived I provided my OS and PS/LR version number information.

As for "Hardware," what information do you need?  My son built my machine so I don't have a brand or model number.  Can you list what specific information you need?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 03, 2021 Sep 03, 2021

Copy link to clipboard

Copied

I see OS Version , PS Version Lr VersionGenerally, 

Additionally: 

CPU?

RAM?

Harddrive(s)

  • Size
  • Free Space
  • How Connected

Step-by-step reproducible instructions would all be great to have. 

 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

I found a solution that worked for me! Maybe worth looking into if you use more than one disk drive.  I have a built in SDD that I use for Windows and my applications (C:) and a 2TB HDD for everything (P:).  On PS21, the "Scratch Drive" was set to the smaller SDD (C:).  When I switched it to the HDD (P:), the Open as Layers in LR Classic worked perfectly.  My guess is that since I was layering 459 files, the SDD didn't have a enough space to act as the Scratch Drive and was cancelling the operation.

 

If you run two drives like I do, the switch to the larger drive to be the Scratch Drive is really easy:

 

Edit / Preferences / Scratch Drive - then select the larger drive to be the Scratch Drive.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

to: danless06

 

the "Scratch Drive" was set to the smaller SDD (C:).  When I switched it to the HDD (P:), the Open as Layers in LR Classic worked perfectly.

 

and, earlier

 

I run LR and PS on Windows 10, ver. 20H2 

 

So Windows, that brings up Windows paging file location vs Camera RAW CACHE location.

 

For optimizing LrC performance, it is recommended that the Windows paging file (by default on drive C, no reason to relocate, normally) and the Camera RAW CACHE, be on separate hard drives if possible. The two will constantly compete for read/wright on the drive (while in develop). Same goes for the PS scratch disk.

 

Also, the Camera RAW CACHE can take advantage of being on your fastest hard drive (as does the catalog as well).

Photos can be anywhere, no speed advantage for them

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Rikk Flohr,

 

Here a video of the issue. I dont know what steps youre looking for exactly. It doesnt happen every time, just like 1 out of every 3-10 stacks I try to open. Sometimes it seems like it happens more often than others. I will also say that I've had this same issue with two different computers (my old computer was a 2016 MBP, I cant remember all the stats). Additionally, before this session of editing, I had uninstalled both LR and Photoshop, and then rebooted my computer, and then reinstalled both.

 

My Stats:

Fresh install of Photoshop 22.5.0

Fresh install of "Adobe Photoshop Lightroom Classic" 10.4

MacOS Big SUr 11.5.2

Screen Shot 2021-09-04 at 1.20.28 PM.pngScreen Shot 2021-09-04 at 1.20.43 PM.pngScreen Shot 2021-09-04 at 1.20.52 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Here's my steps leading up to the issue:

 

  • i shoot images with a Nikon D750 camera in RAW.
  • I insert my memory card into my computer, select the files I need, and copy and paste them into a folder in on my iMacs SSD.
  • I use "add folder" to import the images into Lightroom.
  • I apply a preset to all images (exposure, contrast, lens profile, etc)
  • I go through all my images and rate the images I intend to use 3 stars. As I'm doing this, I make further adjustments to individual images (color correction, etc).
  • I then filter to show only images rated 3 stars.
  • I select the first group of 2-10 images and open them "as layers in photoshop".
  • I make edits in photoshop, then close the file (command W) and save as a tiff out of photoshop. The tiff is automatically imported into Lightroom. I rate the new edited image 5 stars and then move onto the next set of images.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

In your video, cannot make out what the 4 photos in LrC are. Perhaps a screenshot of that

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

It's just a set of four sequential RAW images. It's not really tied to those four images in particular. It happens all the time with different sets of images. Is there some info you're wanting about the image files? I can grab a screenshot next time I'm at my computer. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

Additionally. After that video, I closed the photoshop file without saving. Clicked "open as layers in photoshop" a second time, and it successfully loaded all 4 images into PS. This is usually how it works, it's rare that the same set of photos will fail to open as layers twice in a row. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Investigating

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Bug Investigating

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

Since upgrading to Mac OS10.4, I try to Edit In Photoshop several layers (3-10) and it stops at 2 with the base named "Load Layers".  Prior to this, I was able to Edit In PS as many layers as I wanted with no problems.

 

Is there something I'm missing?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

Moved to Lightroom Classic by moderator, because Open as layers only exists in LrC.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines