• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
22

P: Save Metadata To File doesn't always set metadata status to Up To Date

LEGEND ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

The Save Metadata To File command doesn't always update a photo's metadata status to indicate it is Up To Date. To reproduce:

 

1. Download and open this catalog in LR:

https://www.dropbox.com/scl/fi/jokv9a8pfsdc2z0jrqlu5/save-metadat-bug.2024.05.25.zip?rlkey=z833g3ek2...

 

2. In Library View > View Options > Grid View, check Cell Icons > Unsaved Metadata.

 

3. In the Library Filter bar, open the Metadata browser with the column Metadata Status.

 

4. Observe that all 32 photos have metadata status Has Been Changed as indicated in the Metadata browser and on the thumbnails.

 

5. Select all the photos and do Metadata > Save Metadata To File.

 

6. Observe that 32 photos remain with status Has Been Changed, and Finder / File Explorer show the files or their .xmp sidecards have their Date Modified set to "now", indicating that LR wrote the files (but I haven't tested if they've been written correctly).

 

Tested on LR 13.3 / Mac OS 14.4.1 and Windows 11.

Bug Investigating
TOPICS
macOS , Windows

Views

323

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , May 25, 2024 May 25, 2024

Setting status

Status Investigating

Votes

Translate

Translate
11 Comments
Explorer ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

Metadata save stoped working after updating to Lightroom Classic 13.3 on Mac OS 14.5.

 

Anyone with the same issue?

Votes

Translate

Translate

Report

Report
LEGEND ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

I observed that the Metadata > Save Metadata To File command saves the metadata to the file (or its .xmp sidecar) but LR 13.3 isn't updating the Metadata Status:

https://community.adobe.com/t5/lightroom-classic-bugs/p-save-metadata-to-file-doesn-t-always-set-met...

 

Select one of the files in your catalog that has Metadata Status of Has Been Changed. Do Metadata Status > Save Metadata To File. Does Finder show Date Modified has changed to "now"?

 

If it has, you're tripping over the same bug.  If it hasn't, it's a different bug and we should file a different bug report.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 25, 2024 May 25, 2024

Copy link to clipboard

Copied

Setting status

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Investigating

Votes

Translate

Translate

Report

Report
Explorer ,
May 28, 2024 May 28, 2024

Copy link to clipboard

Copied

tried 13.3 today and immediately had problems with reflecting metadata changes. I sent a raw file to PS for editing and then saved the psd file. Back in LrC, it would not reflect the edits that I made. Even asking it to update the metadata failed to reflect the edits. Had to remove the psd file from the catalog and then synchronize the folder. Very awkward, so I've reverted back to 13.2.

Votes

Translate

Translate

Report

Report
Explorer ,
May 28, 2024 May 28, 2024

Copy link to clipboard

Copied

had the same problem. I've reverted to 13.2. The generative fill removal tool isn't that great anyway.

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 01, 2024 Jun 01, 2024

Copy link to clipboard

Copied

Customer care about this issue says: "(...)

reading and writing the metadata in Lightroom Classic 13.3. We have checked and discovered that this is a known issue in the latest version of LR and the team had identified it. the team is working on it and this should be fixed in the next release of LR."
 
thank you
 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 01, 2024 Jun 01, 2024

Copy link to clipboard

Copied

Adobe acknowledged that bug in the Bugs section here:

https://community.adobe.com/t5/lightroom-classic-bugs/p-save-metadata-to-file-doesn-t-always-set-met...

 

(I see the post above had an incorrect link -- I corrected it.)

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 11, 2024 Jun 11, 2024

Copy link to clipboard

Copied

Bei Lightroom Classic 13.3.2 funktioniert es immer noch nicht. Es nervt !!!!

Votes

Translate

Translate

Report

Report
Community Expert ,
Jun 12, 2024 Jun 12, 2024

Copy link to clipboard

Copied

@Klaus-Jürgen32479191h6ra , When did you get an update to LrC 13.3.2, the latest update I see on Adobe Creative Cloud is 13.3.1.

Regards, Denis: iMac 27” mid-2015, macOS 11.7.10 Big Sur; ( also laptop Win 11, ver 23H2; LrC 13.3.1,;) 2TB SSD, 24 GB Ram, GPU 2 GB; LrC 12.5,; Lr 6.5, PS 24.7,; ACR 15.5,; Camera OM-D E-M1

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 12, 2024 Jun 12, 2024

Copy link to clipboard

Copied

sorry 13.3.1

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 12, 2024 Jun 12, 2024

Copy link to clipboard

Copied

LATEST

Sudenly my corcens gone to this subject and what's happening on Adobe https://youtu.be/rEbgh-q7RCc?feature=shared

Votes

Translate

Translate

Report

Report