• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

P: Searching for ancestor keywords in Keyword List panel shows incorrect results

LEGEND ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

Searching for ancestor keywords in the Keyword List panel shows incorrect results for descendant keywords.  The behavior broke somewhere between LR 10.4 and 12.2.1.

 

To reproduce on LR 12.2.1:

 

1. Assign the hierarchical keyword 1 > 2 > 3 to a photo.

 

2. In the Keyword List's Filter Keywords box, enter "1".

 

3. In LR 10.4, observe that all the keywords contained by keyword 1 are displayed, that a right arrow appears when you hover over 1, and the correct count is shown next to 3:

johnrellis_2-1680038339464.png

 

4. But in LR 12.2.1 observe that:

a) keyword 3 is not shown,

b) no right arrow appears when you hover over keyword 1,

c) an incorrect count of 0 is shown for keyword 2 (the panel normally never shows counts for ancestor keywords, only for directly assigned keywords), and

d) the triangle to the left of keyword 2 points down to indicate there are descendants displayed, but the descendants aren't shown:

johnrellis_3-1680038880717.png

 

See here for the original report:

https://community.adobe.com/t5/lightroom-classic-discussions/lrc-keyword-panel-list-not-showing-hier... 

 

 

 

 

Bug Fixed
TOPICS
macOS , Windows

Views

770

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Mar 29, 2023 Mar 29, 2023

Thanks for the report, I've merged the previous thread and cross-referenced to the new bug report. 

Status Acknowledged

Votes

Translate

Translate
9 Comments
Participant ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

Most of my keywords are orginized in hierarchies. This includes individuals in families, places, dates (by decades and years), etc. For a long time, when I search for a higher level in the hierarchy in the Keyword panel list, all images with that and the lower levels will show up. In the Filter bar, I have Keyword hierarchies selected. The filter bar is normally closed. In the past, that is how I was able to set hierarchy or flat for browsing or searching in the Keyword panel list. But now when I select a higher level keyword, when Keyword Hierarchies is selected, only that keyword is retrieved, showing it superior keywords. None of its subordinate keywords show up. Yes, I have double checked the Hierarchy status in the filter bar. Why is LRC not showing all subordinates keywords anymore? What has changed? I this a bug?

LrC release: 11.3.1

Votes

Translate

Translate

Report

Report
Contributor ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

I am using ver 12.2.1 on Windows 10.  Hierachical keywords work as they should.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

Something changed between LR 10.4 and 11.3.1 -- I filed a bug report:

https://community.adobe.com/t5/lightroom-classic-bugs/searching-for-ancestor-keywords-in-keyword-lis...

Votes

Translate

Translate

Report

Report
Participant ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

Well, I updated to version 12, but it still is not showing subordinates when I find a higher-level locality. If I browse through the list without querying, the hierarchies all show properly, but not when I do a query. It must still be a bug.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

Right, see my bug report.

Votes

Translate

Translate

Report

Report
Contributor ,
Mar 28, 2023 Mar 28, 2023

Copy link to clipboard

Copied

For some reason I am not seeing that behavior.

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 29, 2023 Mar 29, 2023

Copy link to clipboard

Copied

Thanks for the report, I've merged the previous thread and cross-referenced to the new bug report. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Acknowledged

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 13, 2023 Jun 13, 2023

Copy link to clipboard

Copied

Greetings all,

 

Updates for Adobe Photography products have been released.  The June 2023 updates contain a fix for this issue. 

If you do not see the update in your Creative Cloud Application, you can refresh it by hitting [Ctrl/Cmd]+[Alt/Opt]+[ R ].

Note: It may take up to 24 hours for your update to be available in your Creative Cloud app.

 

Thank you for your patience.

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Fixed

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 13, 2023 Jun 13, 2023

Copy link to clipboard

Copied

LATEST

I verified that the bug recipe now produces correct results (the same as in LR 10.4).

Votes

Translate

Translate

Report

Report