• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

P: Syncing Transform > Auto w just Upright Mode checked sometimes won't automatically recompute Auto

4 Votes
LEGEND ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

Normally, you can apply Transform > Auto to a batch of photos by syncing/copying with just the Upright Mode checked.  The Auto transform settings will be recomputed for each target photo.

 

But if you accidentally sync/copy Auto mode to target photos with both Upright Mode and Upright Transforms checked, Auto won't be recomputed on the target photos, and they'll display the Update button in the Transform panel.  This is as-designed.

 

If you try to correct the mistake by copying Auto mode again but with just Upright Mode selected, then Auto won't be recomputed on the target photos, and you'll have to click Update on them one by one.  This is incorrect. The photos have become "poisoned", and no use of Sync, Auto Sync, or presets will compute Auto automatically on the entire batch -- you'll have to click Update on each photo individually.  Too bad if there are hundreds of poisoned photos.

 

I've discovered just one way to clear the poisoned state other than clicking Update: Apply a preset that sets Upright Mode to Off, restart LR, and then apply a preset that sets Upright Mode to Auto.  Unfortunately, this workaround only clears the poisoned state for the currently selected photo in Develop, not on an entire batch.

 

The preset behaves differently before the restart than after, conclusively demonstrating this is not "as-designed" behavior.

 

Steps to reproduce (also see the attached screen recording):

 

1. Create a new catalog.
2. Import two photos A and B.
3. Edit A.
4. Make a preset Upright Mode Off with just Upright Mode selected.
5. Click Transform > Auto.
6. Make a preset Upright Mode On with just Upright Mode selected.
7. Cmd-click B in the filmstrip, do Sync, with Upright Mode and Upright Transforms checked.
8. Select B, observe Update is displayed in the Transform panel.
9. In Transform, click Off, then Auto, and observe Update is displayed (wrong).
10. In the filmstrip, click A and cmd-click B.
11. Do Sync, with Upright Mode only checked.
12. Select B and observe Update displayed in the Transform panel (wrong).
13. Apply the Upright Mode Off preset.
14. Apply the Upright Mode On preset, observe Update (wrong).
15. Apply the Upright Mode Off preset.
16. Restart.
17. Apply the Upright Mode On Preset, observe no Update (correct).

 

Tested on LR 11.4.1 / Mac OS 12.4.

Bug Investigating
TOPICS
macOS , Windows

Views

96

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jul 11, 2022 Jul 11, 2022

Updating status and adding bug number

Status Investigating

Votes

Translate

Translate
5 Comments
LEGEND ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

Update: Sync/Copy is neglecting to clear these settings when copying just Upright Mode:

I discovered one way of clearing the "poisoned" state and setting Upright to Off via the SDK:

 

        PerspectiveUpright = 1,
        UprightTransform_0 = "", 
        UprightTransform_1 = "", 
        UprightTransform_2 = "", 
        UprightTransform_3 = "", 
        UprightTransform_4 = "", 
        UprightTransform_5 = "", 
        UprightTransformCount = 6,
        UprightCenterNormX ="", 
        UprightCenterNormY ="", 
        UprightFocalLength35mm = "",

 

I had thought that a plugin could clear them to restore the ability to copy Auto.  But that doesn't work in LR 12.0.1 -- either my previous testing was flawed or something has changed in LR since then.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Updating status and adding bug number

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Investigating

Votes

Translate

Translate

Report

Report
Community Expert ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

I haven't tested this lately, and cannot do so just now: but with a previous LrC version I recall that setting AutoSync on with multiple images highltighted, and then re-clicking the desired Upright mode, did prompt an individual Upright recalculation for each of those images. Worth a try maybe.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Just now I tested 10.4 and rested 11.4.1, and unfortunately they behave the same: Once a photo has been "poisoned" as described above, using Auto Sync to set the Upright Mode to Off and then to Auto won't clear the poisoned the state.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 14, 2022 Dec 14, 2022

Copy link to clipboard

Copied

LATEST

Adding that in the latest Lightroom (12.1) this bug persists, but it can be solved by completely resetting the Develop settings on the selected images, and then synchronizing "Upright Mode" from your target photo.

 

Still not ideal, but not as complex.

Votes

Translate

Translate

Report

Report