• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Book module Photo Text template problem

Explorer ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

I am using an M1 Mac and the current LrC 12.0 (but the problem I am having has been for a long time). In the Book module I am having a problem that I have been tearing my hair out over. 🙂 In the Photo Text panel I created a text template and saved it with a name. I can select the template I created in the Photo Text panel. It works and does what I want. The problem is that I have to do this for every single page, one by one (select the page, select my photo text template, select the next page, select my template, etc.). If I select all the pages using Cmd-A and then select the template it will only work for the first photo so I still have to one by one select the template for each page.

 

Okay, now that I gave the basic problem above, let me give some more info and background. I also have a photo page template I created and have it selected in the Auto Layout panel. It works and does what I want. When I enter the Book module and have a bunch of photos I can click on Auto Layout using my photo page template and it creates the book the way I want pulling captions from the Caption field of the photo metadata. The problem is the text template I mention above is not used. I cannot find a way to have it already selected and used since before I do Auto Layout the Photo Text panel is grayed out. I want it to be used by default.

 

Now some further info and background. Up until a few months ago I had been using LrC on various Windows PCs for the last 11 years or so starting with Lr 4. I spent months in 2019 trying to get this all working properly with Auto Layout. I created my photo page template, photo text template, and with great effort got everything set up to work properly. As we all know, Adobe documentation, videos, Lightroom Queen, etc. info on the Book module while good at a basic level does not get into many of the nooks and crannies so I spent lots of time experimenting, searching on the internet, piecing clues together, etc. to get it all working the way I wanted.

 

Since 2019 I have created about a dozen photo books using my templates. Then a few months ago I switched to an M1 Mac. Mostly the transition has been fairly smooth. I have used LrC with no problem on it, but I had not made use of the Book module since the transition. Recently though I went into the Book module to start a new book. Even though months ago I had transferred my last Windows LrC catalog to the Mac I discovered that my book setup, templates, etc. were missing. 😞 I had mistakenly thought that all I had to transfer over was the catalog. Anyway, I have recreated it all on the Mac now after weeks of difficulty working on and off on it until I became so frustrated and took a break for a few days or a week. I had forgotten all the pieces and steps I had went through over a period of months in 2019. It was all working on my Windows PC for the last several years.   I have booted up my old PC and carefully examined the LrC book module while doing the same on my Mac.  All seems to be the same except for this one problem with the Photo Text template.

 

It seems the only part that I have not been able to get working is what I wrote about above with the Photo Text template. How can I get it to always be selected when I click on Auto Layout (particularly when I have the page layout I created selected? Somehow in 2019 I apparently figured it out, but after the last few weeks I cannot figure it out again. Help!

 

Lastly allow me to apologize to some of you who dislike rather long, detailed, carefully explained, precise questions. 🙂 I try to give detail and information in order to help the few people who actually know about this stuff so that they may be able to help me. If you need even more information then just ask.

TOPICS
macOS , Windows

Views

77

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

If you still have access to the PC (and you seem to do), why not copy the template over?

In the Presets section of Preferences, there is a Show All Other Lightroom Presets button that reveals a Lightroom Folder. Inside is the Auto Layout Presets folder. Copy these to the equivalent location on the Mac. 

 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Sean, thank you for your reply.  I have the template.  That is not the problem.  I copied it and my other templates from the PC a few weeks ago when I first discovered that the Book module on the Mac was missing the templates that I created in 2019.  It took me awhile to find the templates on the PC, but I found them and got them on the Mac.  Please reread paragraph 1 and 2 to understand the problem I am asking about.  And then this paragraph:

 

It seems the only part that I have not been able to get working is what I wrote about above with the Photo Text template. How can I get it to always be selected when I click on Auto Layout (particularly when I have the page layout I created selected? Somehow in 2019 I apparently figured it out, but after the last few weeks I cannot figure it out again. Help!

 

If I have been unclear about something or you need further info then please ask me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

I read a few times, but it wasn't clear that you had copied them over. It sounded like you were using a recreated version that wasn't quite the same. 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

For the sake of trying, I created an auto layout with a custom Text Template, and it applies to all photos in the layout. What I can't get is it to be the caption automatically. Each change requires a Clear Layout and then the Auto Layout to force a full refresh. 

 

Without actually seeing the one you're using, I can't really help. 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Okay... Command Option A allows me to select all text cells and change the Photo Text to Caption. 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2022 Oct 28, 2022

Copy link to clipboard

Copied

I am sorry that I was unclear above.  When I discovered the templates I had created in 2019 on my PC were not on my Mac I went back to my PC, found them, and copied them to my Mac.  When I said I "recreated it all" I should have been more clear.  I just meant I had recreated the Book environment I had earlier on my PC.  Not that I had started from scratch and made new templates.  While it sounds like a simple thing to just copy the templates, it took quite awhile to figure out why the templates were missing.  I mistakenly thought that copying the catalog was all I needed to do because it had everything in it.  I never realized that there were lots of other miscellaneous files around that might need to be copied to.  I did not even know they existed or where they existed.  Since Lr 4 in 2011 I have updated to new PCs several times and I always just copied the catalog.  Even though before 2019 I had made several books I only used the included templates so that is why I never got into any trouble.  In 2019 though I spent lots of time creating new templates and figuring out how to get them all working.  Since then I have made about a dozen books using them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2022 Oct 28, 2022

Copy link to clipboard

Copied

Today I unpacked my old PC, updated to LrC 12.0 since it had LrC 11.? (left on it from the last time I used it before switching to the Mac a few months ago), and started LrC up on the PC and the Mac, side by side.  I spent a long time in the Book module on both using the same set of photos.  Once again all looked the same except that on the PC there is no problem with the Photo Text template being automatically used, but on the Mac it does not get automatically used.  See my original post for the details.

 

I went into the Presets section of Preferences and clicked on the Show All Other Lightroom Presets button on the PC and Mac and looked at the Auto Layout Presets, Text Style Presets, and Text Templates folders on both computers.  Both had my templates in the proper folders.  And, as I have already said, they all appear on the Mac and work, but the Photo Text template does not get used automatically, although it does on the PC.

 

After lots more frustration I decided to uninstall LrC on the Mac because I was wondering if there was some sort of corruption problem or something else.  After I uninstalled I then deleted the leftover folder with all the presets/templates.  I then reinstalled LrC using the CC app.  Then I copied my 3 templates to the proper folders.  Unfortunately, the same problem still exists.  I am now thinking this is a bug in Mac LrC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 28, 2022 Oct 28, 2022

Copy link to clipboard

Copied

If you can show the difference between the two, then use the Bug forum to report it. Do check the bug reporting post first to see how they need the post laid out. 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

I have done more experimenting.  See below.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

Let's try to condense this down to the most basic question. I have spent almost 3 hours today trying to figure out what is going with LrC. It seems like there must be a way to link a custom Text Style Preset to a custom Photo Text and custom layout. I say that because when you create a layout preset in the Auto Layout panel you select the Text Style Preset you want to use. Therefore when you select that layout preset it also automatically uses the Text Style Preset -- they are linked together. But, there seems to be no way to link the Photo Text preset to them. When you select the custom layout preset and click Auto Layout it will also use the Text Style Preset that is linked to it, but the Photo Text preset is not used. And yet using the 2019 ones on my PC it all works properly.

 

I did a test on both the PC and Mac today and created 3 new test presets for the layout, Text Style Preset, and Photo Text preset. I verified that the PC and Mac both work the same in this case. The Photo Text preset is not automatically used with Auto Layout on both. But, the 2019 ones on the PC do work. That makes me think there must be some hidden, forgotten way I linked it to the others in 2019. Anyone know?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

The Auto Layout Presets are text files. Open the old ones and the new ones. Compare them. The difference between them should give you a clue. 

 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 31, 2022 Oct 31, 2022

Copy link to clipboard

Copied

LATEST

I finally got it working properly on the Mac!

 

I spent several more hours working on this. I rewatched several videos about the Book module by Julieanne Kost (Adobe), couple of videos by other people, reread the Adobe documentation, searched on the internet about the problem and read several more websites which had Book module info. Also, I found some forum posts on various websites about other problems. Watched and read it all. None talked about the Text Style Preset and how to use it though and link it up for Auto Layout.

 

I then spent another couple of hours once again going through everything on both my Windows LrC and my Mac LrC. Then I decided to concentrate on trying to set up new templates and presets to test all this some more. Finally, just as I had done in 2019, I on my own stumbled on the magic way to get it set up properly. Hurray!

 

I am working on writing detailed notes to myself so that in the future I can get things set up properly. Not just for this set I made in 2019 for the books I have been making, but to allow me to create news ones in the future if I want to. To get things properly set up in the Book module is complicated, confusing, convoluted, and not intuitive. I am sure that in a few months I will have forgotten it again. Along with the detailed text instructions, I think I will need about 8-10 screenshots to illustrate it all and put it all in a document that I will save.

 

Of course, it would be even better for Adobe to properly document their own product. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines