• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't delete publishing service

Community Beginner ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

I have several items that are listed in Publishing services as missing plug-in. When I try to remove them I get the following:

Can't delete the published collection

An internal error has occured: ?:0:

attempt to index field

'publishSettings' (a nil value)

 

I'm using the latest 12.3 release of Lightroom Classic on iMac (2015) with latest OS

Thanks,

Lyle

TOPICS
macOS

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

Have you tried reinstalling the plugin? And this would be withing the plug-in manager.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

It’s not exactly a plug-in I think. They are all some sort of artifact from opening my SmugMug services and making changes to the folder hierarchy with SmugMug. I posed the question to SmugMug support but no answer yet. They refer, I believe to folders in SmugMug. No matter what I do I can’t get rid of them. I will look through the Lightroom area on my hard drive to see if I can find any reference to them as plugins

Thanks,

Lyle

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

The Smugmug publishing service uses a Smugmug plug-in. You should see it listed in the Plug-in manager, See if an error is stated in the manager. Or for that matter, if the plug-in is missing.

 

And yes, those are folders on the Smugmug site (folders, catalogs, etc)

 

and see:

https://www.smugmughelp.com/en/articles/327-upload-from-lightroom

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

To build on GoldingD's reply, your screenshot shows that LR thinks the SmugMug plugin isn't installed and enabled:

johnrellis_0-1682271893273.png

 

Without that plugin installed and running correctly, LR will get very confused.  Troubleshooting steps:

 

1. Do File > Plug-in Manager.

 

2. Select SmugMug in the left column.

 

3. In the right column, in the Updates panel, click Check Now to ensure you have the latest version installed (version 3.4.3.0).

 

4. If the Status panel indicates the plugin is disabled, click Enable.

 

5. In the Plug-in Author Tools panel, if there are diagnostic messages, click Save Diagnostic Log To File and post the contents of the file here.

 

johnrellis_1-1682272340592.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

I tried updating to new version and get this:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

Hmm, it shouldn't be trying to use that folder. Please do File > Plug-in Manager, select SmugMug, make the Plug-in Manager window big enough to show all the panels, and post a screenshot of it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

I hope this helps

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 23, 2023 Apr 23, 2023

Copy link to clipboard

Copied

That confirms that somehow the plugin got installed in the Adobe Lightroom Classic app folder, which isn't where plugins should go.  To straighten this out:

 

1. In File >Plug-in Manager, select SmugMug, and in the Status panel, click Show In Finder.

 

2. In Finder, delete SmugMug.lrplugin -- you'll probably be prompted for your password.

 

3. Download the latest version of the plugin from here:

https://www.smugmug.com/software-updates/lightroom-plugin/latest 

 

4. In Finder, double-click the downloaded .zip file in Downloads to unzip it.

 

5. Open a second Finder window, do the menu command Go > Go To Folder, and copy/paste this line into the Go To Folder window:

 

~/Library/Application Support/Adobe/Lightroom/Modules

 

(That folder is normally hidden.)

 

6. Drag SmugMug.lrplugin into the Modules folder.

 

7. Restart LR, and SmugMug should be automatically installed.

 

8. In File > Plug-in Manager, verify that the Status panel shows the plugin as enabled and there are no diagnostic messages.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

Thanks for your expert guidance. I now have the plugin in the right folder and it is updated.

I stil can't get rid of any od the "missing" plugins that are listed with the names of my SmugMug folders. Is this a SmugMug issue? I have sent them the info and they responded but no solutions yet. I was reorganizing my SmugMug folders and galleries. Here attached is what shows in the Publishing services in Lightroom. The the error I get if I try to delete.

Thanks,

Lyle

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

quote

Thanks for your expert guidance. I now have the plugin in the right folder and it is updated.

I stil can't get rid of any od the "missing" plugins that are listed with the names of my SmugMug folders. Is this a SmugMug issue? I have sent them the info and they responded but no solutions yet. I was reorganizing my SmugMug folders and galleries. Here attached is what shows in the Publishing services in Lightroom. The the error I get if I try to delete.

Thanks,

Lyle

 


By @lyleb59349507

1. Have you restarted LrC after installing/updating the plugin?

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

I just noticed in your screenshot that all the lines with "(missing plug-in)" appear as top-level instances of publishing services:

johnrellis_0-1682377452455.png

 

Did you make a new instance of the SmugMug publishing service for each new published collection?  (E.g. by right-clicking SmugMug and doing Create Another Publish Service.)

 

Normally, if a plugin is missing, all the collections in the instance would look like this, indented under the publish service instance:

johnrellis_1-1682377660367.png

 

Regardless, the SmugMug service(s) in your catalog look very sick, and I think your only hope is to get SmugMug support to help you.

 

I recall someone else with similar symptoms a few months ago, either here or at Lightroomqueen.com, but unfortunately, I can't find that thread. (I don't recall seeing a final answer about whether the problem was sorted out.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 27, 2023 Apr 27, 2023

Copy link to clipboard

Copied

I just tried a little test and checked a different catalog and also created a new catalog. In both cases the false entries are not visible. They only occur in my main catalog that I have been using for over a year. Would you recommend creating a new catalog and importing everything to it and then deleting the current trouble maker?

 

I have been working with SmugMug technical support and they can't figure it out so far.

 

Thanks,

Lyle

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 27, 2023 Apr 27, 2023

Copy link to clipboard

Copied

"Would you recommend creating a new catalog and importing everything to it and then deleting the current trouble maker?"

 

That would likely get rid of the corrupt published collections, but it would get rid of any remaining uncorrupted ones as well.  Worth a try.  It's a little simpler and faster to do File > Export As Catalog.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 27, 2023 Apr 27, 2023

Copy link to clipboard

Copied

Thanks for your feedback and all the time you spent. I think this software manifestation will go unsoved.  I've done several catalog File> Exports As Catalog and feel comfortable proceeding in that direction.

Thanks,

 

Lyle

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 06, 2023 May 06, 2023

Copy link to clipboard

Copied

LATEST

I haven't had a chance to do a new catalog yet. I took the advice of most lightroom experts and put all of my photos from 6 different catalogs into one master and it's gor 600,00+ photos. I have to think this through before I try a new master catalog. I have to get rid of a lot of unneeded photos and duplicates. I wish Lightroom had a tool to look for duplicates.

Thanks so much for showing me alot of Lightroom info.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines