Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Change language in Lightroom

New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

I installed Lightroom 6.0 with Sweedish text but want to change to English. I follwed the description given by Adobe on how to change language, but it does not work.

I also tried to reinstall the product. Then I picked English, but still got Sweedish!

Adobe says:

Lightroom can display menus, options, and tool tips in multiple languages.

  1. 1.      Choose Edit > Preferences (Windows) or Lightroom > Preferences (Mac OS).
  2. 2.      In the General tab, choose a language from the Language pop-up menu.
  3. 3.      Close Preferences and restart Lightroom.

The new language takes effect the next time you start Lightroom.

TOPICS
How to

Views

28.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 18, 2017 Sep 18, 2017
This solved the same problem for me.(W7) Lightroom version: CC 2015.12        In Lightroom set the language to English (Suppose you have already even though LR is still in Swedish)        Go to Control panel        ‘click’ Clock, Language, and Region        ‘click’ Region and Language        A separate window should pop up and there should be 4 tabs, ‘click’ the ‘administrative’ tab        The second section should be about Language for non-Unicode programs        ‘click’ ‘Change system locale…’...

Likes

Translate

Translate
LEGEND ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

I think it is because of the language you have selected for the OS, Swedish. If you set the OS to be English then LR can be in English.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

No, this is not the case, the OS language is not Sewdish. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

You can change the language from the Lightroom preferences, refer the below screenshot.

Lr language.png

Regards,

Mohit

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Thanks, but NO, this suggestion was the first I tried, it I does not functjon.

Kind regards Erik

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Just to double-check, did you restart LR after changing the language in Preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

Yes I did, I tried several times.

Erik

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

If you change another setting this setting in Preferences > General:

     "Treat JPEG files next to raw files as separate photos" / "Ha JPEG-filer intill Raw-filer som separato foton"

does the change stick after restarting LR?  If the change doesn't stick, that indicates an issue with storing preferences in your installation.  Which version of Mac or Windows?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2017 Mar 08, 2017

Copy link to clipboard

Copied

When I changed from Swedish to English language under Preferences, the change was not saved -  when opening Preferences again Swedish was still the language,

But, when I at the same time opened Catalog settings - making no changes - but clikking the OK button, the language change was stored and took effect next time I opened the program.

Suggestion: Have an OK button on the general page under Preferences to save/make sure settings take effect? 

(I also clikket the      "Treat JPEG files next to raw files as separate photos" / "Ha JPEG-filer intill Raw-filer som separato foton".)

Erik

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 09, 2017 Mar 09, 2017

Copy link to clipboard

Copied

I think there's some problem that's specific to your Lightroom installation. Normally, after you change the language in the dropdown, all you need to do is restart LR.  You don't even need to close the Preferences dialog.

I don't recall seeing similar reports in the last many years -- I think yours is the first. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2018 May 05, 2018

Copy link to clipboard

Copied

Guys, you are absolutely brillant! I had the same problem. I have asked for help to Adobe. The lady stayed a long time trying to help me, but nothing worked. Lightroom CC 2018 was still in French, no way to change it to English. She said I had to change my computer's system to English. No way, I am not the only person to use the PC and changing the system language would bother the others and who knows all the consequences for the other installed softwares.

And there it is:

"Treat JPEG files next to raw files as separate photos"

It works!!! I have been looking for a solution for long weeks. Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

Well I checked and unchecked I "Treat JPEG files next to raw files as separate photos"

and after a restart it was English and "Treat JPEG files next to raw files as separate photos" was checked again. I unchecked it again and now it is in English and that check is off... wow

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2017 Sep 18, 2017

Copy link to clipboard

Copied

This solved the same problem for me.

(W7) Lightroom version: CC 2015.12

  1.        In Lightroom set the language to English (Suppose you have already even though LR is still in Swedish)
  2.        Go to Control panel
  3.        ‘click’ Clock, Language, and Region
  4.        ‘click’ Region and Language
  5.        A separate window should pop up and there should be 4 tabs, ‘click’ the ‘administrative’ tab
  6.        The second section should be about Language for non-Unicode programs
  7.        ‘click’ ‘Change system locale…’
  8.        Change the Current system locale: English (United States)
  9.        Restart the computer
  10.    LR should now display menus etc. in English

Hope it works for you also

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

LATEST

al you have to do change language to yours reboot your apps than change to English en reboot.

al done

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines