Edit in Photoshop Issue [How to launch Intel version of PS instead of M1 version via "Edit In"?]

Advocate ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

I have some extensions and plug-ins that require Photoshop to run under Rosetta in my new Mac Studio. This is not an issue since I set Photoshop to run in Rosetta (in the Get Info panel for the app). I can launch Photoshop and it runs fine and I can use my extensions and plug-ins. The issue is that when I am in LR Classic and use the external editor option, that is, select an image and use the Edit in... command, LR launches the standard M1 version of Photoshop, but not running in Rosetta. When this happens, my extensions and plug-ins do not load (as expected). How can I force LR to launch PS under Rosetta? Can it be done?

TOPICS
macOS

Views

79

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 25, 2022 May 25, 2022
I haven't tried this, but I believe the following might work: 1: Make a copy of the Photoshop application. Call it 'Photoshop Rosetta' for example. 2: Select the copy, type Cmd-i to get the Finder info dialog and check the box to always open this app in Rosetta. See https://www.macworld.com/article/338843/how-to-force-a-native-m1-mac-app-to-run-as-an-intel-app-instead.html 3: Add 'Photoshop Rosetta' as your secondary editor like @johnrellis  suggested.

Likes

Translate

Translate
LEGEND ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

Try defining a custom external editor that references Adobe Photoshop 2022.app:

 

johnrellis_0-1653450168212.png

 

The menu Photo > Edit In will show two entries for Photoshop -- use the ".app" one:

 

johnrellis_1-1653450218909.png

 

I don't know if this will work, but it's easy to try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

Thank you very much for the suggestion. Unfortunately, it did not work, as it launched PS in the "native" (non-Rosetta) way. It seems LR just bypasses or ignores the setting in the operating system (Get Info) panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

Launch Photoshop first so it is already running in the background in Rosetta mode. 

When you launch Lightroom now, it should pass the file to the open instance of PS (Rosetta) rather than open its own instance. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

Rikk, you are right, that is a good workaround. I do use it - but I often forget to do it because I am so used to just letting LR launch PS! Muscle memory and all that. That is why I was hoping there was a setting (or preset) in LR that would help. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

I haven't tried this, but I believe the following might work:

1: Make a copy of the Photoshop application. Call it 'Photoshop Rosetta' for example.

2: Select the copy, type Cmd-i to get the Finder info dialog and check the box to always open this app in Rosetta. See https://www.macworld.com/article/338843/how-to-force-a-native-m1-mac-app-to-run-as-an-intel-app-inst...

3: Add 'Photoshop Rosetta' as your secondary editor like @johnrellis  suggested.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

LATEST

Excellent! That worked (the copy of the application has to be in the same folder as the original, for it to work).

Thank you very much, I really appreciate your help and that of @johnrellis and @rikk flohr.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines