• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Error exporting images using LRMogrify with Lightroom Classic

Explorer ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

I am using the latest version of LRMogrify with the latest version of Lightroom Classic and I get this error message 90% of the time when I export which basically says "./LRMogrifyExportTask.lua:85: attempt to concatenate field 'LR export bitDepth' (a nil value) (1)".

 

Has anyone else come across this issue and more importantly a fix?

I am using an M1 Mac running macOS 12.6.

I emailed the developer but their emails have been shut down.

 

Any help would be fantastic. Thanks

 

 

 

Screenshot 2022-09-26 at 3.26.14 p.m..pngScreenshot 2022-09-26 at 2.52.35 p.m..png

TOPICS
macOS

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

Are you trying this in a publishing service? Then this is a known issue. Mogrify should work in normal export, however. If not in a publishing service, then what image type and bit depth do you use for export? The error mentions a problem with the bit depth of the exported image.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

Hi Johan,

Thanks for the reply! I am exporting just to the desktop actually and exporting as a jpg which has to be 8bit but all the RAW files were shot in 16bit which might be causing the issue but I don't get the error all the time so not sure if this is the cause or not?! it's very frustrating as it's such an incredibly useful plugin!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

LATEST
quote

Hi Johan,

Thanks for the reply! I am exporting just to the desktop actually and exporting as a jpg which has to be 8bit but all the RAW files were shot in 16bit which might be causing the issue but I don't get the error all the time so not sure if this is the cause or not?! it's very frustrating as it's such an incredibly useful plugin!


By @peadarotuathail

 

No, the bit depth of the original image should not be the problem. Mogrify adds something to the exported image, so it only deals with that image, not with the original. I hardly ever use Mogrify2, but I do have it installed and when I tried it on my MBP M1 Max and Lightroom Classic 11.5 recently it worked fine. Maybe just luck...

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines