Fullscreen is black, "before" view doesn't render an image, and other problems... but ONLY on one of two monitors!?

New Here ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

HI all, I'm running the 7.0.1 release of Adobe Photoshop Lightroom Classic CC with Camera Raw 10.0. My operating system is Windows 10 Home 64-bit (10.0, Build 14393). My CPU is an Intel Core i7-6700K @ 4.00GHz. I have 16GB RAM and a water cooled GTX 980ti. I just upgraded one of my two monitors to a higher resolution, higher frame-rate display, and some Lightroom features are malfunctioning.

Monitor on the left: 1920x1080 ASUS VE247H LED @ 60Hz - plugged into GPU HDMI
New monitor on the right: 2560x1440 ViewSonic XG2703-GS @ 165Hz - plugged into GPU Display Port

Problems:

On the new monitor in the Develop module with GPU acceleration enabled, pressing "F" for fullscreen turns the entire screen black. I briefly see text that says "Loading..." before it goes black.

Pressing "\" to view the before image removes the edited image from view and shows the gray background color that I have selected in Lightroom. The text "Before" is displayed in the upper-right corner of the image viewing frame. https://i.imgur.com/dPGd14I.png

1:1 module views such as the Detail zoom area tool and the Transform > Guided Upright Tool image overlay do not display an image in the view, but sometimes it's just heavily pixelated. Weird, right? https://i.imgur.com/Hd16voY.jpg

Thumbnail vs Develop display, images have slightly different tones. The thumbnail colors are a bit muted and the hue/saturation/luminance seems to be a bit off.

Disable GPU acceleration, you say? The problem isn't fixed. Fullscreen is still black, and the Before view is still blank. But, strangely, the Before view renders a shadow around where the image would be. https://i.imgur.com/Tipcxlz.jpg

Here's where it gets frustrating. ALL of these problems go away when the Lightroom window is on my left monitor, one of my older ones. What gives!?!? Both monitors are plugged into my GPU. HELP!

Views

797

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Nov 01, 2017 Nov 01, 2017
The left monitor is a $100 crappy TN panel at 1080p, with awful color and bad contrast, and the color varies based off of viewing angle.The right monitor is a $700 IPS display at 1440p with accurate color at just about any reasonable viewing angle. It is a world of difference. I bought it almost exclusively for photo editing, so I'm not about to discard it and use my smaller, old, uncalibrated cheap monitor.Disable GPU acceleration, you say? The problem isn't fixed. Fullscreen is still black, an...

Likes

Translate

Translate
Adobe Community Professional ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

First - thank you for the great description of your physical set up. Second... it's hard to reproduce the problem. Forgive the obvious question here but if the problem doesn't exist when you have the Lr window on your left monitor why is that not an acceptable scenario?

What happens if you disable Graphics Processor?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

The left monitor is a $100 crappy TN panel at 1080p, with awful color and bad contrast, and the color varies based off of viewing angle.

The right monitor is a $700 IPS display at 1440p with accurate color at just about any reasonable viewing angle. It is a world of difference. I bought it almost exclusively for photo editing, so I'm not about to discard it and use my smaller, old, uncalibrated cheap monitor.

Disable GPU acceleration, you say? The problem isn't fixed. Fullscreen is still black, and the Before view is still blank. But, strangely, the Before view renders a shadow around where the image would be. https://i.imgur.com/Tipcxlz.jpg

Edit: I just reinstalled Lightroom and made a new catalog to try again with a brand new photo import. The exact same problem persists.

Edit 2: I fixed it! Turns out it was a color profile issue. Here's how I fixed it. These steps are for Windows 10.

Go to Display Settings, either by searching in the start menu or by right clicking on the desktop wallpaper. Scroll to "Advanced display settings." Scroll to "Color management." Select the monitor that is being weird in the dropdown. Click the check box that says "Use my settings for this device." On the lower left of the window, click Add. Scroll down to the ICC Profile menu and find the sRGB profile. Click okay, and then Set as Default Profile.

You're done! That's all it is!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

Thanks dude, this was exactly my problem. Would have never thought to try what you did. Was thinking either my monitor or video card was a lemon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

This fixes the issue, yes. However, you should calibrate your monitor with a Spyder or alike to have reliable color and brightness rendering.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2022 Apr 02, 2022

Copy link to clipboard

Copied

LATEST

Thank you very much, i had same problem here, all thumbnails in my monitor wasnt' showing, just on my second screen (that's a TV), so i did the ''color management'' step and now its working again! Thank you thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines