Lightroom Classic v11.4 import slow on macOS

New Here ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Using Mac OS Monterey.  Lightroom Classic 11.4 very slow to import photos.

 

Thanks,

 

Matthw Kraus

 

 

{Thread title updated by moderator}

TOPICS
macOS

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Hi Matthew,

 

Thanks for reaching out. We're sorry for the trouble with Lightroom Classic. I'll need more information to help you with this.

 

Could you please share the specific version of the macOS Monterey? Where are the original images stored on an internal or an external drive? Are you using Add, Copy or Move? Where are you trying to import to? How many images are you trying to import at once?

 

What type of preview are you creating while importing images in File Handling?

SameerK_0-1658412048025.png

 

Could you please share a screenshot of the import settings you are using? Have you tried any troubleshooting steps?

 

Please try the import operation with the following suggestions:

  • Copy images on the internal drive manually using the File browser & use Add while importing images.
  • Try using embedded & sidecar or minimal when importing images.
  • Please update Lightroom Classic v11.4.1 is now available

 

Let us know how it goes,

Thanks!
Sameer K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2022 Jul 30, 2022

Copy link to clipboard

Copied

Here is screenshot of my workflow.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Hi Matthew,

 

Thanks for sharing this.

You are copying images from an external source to an external destination with a metadata preset applied during import.

Please try these suggestions

  • Import images from the external source to the internal drive as a test.
  • Select 'Move To' > Import images from the internal drive to the external drive.
  • Try the above workflow with the metadata preset & without the metadata preset.

 

Let us know the results,

Thanks!
Sameer K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Thanks for staying with me as I go through the process.

 

When I connect my card which has about 200 grayed out images that were previously imported plus 20 unimported images ready to import, it takes quite a long time for th thumbnail previews of the 220 images to show up, before I even try and iport them.

 

Thanks,

 

Matthew Kraus

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

LATEST

When I connect my card which has about 200 grayed out images that were previously imported plus 20 unimported images ready to import, it takes quite a long time for th thumbnail previews of the 220 images to show up, before I even try and iport them.

 

Thanks,

 

Matthew Kraus

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 21, 2022 Jul 21, 2022

Copy link to clipboard

Copied

Perhaps you can share more information as to your process and computer setup. I have a similar platform and not experiencing such issues.

warmly/j

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines