Lightroom hangs when importing from SD cards

New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Since a while I can not import pictures from SD cards anymore (I have imported +120000 pictures the last years and never had an issue).

With an SD card inserted into the SD card slot of my PC Lightroom hangs after the import screen has apperared and the previews were generated. If I open the import without SD card everything is Ok and the import works fine from other devices like the internal hard disks. When I start without card and then put one into the card reader slot the program generates the previews and then hangs.

Any ideas what is wron?

Thanks

Peter

Views

1.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

There is a known issue when importing via the 'Devices' segment import dialog. Try selecting your SD card from the 'Files' segment as shown below.

Note that the alternative shown does not auto eject.

import.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Thank you Ian. I tried this but LR hangs before I can switch to the files segment. Even if I am very fast in clicking the files segment it hangs a short moment later.

I use LR since version 1 and never had problems.Very frustrating issue....

Peter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Try putting the SD card into reader after the import window has open rather than before, avoid selecting as a Device.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Looked like it works at first. When I stick in the card reader everything seems normal for a while. But then it ends up with the program hanging again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Looks like the bug is biting you harder than other.

Best work around I can suggest is to copy the files from your SD to the correct location on computer using OS Copy or Drag and Drop then use the Add option in import window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

That is how I do it since a few weeks. But this is quite annoying and no acceptable long time option for me.

I wonder what had happend to bring this bug into a system that was stabile running for years. I did not do any hardware changes and no LR update that could have caused the issue. I updated LR today and it did not help.

But anyway - thank you very much for your help, Ian!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

My particular problem with an internal card reader (Win10 PC) is that once Lr (v.7.3.1) acknowledges the card Lr won't let it go.  In other words, Lr won't eject it and if I ask the OS to eject it it reports as "in use". If I physically eject the card Lr will hang, and the only option is to close Lr (including the time it takes to back up the library).  It makes no difference if I select the files for import via 'device' or otherwise.

I understand this being a Windows hardware problem with some internal readers, but why can't Lr simply disengage from using the device first before attempting to eject it? At least then I can leave Lr open for reasons required, and use the OS to eject the card.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

As Ian has explained, this is a known issue and Adobe is working to fix it. My experience is that I can import the images and begin editing them, but Lightroom will eventually crash. After I restart Lightroom I can then work with the images without further problems. My solution has been to use Windows Explorer to copy the images from the card to a folder on my hard drive. Then I use the Add option in the Lightroom import dialog to import that folder to Lightroom. As has been indicated, this isn't as convenient. But until the problem has been resolved, it is much more convenient than having Lightroom crash in the middle of an editing session. When the problem has been acknowledged, and a temporary workaround has been suggested, it seems reasonable to accept that workaround rather than to complain that it is unacceptable. Yes, it's inconvenient and not part of a "normal" workflow, but at least Adobe is offering suggestions to assist while they are evaluating the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

Interesting...but not useful...."[JimHess]....it seems reasonable to accept that workaround rather than to complain that it is unacceptable" .

Though I appreciate the help of others very much there is however the possibility to accept a workaround and complain despite this.

I said " But this is quite annoying and no acceptable long time option for me" and stand by it. It is normal that Adobe cleans out bugs - I did not pay for bugs since 2007 - it is their business to clean out bugs. (and would be normal to give direct support - by the way - I do not find an official Adobe support channel for me as a single user). So what shall I do? Sit and wait and don't complain?

Cheers

Peter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

You DID complain. Adobe has acknowledged that there is a problem. Adobe has indicated they are working on the problem. There has been a "reasonable" workaround to use in the meantime. Is there any reason for you to continue to complain? I don't think so. I don't work for Adobe, have no connection to the company whatsoever. But I see no reason to keep dragging complaints like this along when the problem has been acknowledged.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

It is totally inappropiate for you to criticize me. I did not make a big show here just stated that this "workaround" is not acceptable as  A LONG TERM OPTION for me. And it is not!

It is not your business to comment on that.

End of discussion for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2018 May 19, 2018

Copy link to clipboard

Copied

It is not a long-term option! Adobe has acknowledged there is a problem that they are trying to fix, and have offered A SHORT TERM option for you to use until the update is released that will fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

Just to say it: it is mid of August and the problem is still unsolved. I still can not import from SD cards. I have my camera mounted outside at a telescope and shoot hundreds of images that I have to select and copy manually. Frustrating and inacceptable for a professional product.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2018 Oct 20, 2018

Copy link to clipboard

Copied

Oh well. It is now almost end of October/2018 and this issue is still there. So yes, this is unacceptable and to be honest Adobe is really testing customers patience. LR is a slow and buggy software and it's been like this for years. And this bug is just one more thing. I've just bought a Fuji XT-3 and I am terrified about how bad the raw conversion is when compared with most converters out there. The only reason I still use it is moving away would be a major effort for me.

As a paying customer (for years) I have the right to complain as much as I want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

LATEST

3 March 2022

I have the identical problem as peterm4847186 posted here in 2018!   Has there not been a fix for this in Lr Classic in four years? 

Using Adobe Bridge, the card reads and downloads the files as it should, but this doesn’t enter it into the Lr catalog! 

What am I missing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines