• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

LR was unable to prepare the selected file

Explorer ,
Apr 24, 2020 Apr 24, 2020

Copy link to clipboard

Copied

After the lastest update for LR Classic V9.2.1 Windows version, I am unable to use any plugin's. PS, Affinity, Nik, Topaz ...all give me this error "Lightroom was unable to prepare the selected file at..It will not be opened. All plugins were working prior to update.

 

How do I fix this error?

 

Thanks

Cindy

 

 

TOPICS
Windows

Views

5.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 05, 2020 May 05, 2020

It was an issue with the external drive. Copied files from bad drive to new WD External drive, renamed drive letter to same as the old, opened LR and pointed catalog file to new location --- opened a photo > right click > Edit in > Dfine....WORKED, tested again usin Affinity photo and a different file...worked fine that time.

 

So the issue was with the external drive and nothing to do with LR or the external editors. Thanks everyone for helping and pointing me in the right direction to figure it

...

Votes

Translate

Translate
LEGEND ,
Apr 24, 2020 Apr 24, 2020

Copy link to clipboard

Copied

Using smart previews? If so, is the hard drive the original photos are on connected? On?

 

P.S. apparently using attachments on this community site is even worse than previous, try to not attach files, just paste the image in a reply.

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

External hard drive is connected, all programs work seperate from Lightroom using the external drive, just when you try and right click on the photo in LR > select Edit > select which program I want to edit in....I get this error. External drive has all the correct permissions so it's not a read/write issue...I did double check that. It doesn't matter which plugin I try and use - Affinity Photo, any of the NIK collection like Color Efex, Topaz DeNoise....none work.

cindyh83512444_0-1588523631067.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 25, 2020 Apr 25, 2020

Copy link to clipboard

Copied

Corrupted file? If that's the case, you need to find a backup, or the original on the camera card.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

Files are not corrupt -- External hard drive is working fine, double checked that and even ran a scan to verify. I get this error no matter which photo I try and open - whether I try from my desktop or the external drive....could it be the LR catalog is corrupted?

cindyh83512444_0-1588523850580.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

1. Can you accomplish a simple export, without editing in external editor? Can you simply export to a TIFF file?

 

2. After that export, outside of Lightroom Classic, can you use one of those third party programs to edit. DxO NIK ColorEfex for example (not all NIK apps can run on their own)

 

This is a diagnostic, not a workaround.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Yes I can export the file from LR as a tiff, then open in my 3rd party apps -- Affinity Photo, Topaz Denoise, Nik Color Efex Pro ....all worked fine outside of LR on the tiff.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

So, not a folders rights issue with Lightroom Classic, or the external editor.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

If the previous worked, export another. This time within Lightroom Classic, try Edit In (sekect original when propted)

 

Does that work.

 

If that worked, tey another, this time select edit a copy when prompted (with or without, not important)

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

The edit in from with LR does not work....doesn't matter if it's a jpg, tiff or raw file....that's where the issue lies.  Thanks for helping me ...I do appreciate it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

While researching this error message- one link suggested that the error occurs when the folder with the images is set to 'Read only'. Check that the external drive and all image folders have full Read/Write permissions.

'Read only' would prevent the new 'exported' file being 'saved' to the folder.

https://www.online-tech-tips.com/computer-tips/set-file-folder-permissions-windows/

 

Also does the external drive have sufficient free space? (maybe even 20% of its rated capacity?)

 

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

That was the first thing I checked and I do have full control over the Pictures folder as well as the main drive itself, and my drive is no where near full.

cindyh83512444_0-1588640365769.pngcindyh83512444_1-1588640425697.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

BUT....after checking the individual folders....the Read Only is checked .....but when I uncheck it and hit apply or ok....close the folder and go back to check....the Read Only is checked again.....hmmm.....what the heck!

cindyh83512444_0-1588640879151.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Windows is 'crazy' like that! I do not really understand it either. 😞

My image folders show the same 'Read only' but the image files individually are not 'Read only', and I have not had problems.

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Thanks for trying!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Your screen-clip of the error message shows that the file you are trying to 'Edit In' has full-stops in the Folder name.

....Eagles Nest\4.23.2020\DSC_3800.NEF

Another diagnostic-

Can you try moving this image to another folder in Lightroom that does not have the full-stops, and try the 'Edit-in' again.

ScreenShot107.jpg

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Created a new folder on my external drive, moved a couple of photo's to it, imported to LR and tested....did not work...got the same error

cindyh83512444_0-1588641164369.png

However, when I look at the security of the folder I created on my external drive...it is showing as Read Only....even after unchecking the Read only....apply....close folder and reopen...the Read Only is checked.

cindyh83512444_1-1588641332773.png

So I am thinking this is an issue with my external drive and not LR....but what...that is the question now!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Not at my PC, but will comment

 

In that screen, click on the Security tab.

 

Will look for link with directions.

 

Just playing with that Read only box will not solve much.

 

see:

 

https://www.online-tech-tips.com/computer-tips/set-file-folder-permissions-windows/

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Went into the Security tab and already have full control for my user account....on the main "Pictures folder" as well as checked folder within ...all have full control.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Hopefully you will have it working eventually.

Next diagnostic-

Recreate an 'Additional External Editor' preset for one of the external programs (eg. NIK Silver Efex) as a totally new 'Edit-in' preset.

Double-check that the correct file format is set in Preferences for this new entry.

Try again.

 

If 'Edit In' Photoshop (the default) is not working, then a re-install of Photoshop is often recommended.

Also curious- Why would you be using a drive that is labelled as a "Backup" drive for photos in the Catalog?

 

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

I had already removed and re-added all the external editors...that didn't help. The name of the external drive is the default of the drive...I just never changed it.

 

However, I do have another external drive that I tested with and the photo's on that drive work just fine in LR - I can import, right click and select an editor and it opens just fine.

 

So it has something to do with the Seagate external drive....it might be going bad. I will copy all the files from the Seagate to the WD drive and then test again to see what happens....but that's going to take a while...lots of gig's to copy!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 05, 2020 May 05, 2020

Copy link to clipboard

Copied

It was an issue with the external drive. Copied files from bad drive to new WD External drive, renamed drive letter to same as the old, opened LR and pointed catalog file to new location --- opened a photo > right click > Edit in > Dfine....WORKED, tested again usin Affinity photo and a different file...worked fine that time.

 

So the issue was with the external drive and nothing to do with LR or the external editors. Thanks everyone for helping and pointing me in the right direction to figure it out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2021 Feb 04, 2021

Copy link to clipboard

Copied

Hi 

 

I had same problem, What I did need to do was to download Paragon Driver  -  Seagate official website. It takes advantage of read and write access without having to reform your external drives, both on Windows and macOS.

My external hard drive was Microsoft NTFS format but I´m working on MAC. It worked now after I installed this paragon driver! 

So your Seagate external drive it might mot be going bad - just not correct format? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2023 Nov 13, 2023

Copy link to clipboard

Copied

Thank you so much. I just had this same issue. My sister wants a print of a photo I took and edited almost 2 years ago. First, I couldn't find it and was freaking out. Relieved that I found at least the RAW version, but then I got this same message. Lots of up and down emotions. But thank you so much for sharing this info. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 13, 2023 Nov 13, 2023

Copy link to clipboard

Copied

LATEST
 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines