LR won't edit in PS, greyed out

New Here ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

Want to edit an image in PS but it's greyed out. PS is open. When I click on photo to get to edit in photoshop it's greyed out

Views

17.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 26, 2017 Dec 26, 2017

Correct the link in Registry(Windows) or correct the plist file on Mac: 'Edit In Photoshop' command missing

Try to deinstall Lightroom and Photoshop, run the Adobe Clenaer Tool and install the programs again.

Axel

Likes

Translate

Translate
Community Expert ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

Have you moved the image file?  What version of Lightroom?  What version of Photoshop?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

Moved image files from without Lr (finder on mac / explorer on Windows) opposed to from within Lr is the #1 cause of 'Edit In' being disabled.

Being signed out of PS could also be a cause.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 25, 2017 Dec 25, 2017

Copy link to clipboard

Copied

Some Reasons for "greyed out" that I know-

1) The Photo is 'missing'  Lr shows a ! on the thumbnail, or a complete folder is 'missing' showing a ?.

2) There is no image selected. (Not often seen, but is possible by Ctrl+D )

3) Lr only has access to a Smart Preview. (Full size original file must be available to Lr)

Regards. My System: Lr-Classic 11.5 Photoshop 23.5.1, ACR 14.5, Lightroom 5.5, Lr-iOS 7.0.2, Bridge 12.0.3, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

Lr said it only had acess to a Smart Preview.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

@Martha22038820i8pc  You (very brief) reply suggests you are using the 'Cloud' version of Lightroom-Desktop?

Lightroom-Classic would not show any message- just 'greyed-out' menues.

Lightroom-Desktop may give this message if the image was synced up to the Cloud from Lr-Classic, or you are not on-line for Lr to access the full-size file in the Cloud.

 

Please include the following in your questions:
Adobe product and Version number.
A Screenshot of the info panel from MENU: Help/System Info...
Operating system and Version number
The full text of any Error Message(s)
What you were doing when the problem occurred
Screenshots of the problem

 

 

Regards. My System: Lr-Classic 11.5 Photoshop 23.5.1, ACR 14.5, Lightroom 5.5, Lr-iOS 7.0.2, Bridge 12.0.3, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

LATEST
I realized it was just that folder of pics. I removed my rejected photos and that caused my originals to be lost. I did not have a problem with sending pics to Photoshop from other folders.

Be Joyful! Martha

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 02, 2021 Dec 02, 2021

Copy link to clipboard

Copied

In addition to what @Rob_Cullen wrote.

You said "LR only have access to the Smart Preview". It seems that you have stored your  original files on a external hard drive. In this case connect the appropriate drive so LR can access the original files. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 26, 2017 Dec 26, 2017

Copy link to clipboard

Copied

Correct the link in Registry(Windows) or correct the plist file on Mac: 'Edit In Photoshop' command missing

Try to deinstall Lightroom and Photoshop, run the Adobe Clenaer Tool and install the programs again.

Axel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Hello!  I'm relatively computer illiterate, but thankfully married a computer nerd.  I just read him your response in the hopes that he could help me fix this issue of Edit in Photoshop being greyed out, and he asked what link you're talking about.  Is that something that would need to be changed on each individual photo, or something more general?  I found I've got numerous photos in which that option is greyed out and the full sized originals are still on the computer where they've always been.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

The "link" that @Axel Matt refers to is a Windows Registry link (Editing the Registry is a "nerd's" job!) The method is in the web-link provided by Axel: https://helpx.adobe.com/lightroom/kb/edit-photoshop-command-missing-photoshop.html

IMO this "link" problem is more likely to give error messages like "Photoshop cannot be opened, or found"

 

There is also the "link" between the catalog and the location of image files. When the catalog loses this reference, LrC indicates the images as "Missing", which will show the [Edit-In] menu command as greyed out. See my post above- https://community.adobe.com/t5/lightroom-classic/lr-won-t-edit-in-ps-greyed-out/m-p/9584708#M87215

"Missing" files need to be re-linked to the catalog by -

MISSING FILES & FOLDERS (Adobe link)

MISSING FILES & FOLDERS (Lightroom Queen)

 

 

 

Regards. My System: Lr-Classic 11.5 Photoshop 23.5.1, ACR 14.5, Lightroom 5.5, Lr-iOS 7.0.2, Bridge 12.0.3, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2020 Mar 24, 2020

Copy link to clipboard

Copied

Friends,  I appreciate the advice given re: correct item in registry... no idea how to do that. Suggestions welcome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 24, 2020 Mar 24, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 03, 2020 Oct 03, 2020

Copy link to clipboard

Copied

just had the same problem.

will try the solution. but have to say: if you ask customers to re-install all the software, this is a major bug and should be handled with a bit more "sh_t, we are sorry"... i am angry right now, because i pay for this software and now i have to go through this....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 03, 2020 Oct 03, 2020

Copy link to clipboard

Copied

Have you checked the three points I mentioned on 26/12/2017 above?

They will still apply even if you re-install LrC & Ps!

 

 

Regards. My System: Lr-Classic 11.5 Photoshop 23.5.1, ACR 14.5, Lightroom 5.5, Lr-iOS 7.0.2, Bridge 12.0.3, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines