Mac OS high Sierra

New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

how can i download a version of lightroom compatible with a older mac os High Sierra? Thanks

TOPICS
macOS

Views

147

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 10, 2022 Jan 10, 2022

Likes

Translate

Translate
Adobe Community Professional ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Older versions of Classic can be downloaded and installed by clicking on the ellipsis next to Classic in the creative cloud app and selecting other versions. Don't know how far back you have to go for High sierra compatibility as Adobe only supplies one major version back. For older versions you have to use non-adobe sources. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

The Cloud deskapp app only goes back to version 10.x which requires Mojave or later.

 

Lightroom Classic Version 9.x (which supports High Sierra) is only available from the link provided by Prodesigntools, to my knowledge.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

LATEST

macOS 10.13 itself has been out of Apple's support for over a year now.
Apple's operating system has only a 3-year life cycle, so upgrading accordingly is a must.
Let's review the OS versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines