• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Macbook M1 Max slow 1:1 preview rendering // poor CPU utilisation

Community Beginner ,
Jan 30, 2023 Jan 30, 2023

Copy link to clipboard

Copied

I just got my MBP 16" M1 Max / 64GB / 2TB today (OSX 13.2 , current version of LRC) and unfortunately 1:1 preview generation is really slow and only using 50 % - 60 % CPU capacity. Tried several catalogs on internal an external drives, all the same.
Googled and found others have the same issue. Please Adobe enable LRC to make full use of the CPU (and maybe even GPU - if it works for export, why not for previews?)

TOPICS
macOS

Views

183

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 30, 2023 Jan 30, 2023

Copy link to clipboard

Copied

Tried several catalogs on internal an external drives, all the same.

Where are your photos?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Also tried different locations. Always on fast SSDs. E.g. catalog on internal SSD & files on external OWC Envoy Pro SX. Also tried catalog internal & files internal and both external.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

If you didn't reboot after installing LrC, do that. In Preferences, Performance tab, try settings other than Auto for the Graphics Processor and restart LrC if you make a change. That may not affect preview building but could help with other operations. You realize that 1:1 previews are only used when zooming in in the Library module, right? 

And verify that LrC has Full Disk Access: Go to System Preferences > Security & Privacy > Privacy tab. Click on Full Disk Access on the left. Unlock the padlock at the bottom and add LrC to the list of programs to have full disk access. Relock. (In Ventura, System Preferences is now System Settings.) Reboot the Mac. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Hey Linda,

thank you for your reply and suggestions. Unfortunately they could not solve the problem. CPU utilisation is still at approx. 55% for both 1:1 and standard preview rendering.

 

Out of curiosity I even tried to render both of them ( 1:1 & standard ) parallel, but even then CPU usage is still below 60%. It basically only makes use of 6 cores

Exporting btw is working fine and making use of nearly 100% CPU capacity and all cores

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2023 Feb 01, 2023

Copy link to clipboard

Copied

Do you have "Generate Previews in parallel" checked in Preferences, Performance tab? That should maximize the number of CPU cores used for building previews. And I don't think preview-building uses the GPU at all.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2023 Feb 01, 2023

Copy link to clipboard

Copied

LATEST

Yes it was checked and I also - again out of curiosity - tried not checking it.

I'm aware preview rendering does not use gpus at this point - I just wonder why tbh. I'm sure the process is pretty similar to exporting and sure would speed things up. First step of course would be to use all cpu cores as it should be.

As I mentioned I seem not to be the only one experiencing this with this particular MBP configuration. The issue is for example also discussed in this benchmarking video: https://youtu.be/dGBdh-bXyJc?t=755

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines