• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

P: Backslash (view original photo) button does not work on a Hungarian keyboard.

Explorer ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

Hi,

 

I use Lightroom Classic with a Hungarian keyboard and I would like to be able to see the original state of the photos. I can do this with the Y key, but the \ key doesn't work (on my Hungarian keyboard it's the AltGr + Q key). I have read many articles and many forum posts about this error. It seems that this is a common error with national character keyboards (I have read about such a problem with e.g. German and Dutch keyboards as well). In a couple of places, I came across such a evasive solution proposal that a configuration file must be created under Lightroom and the new hotkey can be entered in one line. I tried this too (maybe wrongly), but it didn't help either. I have the latest version of everything on my machine. I use Widows 11 in Hungarian, with a Hungarian keyboard. Maybe it would be worth combining the related forum posts, or if there is a workaround that works in all languages, then make it public. Of course, it would be best if Lightroom handled keyboards correctly, regardless of language. Dear Adobe colleagues! Can anyone confirm that Adobe is addressing this issue?

 

Best regards,

 

Péter

TOPICS
Windows

Views

323

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Feb 12, 2024 Feb 12, 2024

Create ticket to investigate and updated status

 

This is not a bug as Lightroom does not support Hungarian. 

Votes

Translate

Translate
LEGEND ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

"but the \ key doesn't work (on my Hungarian keyboard it's the AltGr + Q key)"

 

1. Are you running LR in English?

 

2. Are you running Mac OS in Hungarian or English?

 

3. Which keyboard layout is shown in the Mac Input menu?  See step 1 of this article for how to access the Input menu:

https://support.apple.com/guide/mac-help/use-the-keyboard-viewer-on-mac-mchlp1015/mac

 

In my Mac OS 14.2.1, when I use the Hungarian keyboard viewer with the ANSI or ISO layouts, Opt/Alt ü produces a \.  When I use the Hungarian QWERTY keyboard viewer, it's Opt/Alt ű. In LR running in English, using those key combinations toggles the before/after view in Develop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

My apologies, for some reason I concluded you were on Mac, but your post clearly shows you on Windows. I'll investigate Windows later today.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

I see the same misbehavior in my LR 13.1 / Windows 11 when Hungarian is selected as the input language and using the On-Screen Keyboard app.  Typing "AltGr q" enters a \ when the input focus is in a LR text field (e.g. Caption), but it is ignored as the shortcut for Toggle Before/After in Develop.

 

Perhaps the cause of this bug is that LR is seeing the key combination AltGr q (analagous to, say, Ctrl A), not "\".

 

LR defines the shortcut as something other than \ in many of its supported languages, probably for the same reason that it doesn't work in Hungarian:

 

johnrellis_0-1707547953916.png

 

You could use the Any Shortcut plugin to change the assigned shortcut to something else.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

@Rikk Flohr: Photography, please consider moving to Bugs. I am able to reproduce the misbehavior (see my previous post).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 12, 2024 Feb 12, 2024

Copy link to clipboard

Copied

Create ticket to investigate and updated status

 

This is not a bug as Lightroom does not support Hungarian. 

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2024 May 23, 2024

Copy link to clipboard

Copied

Dear Community

 

Best useful shortcut to see after/before modification is not working on LrC 13.3 in Delop mode.

I'm on Windows 11 with an QWERTZ Keyboard (CH-fr)

 

Is strange because, if I enter this caracter \ in the filter mask with it's key attribution the \ caracter is written.

 

Has someone an idea how to solve this?

Many thanks in advance 

simiruffi

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 23, 2024 May 23, 2024

Copy link to clipboard

Copied

Are you running LR in English or French? 

 

If you're running LR in French, then the keyboard shortcut for Toggle Before/After is Opt X. See here for the list of all French shortcuts:

https://www.lightroomqueen.com/keyboard-shortcuts/

 

If you're running LR in English, then you won't be able to use \ as keyboard shortcut (or any character  that requires AltGr). The LR shortcut mechanism can't handle the use of AltGr as a modifier (as it can Ctrl, Alt, and Shift). You can use the Any Shortcut plugin to assign another shortcut to Toggle Before/After.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

Perfect it works, thank you @johnrellis 🙂
I have to switch LrC in French and Alt + x shortcut works now 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

Moderators, @Rikk Flohr: Photography, please merge with this thread:

https://community.adobe.com/t5/lightroom-classic-discussions/p-backslash-view-original-photo-button-...

 

The use of \ on keyboards requiring the modifier key AltGr to be pressed is a fairly frequent question, so it would be good to have a single thread on the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 13, 2024 Mar 13, 2024

Copy link to clipboard

Copied

Hi everyone

Ive run into a little problem with my shortcuts...

to see the Before / After editing Preview, there is normaly the Shortcut [\]. but somehow this does not work on my new Keyboard. Maybe because the Keyboard i use is german?

Is there a possibility to replace the shortcut with another letter/symbol?

Severin28568843iari_1-1710362520723.png

as you can see the [\] key is in the green highlighted box.

 

does anyone have a suggestion on how to fix my problem?

 

Thanks in advance!!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 13, 2024 Mar 13, 2024

Copy link to clipboard

Copied

Just a guess!- Try [Shift+V]

https://www.lightroomqueen.com/keyboard-shortcuts/languages/

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

thanks for the tip! But it still does not work...

i'll keep on looking for a solution.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

@Severin28568843iari 

 

You can customize KBSC using Any Shortcut  plug-in by @johnrellis 

 

https://johnrellis.com/lightroom/anyshortcut.htm

 

I believe German is supported so no worries for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

LR's shortcut mechanism gets confused between the physical key sequence you type (e.g. AltGr \) and the character that is sent to the app (e.g. \).  To provide you with a working solution for invoking Toggle Before/After with a shortcut, I'll need to know:

 

1. In which language is your Windows operating, German or English?

 

2. What is the setting of Preferences > General > Language: Automatic (Default), German, or English?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 15, 2024 Mar 15, 2024

Copy link to clipboard

Copied

Ohh, I Just figured it out, thanks to you question 🙂

 

The Language was set to english, so the correct shortcut would be: [\].

So i Switched it to Default and now its in German. So the new Shortcut is shift + V.

 

Thank you so much, really appreciated the help!!

You made my editing much more easy 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 15, 2024 Mar 15, 2024

Copy link to clipboard

Copied

Glad it was easy to resolve.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

Using the backslash shortcut doen not switch between view image before/after in my English version of Lightroom (12.2.1 Release).

My regional settings are Danish (Denmark) on a Windows PC. 
Logitech MX Keyboard (Nordic with Æ,Ø,Å) 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

I've found that on a Danish keyboard, we have to press ctrl+alt+< (left from Z) to get the backslash, but it still doesn't work in Lightroom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

I have a Norwegian (Scandinavian) Fujitsu keyboard, and the backslash key works for me.

Regional settings in Windows are set to Norway, and LrC is set to English.

Does your keyboard have a different layout?

 

Scandinavian-keyboard.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

I have the same layout (red), but it does not produce a backslash when pressed once (it produces nothing on one press, but ´´ on two presses). 
However, a backslash is produced when pressing ctrl+alt+< (green)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

Keyboard.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

Your keyboard seems to be for both Mac and Windows, maybe it has something to do with that. And the Ctrl + Alt + <  combo does nothing on my keyboard.

Do you have a plain Windows keyboard you could try?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

Yes, I switch between macOS and Windows, therefore this keyboard comes in handy.
I don't have right now, but I can get one. Even if it works on a plain Windows keyboard, it sucks if I have to start using one plain for windows and one plain for macOS, just to use this feature in Lightroom.
No way to get this kind of keyboard working?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines