๐Ÿ”Ž Quick Tips: How to give Full Disk Access to Lightroom Classic on macOS

Adobe Employee ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

LrC HEADER .jpg

 

How to provide Full Disk Access on macOS

 

Since macOS 10.14 (Mojave), Apple introduced a new privacy structure to help ensure that all applications obtain user consent before accessing documents, downloads, desktop, iCloud Drive, and network volumes. This has been reinforced in newer versions of macOS. This change prevents unauthorized access to user files and folders.


When Full Disk access & Accessibility permissions are needed, users may be asked to or be required to change the setting in System Preferences > Security & Privacy > Privacy for Lightroom Classic manually.   

While for the File & Folders access, the user is prompted to allow or deny when needed. 

 

Why provide full disk access to Lightroom Classic?

Insufficient or broken permissions may restrict Lightroom Classic from functioning correctly and break your workflows. All tasks that require access to the computer's storage โ€” importing/exporting images, cross-app workflows, reading/writing metadata,  and more, behave unexpectedly. It may also lead to missing images, performance issues, unexpected sync issues, and random app crash on launch or while working on a file. 

 


Quick steps to enable full disk access and grant permissions to Lightroom Classic

 Follow these steps to prevent the permissions issues from occurring: 

 

โถ  Go to System Preferences > Security & Privacy > Privacy > Click the Lock icon > Authorize via password > Unlock the lock to allow changes to system settings. 

SameerK_0-1649863460950.png

 

โท  Add Lightroom Classic by clicking on the (+) button & navigate to the Applications folder on macOS.

 

SameerK_0-1651070095792.png
 

โธ  Go to Full Disk Access and add Lightroom Classic by clicking on the (+) button & navigate to the Applications folder on macOS.
Note: Adding Lightroom Classic under Full Disk Access overrides Files and Folders settings. 

 

SameerK_1-1651063386869.png

 

 

โน  Click the Lock icon to save the changes. Restart your computer to see the applied changes. 

 

 

Stay tuned for more tips to come.

 

Related links:

Lightroom Classic system requirements 

Quick Tips: Optimize LrC preferences for better performance 

Basic troubleshooting steps to fix issues in Lightroom Classic 

 

 

TOPICS
macOS

Views

3.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 297 Replies 297
New Here ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

I have the same problems with Monterey 12.3. After I updated the system, Lightroom photos all went blank. No smart preview or library view. I tried to import photos again, Lightroom only let me import a few , the rest of the photos are in grey. It work on my other computer that has not been updated to Monterey 12.3. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

I was receiving the same error message in Monterey. Some older posts recommend Files and Folders preferences in System Preferences, but I found Full Disk Access to be the culprit here. Make sure LrC has Full Disk Access and you should be in the clear.

mattplays_0-1649298424353.png

mattplays_1-1649298545381.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

How did you get your photos back into your catalog?

I have switched the full disk access as you've mentioned, but my catalog is still empty. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Thanks @mattplays, this really helped. I was starting to panic and thought that I'd have to get rid of iOS Monterey, with all the hassle of reinstalling Big Sur.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Hi Every one, i get a big problem from the last version of Lightroom Classic version: 11.1 [ 202112022200-7fd1f998 ]

I am a Wedding Photographer, i am editing every day more than 2000 photos.

I have the problem of Crashing (Interface freezing after 300 editing in Develop, when i copy and paste edit, photo to photo, one by one.

I use Lightroom for years, i got all the version, but never get this problem.

Important the lightroom freeze, but not big crash, i can exit clean, and get save. But its dispointing to have to do exit and reload every 30 min.

All is fast, refresh and no bug, but just freezing after 300 edit copy and paste, Also when i switch photo to photo sometime i get a ghost photo from previous edit for less than an half a second and after its ok, but the ghost view is not confortable when moving photo to photo do i have to call ghostbusters team ???

My Config is :

Lightroom Classic version: 11.1 [ 202112022200-7fd1f998 ]
License: Creative Cloud
Language setting: en-IL
Operating system: Mac OS 12
Version: 12.1.0 [21C52]
Application architecture: arm64
Logical processor count: 8
Processor speed: NA
SqLite Version: 3.36.0
Built-in memory: 16,384.0 MB
Real memory available to Lightroom: 16,384.0 MB
Real memory used by Lightroom: 1,486.1 MB (9.0%)
Virtual memory used by Lightroom: 403,547.5 MB
Memory cache size: 57.1MB
Internal Camera Raw version: 14.1 [ 993 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2
Camera Raw virtual memory: 125MB / 8191MB (1%)
Camera Raw real memory: 136MB / 16384MB (0%)
Displays: 1) 3840x2160

Graphics Processor Info:
Metal: Apple M1

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Users/moshemenagen/Pictures/Lightroom/Lightroom Catalog-v11.lrcat
Settings Folder: /Users/moshemenagen/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) Lightroom to Exposure
6) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default - External Headphones#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: LR5x38
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 32
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: Apple M1
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: Apple
GL_VERSION: 2.1 Metal - 76.3
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_cl

 

 

{Thread title edited by moderator}

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 10, 2022 Jan 10, 2022

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Lightroom Classic. Please ensure that Lightroom Classic has the necessary permissions on your Mac by following the steps mentioned below:

1. Go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy tab.

2. Then select Accessibility from the list to the left & check if Lightroom Classic is added to the list with a check mark in front of it.

3. If Lightroom Classic is not a part of the list, please add it by unlocking the window first using the lock at the bottom left, then clicking the + icon & navigating to the Applications folder.

4. Also, grant permissions to Lightroom Classic under Full disk access located in the same list as Accessibility.

5. Once done, restart the Mac & check if it helps.

 

You can also try disabling the option to Use Graphics Processor from Lightroom Classic by going to Preferences, then Performance. Once done, relaunch Lightroom Classic for the changes to take effect.

To optimize the Preferences of Lightroom Classic, please check: https://helpx.adobe.com/lightroom-classic/kb/optimize-performance-lightroom.html

 

If the issue persists, you can try to reset the preferences of Lightroom using the steps mentioned here: https://adobe.ly/2JSym5e

Please backup your presets prior to resetting the preferences.

 

Let us know how it goes!

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Hi, i made the change in Accessibility from Security and Privacy, it fix the freeze in devellop thanks you, but ghost image continue sometime when switching photo to photo, but not always... depend how many edit i did before, now come after 500 or 600 photos, but i confirm it fix the freeze and no respond from LR devellop modul. Thanks you, please fix this bug in next realease, its a new bug never append before in previous LR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

I am having an issue with LrC no longer recognizing an external HD that I have been working off of for years. I was editing files yesterday and today LrC states "file cannot be found" when in the develpoment module. I first noticed the problem when trying to import a new project from today and when I went to "import", the drop down menue for my main working HD in the import module showed nothing. I use Chronosync to manage my backups and nothing appears to be wrong with the drives itself and was successfuly backed up this evening. I can only assume its a problem with Lightroom. Ive included some screen shots below. Apprecaite any help.

 

CamScreen Shot 2022-05-26 at 9.45.40 PM.pngScreen Shot 2022-05-26 at 9.45.20 PM.pngScreen Shot 2022-05-26 at 9.46.14 PM.pngScreen Shot 2022-05-26 at 9.46.01 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Disregard. I was able to resolve the issue by going into my system preferences > security and privacy and then making sure Lightroom was present and check marked under "full disk access". I am still unsure how the problem occured but this fixed the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

The problem occurred because you updated MacOS to Monterey 12.3.1 or higher. Apple has tightened security since 12.3.1.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Hi there, I have an issue that appearing again and again lately.

The photos are not avilable only on the Develop Moudle. 

 

I'm using OS Monterey 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out. We are sorry for the trouble with Lightroom Classic. We are here to help.

Could you please confirm the version of Lightroom Classic from Help > About Lightroom Classic & the version of the macOS?

As it started to happen recently, have you updated Lightroom Classic or the macOS on your computer in recent weeks?

 

Since macOS 12.3.1, Apple has spiked the authorization required by apps. You can also ensure Lightroom Classic has correct and complete permissions on the macOS by following the steps I have shared in this article: Quick Tips: How to give Full Disk Access to Lightroom Classic on macOS

 

Let us know if this works,

Thanks!

Sameer K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Aprรจs la derniรจre mร j,

impossible d'accรฉder ร  mon catalogue, message affichรฉ Le catalogue Lightroom ne peut pas
รชtre utilisรฉ, car le dossier parent "I
Volumes/PH.PRIVEES/Lightroom"
n'autorise pas la crรฉation de fichiers.

Impossible d'afficher les sources et d'importer dans un nouveau catalogue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2022 May 30, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Hi,

Thanks for the quick help, unfortunately did not work.
On another Apple device with the same software version everything works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Hello,

I cannot import the jpg stored on the sdcard neither from direct camera connection nor from sdcard reader.

"No files found" statement displayed whereas the sdcard is full as you can see in the screenshot attached.

I'm working with :

- MacOs Catalina Version 10.15.7

- LrC version 11.3.1 

The camera setup is :

- Image Quality : Fine

- Image size M 3:2

- Film simulation : PRO Neg Std

Many thanks for your support

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Thanks GoldingD !
This fully fixes the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 05, 2022 Jun 05, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

I'm looking for a solution to an problem I haven't seen before. I also haven't seen it answered anywhere else. I cannot export a file because , well 'File could not be found'.

 

Normally I'd go to the 'locate' icon and sort this issue out but this icon isn't appearing and I don't know of any other way to prompt it. This is the case for every shot in the folder.

 

The ARW files are still in position, where they should be, but I don't know how to relink or regain the ability to render, export or upload images.

 

I'm using Lightroom Classic 11.3.1 release on MacOS Monterrey 12.4

 

Does anyone have any suggestions? 

 

Thanks in advance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Make sure you have given Lightroom Classic full disk access permissions. See the first post on this page.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Wow... I didn't realise the impact these permissions would have, that the changes occurred in the background and I didn't even notice until now. Thanks to everyone that answered. This problem and the other problem of importing a travel catalogue is solved. 

 

Phew, what a time waster. and what a relief to solve the issue.

 

Many thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines