• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
4

"Lightroom encountered and error when reading from its preview cache and needs to quit"

Community Beginner ,
Oct 02, 2013 Oct 02, 2013

Copy link to clipboard

Copied

I keep receiving this error every time I open LR, "Lightroom encountered and error when reading from its preview cache and needs to quit" and the app won't open. It said LR would try and fix this error next time I opened it but the error remains. I tried uninstalled and installing the app and the error remains.

Any Ideas here? Is there another app that may be telling it where to look for the cache and it no longer there? I was using a ramdisk for a bit but ditched it. Not sure if that has something to do with it but it seems suspect.

Your thoughts?

--Kenny Brandon Wilson

Views

107.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Oct 02, 2013 Oct 02, 2013

You need to delete the Preview Cache.

It is located in the same folder as the Lightroom Catalog. The preview cache name ends with Previews.LRDATA and should be deleted. Do not confuse this with *.LRCAT, which should not be deleted.

Votes

Translate

Translate
Adobe Employee ,
Oct 02, 2013 Oct 02, 2013

Copy link to clipboard

Copied

Moved from the Creative Cloud to the Lightroom forum. They will be able to help you here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 02, 2013 Oct 02, 2013

Copy link to clipboard

Copied

You need to delete the Preview Cache.

It is located in the same folder as the Lightroom Catalog. The preview cache name ends with Previews.LRDATA and should be deleted. Do not confuse this with *.LRCAT, which should not be deleted.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 02, 2013 Oct 02, 2013

Copy link to clipboard

Copied

NICE! It worked like a charm. I'm back up and running. Thank you.

Kind Regards,

--Kenny Brandon Wilson

Twitter: @kennybrandon

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2013 Nov 02, 2013

Copy link to clipboard

Copied

I have exactly the same problem. It started appearing when I moved my entire file structure to an external drive. However, the first seesion I used the files on the external drive, LR worked fine with no errors. In my second session, it also worked well for sometime, and then I started experiencing this error. Initially, I deleted the preview file as recommended on this forum. It would work for a while, then the error would appear again. Now, it appears almost regularly.

I am using Macbook Pro Retina display, LR5, external drive 1TB Toshiba. Any help/ideas greatly appreciated. Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 26, 2014 Apr 26, 2014

Copy link to clipboard

Copied

If problem increasing in regularity, consider you may have a failing hard drive. Hopefully, if you act soon enough (move catalog to better drive, or replace existing drive), you won't end up with a trashed catalog and have to re-import..

PS - failing ram can also result in symptoms resembling failed hard drive - so if drive not the problem, check ram.

Rob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

After weeks without Lightroom is working! thanks, I just copied the complete file structure to my SSD and it worked like a charm! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2014 Nov 28, 2014

Copy link to clipboard

Copied

WAT WE SHOULD DO TO

RUN

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 28, 2014 Nov 28, 2014

Copy link to clipboard

Copied

IMDAD HUSSAIN wrote:

WAT WE SHOULD DO TO

RUN

Delete preview cache.

For more info, read this thread, or others more like this (see this page - right and up..), or do a forum and/or internet search.. - all the info you need is readily findable - you can't miss it if you look..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2014 Jul 11, 2014

Copy link to clipboard

Copied

YES! Thank you so much. Worked beautifully! After a failed chat with Dujamdkmlknf in who knows where, you are a lifesaver.:)

Warmest regards,

Kelcey

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 09, 2015 Apr 09, 2015

Copy link to clipboard

Copied

This worked. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 05, 2017 Feb 05, 2017

Copy link to clipboard

Copied

Thank you had the same issue

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 12, 2014 Aug 12, 2014

Copy link to clipboard

Copied

Kenny I´m having the same problem but when a reinstalled catalog folder disappear so I can´t rename, delete or moving this folder. Do you remember were was placed the Catalog preview folder after you reinstaled LR?Garetto

Thanks!

Luciano Garetto

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2014 Aug 23, 2014

Copy link to clipboard

Copied

I'm having the same problem.

Last week LR was working fine. Yesterday I come home from vacation, and LR won't launch, and displays this error before shutting down. I found this post and deleted the preview data and it launched. I did my import and development like normal and close the software. Next time I go to open it, same error.

It's to the point that I have to delete the previews data EVERY SINGLE TIME prior to opening the software. This is ridiculous. Is there a long term fix available?

Thanks,

Ed

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2014 Aug 25, 2014

Copy link to clipboard

Copied

Talked to Adobe support this morning, this is their response in case anyone else is looking for help. I'm running a Windows 7 box, LR 5.6.

  Gokul: Click on start and type %appdata%, then open roaming folder.

  Edward: ok

  Gokul: Open Adobe folder.

  Gokul: Open Lightroom folder.

  Gokul: Open Lightroom folder> Preferences.

  Edward: ok

  Gokul: Rename Lightroom 5 Preferences.agprefs file as Lightroom 5 Preferences.agprefsOLD.

  Edward: OK

  Gokul: Please check if you can launch Lightroom without any error.

  Edward: it shows me a welcome screen and is asking me to select my country

  Edward: aka, register the software

  Gokul: You can skip and launch it.

  Edward: LR catalog not found

  Gokul: Please select the catalog.

  Edward: my original catalog?

  Gokul: Yes.

  Edward: testing integrity of catalog

  Edward: loaded just fine

  Gokul: Okay.

  Gokul: Please check if you can re-launch it again.

  Edward: yes, it worked!

  Gokul: Excellent!

  Gokul: Since your preferences were corrupted you were facing issue so we renamed the preferences file to reset it.

  Edward: aha....ok


All of my import/export presets were intact along with develop user presets. I'm happy as a clam for my $10/month!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2014 Sep 21, 2014

Copy link to clipboard

Copied

I'm having the same error and have tried every solution in this page with no luck.

I am not finding the Preferences.agprefs file as discussed in the solution from support.
Any suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2014 Sep 21, 2014

Copy link to clipboard

Copied

I was able to get it to launch again but loaded my latest catalog. Is there any way to load what I have been working on since my last backup or is it all lost?

I've now changed to backup more often but is everything I have worked on since my last time gone?
Thanks in advance,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2015 Oct 14, 2015

Copy link to clipboard

Copied

I can't find a preferences file either. The problem all just started today when for the first time in a year I was asked to register Lightroom for some strange reason.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2015 Oct 14, 2015

Copy link to clipboard

Copied

ok I found the preference file and changed to the agprefsOLD one but have no idea how to get to my catalogue files, i must be stupid, but I can't locate and so I'm still stuck with the same error message. Am getting very upset. Photoshop never does this kind of nonsense to me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 22, 2014 Dec 22, 2014

Copy link to clipboard

Copied

This part of the call dialog ultimately solved my situation with similar problems:

       Gokul: Rename Lightroom 5 Preferences.agprefs file as Lightroom 5 Preferences.agprefsOLD.

       Edward: OK

       Gokul: Please check if you can launch Lightroom without any error.

I tried all the steps on this thread and also updated the software but this final step got me up and running.  Now I have to figure out how to rebuild the catalog with the metadata I imported them with,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2015 Jan 09, 2015

Copy link to clipboard

Copied

Hi - I can't find the preferences file you are mentioning.  What directory will it be in?  It's very strange how this works, I can do hundreds of pictures no problem, then I'll get a bunch of these errors in a row, then things are fine again.  Is there a timeout value that is exceeding trying to read the data?  My connection is not always fast.

Thank you,

Glenn

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 25, 2014 Dec 25, 2014

Copy link to clipboard

Copied

It worked after several attempts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 02, 2015 Jul 02, 2015

Copy link to clipboard

Copied

Very nice. It Works. Thank you for sharing.

Ejvind

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2015 Aug 30, 2015

Copy link to clipboard

Copied

Thank you - Gokul aka Esheato  - worked like a charm and I have not lost anything... Wow.   I started getting knots in my stomach about anything I might loose.

Thanks Again !!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Thank you, worked a treat.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines