Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Tethered Shooting in Lightroom Classic 9.1 not working on Canon 5D Mk III.

Community Beginner ,
Dec 13, 2019 Dec 13, 2019

Copy link to clipboard

Copied

I just upgraded my OS from 10.14 to OS 10.15.2, and upgraded from the 2019 version of Lightroom Classic to the new LR Classic 9.1.  I have a Canon EOS 5d Mk II and 5d Mk III.  Both worked well with Tethered Catpure until these OS and LR upgrades, and now when I start Tethered Capture, it doesn't recognize the camera.  I checked connections, restarted and reconnected the camera, restarted the computer, deleted Lighroom Preferences, updated my camera firmware.  I tested my cameras on an old computer with OS 10.10 and Lighroom 6, and Tethered Capture still works great on that system.  

 

When my camera is connected, I am able to use the Lightroom Import window to navigate to the card in the camera and download images into lightroom.

 

Another puzzle piece, is I installed the October 2019 upgrade to EOS Utility, and it also is unable to recognize my cameras.  But Lightroom shouldn't require EOS Utility to operate the 5d Mk III, right?

 

I was on chat with Adobe tech support for 1-1/2 hours, and they weren't able to solve the problem. They suggested I contact Canon support for help.

 

Can anyone explain how I get Tethered Shooting to work?  Thank you!

 

TOPICS
Bug, Mac, Problem or error

Views

3.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Dec 14, 2019 Dec 14, 2019
I believe the problem is the MacOS X 15.2 update. That breaks tethering, not only in Lightroom but -as you have noticed- also in EOS Utility. And if I'm not mistaken also in CaptureOne.

Likes

Translate

Translate
Community Beginner , Jan 30, 2020 Jan 30, 2020
Catalina 10.15.3 fixed it for me on my Canon 5d mkiv and EOS R.  I can now tether with no problems.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 14, 2019 Dec 14, 2019

Copy link to clipboard

Copied

I believe the problem is the MacOS X 15.2 update. That breaks tethering, not only in Lightroom but -as you have noticed- also in EOS Utility. And if I'm not mistaken also in CaptureOne.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 11, 2020 Jan 11, 2020

Copy link to clipboard

Copied

Good to know - I have been trying to fix this for a few days now. I finally found this post. Now how to reverse my software update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Yup! Facing the exact same problem , both with EOS Utility and Capture One. Is there no way around it?TIA

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2019 Dec 14, 2019

Copy link to clipboard

Copied

I can also confirm this on 3 seperate computers -Canon 5DmIV with MacOS 10.15.2 does not recognize camera in tethered connection. However the previous 10.15.1 update still works with LR tethering (both LR 9.0 and 9.1). But, you just can't go backwards from 10.15.2 to 10.15.1, you have to reinstall Catalina base (10.15.0) and use only the 10.15.1 update... a real pia! Or, go back to Mohave...not ideal if you have moved on from that.

 

One interesting note in 10.15.2, when the camera is attached and you import: "File>Import Photos and Video", the camera DOES shows up in the import window, and you are able to import directly from the camera. But in "File>Tethered Capture>

tethered Capture Settings>OK". camera detection is not recognized and stalls the process. 

Not sure what Apple did with this 15.2 update, but obviously Apple has to figure this out or Adobe has to counter.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 26, 2019 Dec 26, 2019

Copy link to clipboard

Copied

I just tied to tether my 5DIII and not recognised - I'm now running 10.15.3 and this is still the case - come on Apple - not good enough for a 'creative' platform!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 11, 2020 Jan 11, 2020

Copy link to clipboard

Copied

Amen to that. I hate the constant updates because it's too hard as the consumer to know where the breakdown is.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2020 Jan 17, 2020

Copy link to clipboard

Copied

Was on Adobe tech support for over 2hrs they could not fix the problem . Said it was a bug with LR have to wait for updates to fix it. no idea when they will have updates. Thanks Adobe:(

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 17, 2020 Jan 17, 2020

Copy link to clipboard

Copied

Actually we are waiting for Apple on this.

 

Lightroom Classic is not the only program having issues communicating with cameras connected via USB.

 

For example Fujifilm RAW Studio does not work. Fujifilm states they are working with Apple to address.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

Beware all Lightroom Classic users!!! If you are using Lightroom Classic with a Canon camera you will not be able to tether.

Lightroom will spot your camera for importing images but tethering will not be possible. Don't upgrate your macOS version to Catalina.

Stick with Mojave or you will be in a world of trouble.

 

Bas

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

Hey Bas, I thinks it is very bad Adobe is aware of this issue for more than two weeks and nothing has been done about it. Can't work with LR in the studio for now ... CaptureOne made a fix after a few days... So when you need tethering you could use the trial version of CaptureOne for now ... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2020 Jan 12, 2020

Copy link to clipboard

Copied

Seems to be fixed in 10.15.3 (Beta), so this probably means a wait for the release of 10.15.3.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2020 Jan 13, 2020

Copy link to clipboard

Copied

Its been two weeks now!!! And they still havent made an update ...
Dont they understand that this is pretty serious for professional photographers? That shoot tethered everyday..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Downgrade your system to Mojave. It’s the only solution!

Outlook voor iOS downloaden

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

That’s not right. Mojave is not the required solution. The choices are to downgrade to Catalina 10.15.1 or upgrade to the beta of 10.15.3. Mojave 10.14.6 is just another choice. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

The more less time consuming !!!! method is to install the trial version of CaptureOne who had fixed this issue already half of december. I use this now for tethering and import in Lightroom. Still can not believe Adobe did not fix this already. One month ... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Yeah, 1 month and no solution - been a shitshow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 23, 2019 Dec 23, 2019

Copy link to clipboard

Copied

when will lightroom be able to tether canon cameras in catalin 10.15.2

very disruptive to work process not to be able to tether canaon cameras

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 23, 2019 Dec 23, 2019

Copy link to clipboard

Copied

This is a known issue, caused by Apple, not by Adobe. Tethering doesn't work in EOS Utility either, nor in any other application such as CaptureOne.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 23, 2019 Dec 23, 2019

Copy link to clipboard

Copied

Thanks for your reply.

I'll contact Apple, and hope that Adobe will also lobby Apple on behalf of all your Canon shooters for a quick resolution to this issue.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 23, 2019 Dec 23, 2019

Copy link to clipboard

Copied

Apple can't fix this. Canon needs to update their tethering APIs used in EOS utility and Lightroom to work in the updated security model in Catalina and Apple is not going to reverse course on the security features they added.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 24, 2019 Dec 24, 2019

Copy link to clipboard

Copied

I'm not sure what exactly caused this and who needs to fix it, but as tethering worked in Catalina 15.1 and is broken only after the update to 15.2, I doubt this is related to Catalina security. If it were, then tethering would have been broken from Catalina 15.0 onwards.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2019 Dec 29, 2019

Copy link to clipboard

Copied

I just bumped into this issue after buying a new 3500 dollar MacBook and installing Lightroom. With big job coming up next week this very disturbing. Not sure who should fix this. But if it is't fixed in a couple of days I'll walk away from the professional triangle Apple / Adobe / Canon. As the main reason I use them is continuity and reliability.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2020 Jan 04, 2020

Copy link to clipboard

Copied

it's realy big problem. my work is stoped.

hey canon, adobe, apple! don't rest! do work to fix!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2020 Jan 05, 2020

Copy link to clipboard

Copied

This is a user-to-user forum. There is nothing we can do.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines