Images grayed out - can not import

Explorer ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

Have seen other threads on this, but no answers. Stunning. This issue renders Lightroom completely useless.

I click a folder, see all images, then select "import".

Worked once, never again.

I am selecting a folder of images in the same subdirectory as the one I sucessfully imported, but all the images are grayed out.

Why?

TOPICS
Import and export, Problem or error

Views

94.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Guru , Aug 29, 2012 Aug 29, 2012
Usually one sees this, when LR believes the images are already imported. You are certain that your Catalog does not already include them? On my PC, when I hover over one of these greyed-out images, I get a tooltip which (among other things) explains that "this photo has already been imported". Also if you change the selector at the top of the Import dialog grid from "all photos" to "new photos", if the thumbnail grid then becomes empty, that is your explanation. LR doesn't think these are new im...

Likes

Translate

Translate
Explorer ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

All the images are there, in that folder. Why will LR not import them?

lightroomnotworking.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

Usually one sees this, when LR believes the images are already imported. You are certain that your Catalog does not already include them? On my PC, when I hover over one of these greyed-out images, I get a tooltip which (among other things) explains that "this photo has already been imported". Also if you change the selector at the top of the Import dialog grid from "all photos" to "new photos", if the thumbnail grid then becomes empty, that is your explanation. LR doesn't think these are new images.

I believe that the "don't import suspected duplicates" option - which is turned on by default - will also reject images that appear to be mere extra renames of the same original camera file - due to showing the same original capture file name in the EXIF metadata.

But in order for "don't import suspected duplicates" to activate, there have to be images present which these new ones would be duplicates of. So I would advise first checking for any LR filters, or other selective viewing that might be currently stopping you from seeing these if they are within LR.

Repeatedly importing files is likely not the answer; once should be enough AFAICT.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2016 Aug 30, 2016

Copy link to clipboard

Copied

Turning off the 'do not import suspected duplicates' just gave me back so many photos I thought I lost. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2016 Oct 21, 2016

Copy link to clipboard

Copied

If you find images greyed-out during re-importing - Tick off the "Don't Import Suspected Duplicates" in the File Handling option, that you will find on the right side of the screen, in the Import dialog. (See attachment)
Duplicates.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2016 Oct 21, 2016

Copy link to clipboard

Copied

If you find images greyed-out during re-importing - Tick off the "Don't Import Suspected Duplicates" in the File Handling

Except that it doesn't solve the problem. It makes the problem worse.

Now you have two copies of the image somewhere in your Lightroom library, one with whatever edits and metadata you applied previously, and the newly imported version which have no edits or previously applied metadata.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2016 Oct 21, 2016

Copy link to clipboard

Copied

Now you have two copies of the image somewhere in your Lightroom library, one with whatever edits and metadata you applied previously, and the newly imported version which have no edits or previously applied metadata.

Generally, after importing to LR, if the source files are moved in the Windows Explorer - The reference to those files are corrupted. Unless, the files are removed from the disk, there are still three workarounds.


1. Ticking off the "Don't Import Suspected Duplicates" in the File Handling option (works for few projects)


2. To regain the old edits : Create the same physical folder structure in the explorer, as it was when files were imported to LR, And move/rename back the source files to their original locations . Now you can find the old edits still embedded on them in the Catalog > Previous Import.


3. If you cannot move the source files and create the original folder structure. Remove the conflicting images in Catalog > All Import. You can sorted the files by View > Sort >Added Order, to make it easier to locate. After removing it from the catalog, the conflicting images can now be re-imported. There will be no more older instances of the file.

Cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2016 Oct 21, 2016

Copy link to clipboard

Copied

Generally, after importing to LR, if the source files are moved in the Windows Explorer -

The best solution is to not move the photos using your operating system.

But if you have moved or renamed the photos, then regarding your three solutions, the proper solution is to point Lightroom to the new location of the photos. This document explains the details of how to do this: Adobe Lightroom - Find moved or missing files and folders

Your solution 1 and 3 don't solve the problem at all. You lose your edits and user-supplied metadata. Solution 2 is possible but if you return the photos to their previous location using your operating system, the photos don't show up in Lightroom under Previous Import, although they are in the library module with edits and user-supplied metadata intact.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2016 Oct 28, 2016

Copy link to clipboard

Copied

None of the above solutions worked for me but then it looks like there isn't one solution for all. In my scenario, I imported all photos into a new collection, fine. Then, I went through and removed some photos (rejects and such) from that collection. I later noticed that some photos, which I didn't want removed, had also been removed from the collection (probably didn't realised I had multiple selected or something).

Ok, so far, mundane stuff. I then figure all I have to do is Import those photos back into the collection. Boom! the ones I want are all greyed out and no measure of checking/unchecking of settings could change that. I also hadn't moved any files on my OS.

So, I found a solution for me: In the Collections panel, under Smart Collections, there's a set of options/filters - named something like: Colored Red, Five Stars, Past Month, Recently Modified, and so on.

I clicked on Past Month and found the original batch of photos shown there. I then drag and dropped the photos I wanted to add to the Collection I created. The only issue I had was that sometimes the drag'n'drop didn't "work/stick" so I had to keep trying several times on just one photo! I tried to drag'n'drop multiple files but that didn't work 😕

So, for me I found a way, and I hope that helps someone out there... BUT, in my opinion, this whole "method" is nonsense; if I choose to import files I want to be able to access ALL of my photos, regardless of whether or not I've previously imported them or not.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 28, 2016 Oct 28, 2016

Copy link to clipboard

Copied

DigitalHardware wrote:

None of the above solutions worked for me but then it looks like there isn't one solution for all. In my scenario, I imported all photos into a new collection, fine. Then, I went through and removed some photos (rejects and such) from that collection. I later noticed that some photos, which I didn't want removed, had also been removed from the collection (probably didn't realised I had multiple selected or something).

Ok, so far, mundane stuff. I then figure all I have to do is Import those photos back into the collection. Boom! the ones I want are all greyed out and no measure of checking/unchecking of settings could change that. I also hadn't moved any files on my OS.

So, I found a solution for me: In the Collections panel, under Smart Collections, there's a set of options/filters - named something like: Colored Red, Five Stars, Past Month, Recently Modified, and so on.

I clicked on Past Month and found the original batch of photos shown there. I then drag and dropped the photos I wanted to add to the Collection I created. The only issue I had was that sometimes the drag'n'drop didn't "work/stick" so I had to keep trying several times on just one photo! I tried to drag'n'drop multiple files but that didn't work 😕

So, for me I found a way, and I hope that helps someone out there... BUT, in my opinion, this whole "method" is nonsense; if I choose to import files I want to be able to access ALL of my photos, regardless of whether or not I've previously imported them or not.

Importing is not the solution, if you have only removed the photos (accidentally) from the collection. The photos are still in Lightroom! All you have to do is click on All Photographs, find the desired photos in Lightroom, and add them to the collection again. You can add multiple files back to your collection this way. It's incredibly simple, just select all the photos, drag and drop into the collection.

Lightroom is designed to import the photos once. Yes, you can override this but that causes other problems, not recommended.

It is not the method that is nonsense, it is that people don't understand the system. Importing is done once! That's a very simple workflow! From then on, Lightroom can perform all the tasks needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2017 Apr 01, 2017

Copy link to clipboard

Copied

I currently have this problem with importing from a card.

LR imported a handful of images (it was actually a random selection - not sequential) and it didn't import them all. I know the advice here says that they were imported but aren't being shown but that's not the case. There were hundreds of images on the card and the import was only 82 images.

When I put the card in I get a grayed out thumbnail but can't come up with a way to import the images. I have tried clicking off the
"allow duplicates" toggle but nothing changes - the images are still grayed out. There's no way the images were imported because there wasn't enough time to import the entire card. The import was just a minute.

So this seems like a bug or problem with LR. Is there a work around or solution?

Gregor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 02, 2017 Apr 02, 2017

Copy link to clipboard

Copied

Obviously, you have not read this thread where several people have said that Importing is not the solution.

Please do the following search in Lightroom, performing ALL steps (not some of the steps) in order

  1. Click on All Photographs in the Lightroom Library module, it's on the left under Catalog
  2. Turn off all Filters (Ctrl-L once or twice)
  3. Expand all stacks (Photo->Stacking->Expand All Stacks)
  4. Search for the photos by file name using the Lightroom Filter Bar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 07, 2017 Apr 07, 2017

Copy link to clipboard

Copied

Obviously? In fact I did your four steps and it didn't work.

My question has to do with importing.

A clean formatted card is used in the camera.

New images are shot.

The card is inserted to the computer and "import" is selected.

"Don't Import Suspected Duplicates" is unchecked.

Some of the images are grayed out and some aren't.

I've not imported anything.

I thought perhaps LR was seeing the raw camera file name and rejecting the image on that basis but if I search for the grayed out files name it finds the image on the card but not in the library - which makes sense as it's not been imported. 

So, this seems to be a bug or a fault with this version. I can't see how else to explain it.

Gregor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2017 May 05, 2017

Copy link to clipboard

Copied

dj_paige

dj_paige just keep saying what you shouldn't do and that everything is wrong, but nothing about giving a clear answer to your problem. Obviously, dj_paige doesn't have a clue either

I had the same issue and create a new 'catalogue' and problem solved. Check about how Catalogues work in LR if you are interested, but create a new one, it's a quick fix

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

The solution has worked for others in this forum, and once you find the photos via that method, the problem is solved, there is no need to import.

The method you have stated, starting a new catalog and importing, causes you to lose the work you have done these photos in the first catalog.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

Same exact problem... what is happening?!  i formatted my card, shot new images for a magazine feature, and I am on a deadline... Put the card in the card reader, open lightroom, click import and a good section of my images are greyed out... They have never been imported so they are NOT duplicates.  It seems like a lot of people are having this problem and it's a BIG problem!!!  I am on a deadline to get these photos into the magazine and I can't even get them into LR.  Someone please help!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2018 Apr 07, 2018

Copy link to clipboard

Copied

This is probably too late, but create a new folder on your hard drive.  Move the new photos to that folder and import from there.  It needs to be a new folder with a unique name that you haven't used before.  Don't "sync" or do any other actions before importing.  That's the only fix I've found works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

LATEST

Connorand17...You are correct sir..THIS is the solution..new folder, new name, move all images you want to develop. open LR uncheck "Dont import etc.) BOOM..solved..thanks mate!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2020 Apr 06, 2020

Copy link to clipboard

Copied

Thanks so much for this! It was the only solution that's worked for me with this issue. Luckily I was also able to select multiple (the 15 photos that were being difficult) and drag them all into the Collection I wanted them to go in one move. Hope everything is running smoothly for you again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

2. To regain the old edits : Create the same physical folder structure in the explorer, as it was when files were imported to LR, And move/rename back the source files to their original locations . Now you can find the old edits still embedded on them in the Catalog > Previous Import.

 

This is an important point. I have been searching for ages how to re-edit an old dng file so that LR reinstates the original edits. I could of course edit my Photoshop image but I want to return to the edited LR image.  Turning off "Don't Import Suspected Duplicates" didn't work as LR knew this was an image that had previously been imported so was still greyed out. So how to get to the edited dng image?

In the bottom left hand corner of Lightroom (next to the two opposing arrows) you have a menu that by default will be set to 'Previous Import' - change to 'All Photographs' then a thumbnail of every photo catalogued by LR will appear complete with edits. It's that simple - but darn hard if you don't know how.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

That was the answer to my problem also. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

This did the trick for me, too. Thanks for a simple solution!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

This problem was resolved with the last update of the CC suite. I think given the improvement and resolution of the issue through the update that this wasn't an issue due to anything done by the user but was in fact a issue with the software. LR doesn't seen to be as well developed at Photoshop - in fact the different ways that similar tasks are approached makes me wonder if the two teams ever talk to each other.

Regardless, the issue was resolved for me with the most current update. Unfortunately I have lost some original files due to the glitch.

Gregor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 06, 2017 May 06, 2017

Copy link to clipboard

Copied

I am not aware of any bug fix to this issue, or problem being resolved, in the last update. Could you provide a reference?

As stated above by myself and RichardPLondon, this is not an issue that needs to be resolved, as Lightroom is operating as it was designed to operate, the default being to not import duplicates. Furthermore, there was really no intention to have Lightroom and Photoshop behave the same way on many issues, as Lightroom is an independent design.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 15, 2017 Jun 15, 2017

Copy link to clipboard

Copied

It's happened again today so I guess it's not fixed.

Explain to me how this can be happening:

A card is inserted into the laptop. The images were just shot, the card was formatted before. The images flow into the import window and all are clear and then, when the laptop has read them all half are suddenly grayed out - at random. They have not been previously imported because they were just shot. Why are some not grayed but others are grayed out - taken at essentially the same time.

Screen Shot 2017-06-15 at 9.49.17 PM.png

I'm at a loss. If I open the card and drag the images onto the desktop and then import them from there they will open fine.

What could be the reason? Is it possible that the camera naming is duplicated from some previous import or a camera counter rollover or repeat? That shouldn't make any difference...

Interestingly I can double click the grayed out images and they are there. I can right click the grayed out images and I am given a pop up menu that says "import this" with a check in front of it. If I click that it will import it singly.

Somehow Lightroom thinks that these images are imported already but of course they aren't if this is the first time the card is introduced to the machine.

Gregor

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines