Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Re-import photos on lightroom cc

New Here ,
Jul 07, 2018 Jul 07, 2018

Copy link to clipboard

Copied

Is it possible to re-import photos previously imported in lightroom cc? I have gone in to edit my product photos this morning and the photos I need aren't there so I must have accidently deleted them... I have attached my camera to import again and the photos are blacked out with 'previously added' on them when I hover over with my mouse. I have right clicked and the option to 'import this' is there but it doesn't do anything when I click on it. any help would be much appreciated, I don't have time to re-take photos!

Views

4.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 07, 2018 Jul 07, 2018
If Lightroom says 'previously added', then that should mean the photos are still in Lightroom. You haven't deleted them, just hidden them from view somehow. Check if you don't have any active filters.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 07, 2018 Jul 07, 2018

Copy link to clipboard

Copied

If Lightroom says 'previously added', then that should mean the photos are still in Lightroom. You haven't deleted them, just hidden them from view somehow. Check if you don't have any active filters.

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

I  have the same issue but the images that LR grays out and says "previously added" have Never been imported.  They are not hidden in any folder, LR cc, does not even allow to mark for import.  This answer is incorrect for this scenario. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2019 Oct 26, 2019

Copy link to clipboard

Copied

I'm having the same problem but its happening (far too often) with brand new images. Lightroom seems to refuse to import them. This is deal breaker level stupid.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

try to upload it using the web version, it work for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

I use Lightroom for work and home, and don't have easy access to the web version. With all due respect, it doesn't matter that it works for you. It needs to work for paying subscribers as we use this service. 

I use the app. I want the photos to be instantly available, whether I've imported them or not, in the app. 

It's ridiculous that there's no option that says 'Import again and rename' or something similar in this app. 

Let me be clear: We constantly upload THOUSANDS of images each week at the media organization where I work. 

We upload to Lightroom, do quick edits and then forget about them. 

I'm sure this is a common practice for many fast-paced businesses. 

It is inexcusable to not allow the option to re-import a photo that's previously used. 

Please escalate my comment to management, immediately. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

I agree.  Exact same issue.  How do we even get Adobe's attention on this matter?  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

I agree with those who say this is a deal-breaker. I use Lightroom for work and we have literally thousands of unfiled images in the system. If I WANT to re-import this photo so I can do quick edits, rather than scroll through THOUSANDS of images (totally inefficient; total time waster) to find the right image to edit, I should be able to do that, as a paying subscriber.

Please fix this. I'm not having it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

I had same issue. Just go to Lightroom Catalog, remove the photos you want to import again and import as new catalog. Is working.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

What if the images have never been imported and LR cc keeps marking them as "previously added" ? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2020 Dec 19, 2020

Copy link to clipboard

Copied

Has this issue been resolved yet? I'm have IG the same problem and very frustrating. I have a 8 hour shoot with about 1700 photos. Upload failed so I deleted all the photos. Now when I ru to re import says some are previously added"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

I'm dealing with the same problem and there seems to be no workaround...I need to reupload them. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

I'm in the process of doing that now. Now it's a bigger issue because it's picking and choosing only certain ones to upload. Big pain in butt. I even renamed and made new albums and everything. Adobe please fix this. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2020 Dec 26, 2020

Copy link to clipboard

Copied

I was having the same problem but then discovered that by selecting a different year from the 'By Date' filter I could bring them all back. For some bizarre reason some of my photos will only appear if I select 2019 as the date - even though the photos were taken a week ago and have the right date in their metadata.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2020 Dec 26, 2020

Copy link to clipboard

Copied

Update... That has stopped working now!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

What a pain! I did find after logging into the web version is found some of the ones that were missing but it's still a cluster.

Wish there was a refresh or reset button. I mainly do astro photography now, so im looking into other programs that are not connected to the cloud.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

I had a similar problem when I wanted to go back and do a new edit on photos.  The photos were gray and did not show as new so I was unable to import and work on them.  I looked for the catalog and, for whatever reason, I could not locate it.  I was able to fix it by re-naming the files.  Lightroom saw these now as new photos and allowed me to import them...again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

Same issue here, however when attempting to do a new upload on those "gray" images, it continued to say Previously Added.  No solution on my end yet. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

Go to Lightroom Catalog and delete the photos you want to import again. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2021 Jul 17, 2021

Copy link to clipboard

Copied

The problem is that I have previously deleted them from the catalogue but LR still thinks they are there, even though it's not displaying them 🤷‍:female_sign:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2021 Jul 17, 2021

Copy link to clipboard

Copied

But if I uncheck 'Don't import suspected duplicates' it's fine...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

There is no "filter" blocking the files from view... the truth is that Lightroom developers do not recognize the authority of the end-user to add a file when the end-user says it's appropriate.  Lightroom will not allow the re-import.  If you delete the Adobe database, re-import will be allowed.  Of course, you've screwed yourself with regard to all other things in the database that make the program work with regard to your other pics. In the Classic version, there is an option to ignore previously imported files, so you could possibly do it that way but then you are no longer in CC.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

Are people saying that if you delete an image from Lightroom Cloud (just making sure since some of the posts here seem to talk about Classic) and then try to import that same image again, it will refuse to import it? If so that is a bug. It should only refuse to import if the image is actually in the Lightroom Cloud library and then it should just be a quick search away.

In Classic, you can always force the reimport of an image by unchecking the "do not import suspected duplicates" checkbox.

 

Update:

I just tested deleting an image from Lightroom Cloudy and subsequently reimporting it and it reimported it just fine. If you see anything else, I am almost 100% certain the image is indeed already in your cloud library. Could be a bug that only manifests in rare circumstances but I would urge to go to "All Photos" and search for the filename in the search bar. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

I think there are different scenarios.  In my case (and others) is a brand new image to be imported on LRcc. LightroomCC says "previously imported" even when it has never been imported at all.  LR grays out the image alone without possibility to select it for import. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

Ah! That really only should happen if the filenames are the same and all the capture data (capture time and date) is the same. One thing to always do is to make sure your camera is set to sequentially number and to not restart numbering every time you reformat the memory card to avoid false positives based on filename. You should also make sure that the file's metadata does not get stripped at any stage before you import. I just tested with two different files that I named exactly the same and they get imported just fine. Of course that is because the capture time and date metadata is not the same even though the filenames are the same. 

 

If you get the message that it is already there while the actual image really is not there, this can only happen if your filename is identical AND if the capture time and date are identical (or have been stripped from the file).

 

That said, Adobe should really provide an override for this behavior like it does in Classic. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2