• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Generative expand starts when I right click any tool on the toolbar

Engaged ,
Aug 08, 2023 Aug 08, 2023

Copy link to clipboard

Copied

If I use the crop tool to expand an image beyond its current size and thus add a transparent area, right clicking any tool in the toolbar (eraser tool, hand tool, etc.) starts generative expand. Generative expand should only start if the user clicks Generate.

TOPICS
Desktop-Windows

Views

5.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Aug 09, 2023 Aug 09, 2023

Hi @Bazsl on the contrary, you are in control of how this reacts and this is not new behavior.

 

The crop tool (with or without Gen Expand) requires an accept or cancel.

Moving to another tool is considered an "accepting" movement meaning you are ok with the crop you've chosen.

If you have Gen Expand active, it will run.

 

If you dont want Gen Expand to run when you switch tools, change the option at the top of the Crop Tool. If you dont want the crop at all, hit cancel or Esc to remove the crop

...

Votes

Translate

Translate
Community Expert , Aug 09, 2023 Aug 09, 2023

Change the setting before you open a new document. That sets the default behavior of a tool.

Votes

Translate

Translate
Community Expert ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

Hi @Bazsl on the contrary, you are in control of how this reacts and this is not new behavior.

 

The crop tool (with or without Gen Expand) requires an accept or cancel.

Moving to another tool is considered an "accepting" movement meaning you are ok with the crop you've chosen.

If you have Gen Expand active, it will run.

 

If you dont want Gen Expand to run when you switch tools, change the option at the top of the Crop Tool. If you dont want the crop at all, hit cancel or Esc to remove the crop before switching tools.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2023 Sep 29, 2023

Copy link to clipboard

Copied

You are wrong. I have the same problem in Windows. Out of nowhere it won't let me crop without generative fill. Driving me crazy

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

You're definitely wrong.  Simply expanding the canvas size starts generative expand, the only way to stop it is clicking cancel and this also cancels resizing the canvas.  It's very poorly designed 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

@InfiniteWhale see my answer below you can change the default behavior of the tools with no document open to permanently change the setting. No need to use or cancel generative expand if you dont want to use.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 27, 2023 Nov 27, 2023

Copy link to clipboard

Copied

I had this problem too but I've found the answer,  for at least myself - clicking on the crop tool there is FILL in the menu above.  I found that GENERATIVE EXPAND was selected.  Changing it back to BACHGROUND then enabled me to add a crop of my own colour choice, no generative expand popup menu. Hth!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2024 Jan 11, 2024

Copy link to clipboard

Copied

Thank you for this! Should be the top answer!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 11, 2024 Jan 11, 2024

Copy link to clipboard

Copied

@gh30943181 its repetitive of the accepted answer above. Change the tool setting to prevent this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 27, 2024 May 27, 2024

Copy link to clipboard

Copied

LATEST

Your input is the only one that's right!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

The problem, for me, is that the drop-down setting on the top when using the crop tool is not sticky. Having to change the setting to transparent everytime I use the crop tool is annoying. Either they setting should be sticky or there should be an option in preferences to change the default. Thanks for your explanation.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

Change the setting before you open a new document. That sets the default behavior of a tool.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

Thanks, Kevin. I did not know that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2023 Nov 18, 2023

Copy link to clipboard

Copied

"Change the setting before you open a new document"

Sorry which "setting" is being talked about here? I've gone through the thread, everyone talking about a "setting"

Is it the Generative Expand setting?

"Change the setting"

Where? I didn't set anything, by default generative AI is forcefully taking over the crop too, so if I'm to change it, can someone please tell me where to find this setting?

I was hoping even 1 person would mention EXACTLY where that setting is.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

but setting this gross generative nonsense to default from the jump is...just gross. 0/10 photoshop what the heck

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2023 Nov 05, 2023

Copy link to clipboard

Copied

I'm having the same problem in Mac and now it has locked up my computer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

@Chrystine33405718yj7n this should not lock up your computer. Something else must be going on. Go to Photoshop Help Menu/System Info and copy/paste details in a reply. Post only once as the system takes time to process the large amount of data.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

yes let's blame the user

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 05, 2023 Dec 05, 2023

Copy link to clipboard

Copied

@happybana0 I did not blame the user. I asked for system information so we could better diagnose the issue at hand and find a solution. You seem to not want to solve this but simply complain based on your posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2023 Nov 20, 2023

Copy link to clipboard

Copied

NHTKHANH33735458sozi_2-1700484906459.png

 

 

When you click the crop tool, you can see on the right top, Fill, change generate expand => transparent default. So you can do it without AI.

f it, i had to search for 1 morning to find it 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

Thanks Khanh, you save my life :))

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines