Photoshop beta crashes when trying to use a sbsar asset

Community Beginner ,
May 29, 2022 May 29, 2022

Copy link to clipboard

Copied

Photoshop beta 23.4.0

Mac OS Monterey 12.4

 

I make a new document

I launch the Materials plugin

I load my sbsar Substance Painter file (I've just downloaded it today from substance3d.adobe.com). The icon stays grey unlike other files I've loaded.

I try to apply it on my document, and Photoshop crashes.

I use this sbsar file without problem in the latest version of Substance Painter.

 

TOPICS
Desktop-macOS

Views

269

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 07, 2022 Jun 07, 2022

@LaurentR2D2 , this could also happen if the material isn't completely uploaded. Could you check to see whether the material is loaded? It won't be grey if it's loaded.

Likes

Translate

Translate
Community Beginner ,
May 29, 2022 May 29, 2022

Copy link to clipboard

Copied

I've forgotten to mention that I run Photoshop on a Mac Studio Max.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

Hi LaurentR2D2,

 

Thanks for reporting this bug. Is it possible to have the name of the sbsar or better a link of it from substance3d.adobe.com? 

 

Best regards,
Robin Faury

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

@robinfaury , 'stylized_wool.sbsar' : I found this link: https://substance3d.adobe.com/assets/allassets/f0f5f68e44c14c0a3f1490bc87d6937e8ffecf56?format=sbsar...

I was able to use the preset on Mac Intel, 12.4. The preview took a few seconds to draw, but it eventually came in.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

It  is the sbsar I use

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2022 May 31, 2022

Copy link to clipboard

Copied

I have the same problem with these two other sbsar files :

Japanese Shiny Embroidered Peacock Fabric 

Japanese Shiny Embroidered Cranes Fabric 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2022 Jun 01, 2022

Copy link to clipboard

Copied

Hi LaurentR2D2 and Mark.Dahm,

Thanks for the link. I just wanted to check if the sbs file is available along the sbsar one.
We analise the log an files you send and we found that all thus sbsar do not have icon embedded. This result in a thumbnail generation. The sentence: "The preview took a few seconds to draw, but it eventually came in." is expected.
According to the log we may have a packaging issue of the tool for M1 computer. Can you confirm that by applying any default material on a Photoshop document? If you are able to do it that mean the issue may come from the icon.
Can you add an icon to the Substance file? To do so you have this tutorial https://www.youtube.com/watch?v=3-phGvdwkL0&ab_channel=AdobeSubstance3D and you can find the sbs from substance3d.adobe.com stylized_wool 

sbs.png

Thank you for your help and we are sorry for this issue.

Best regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2022 Jun 01, 2022

Copy link to clipboard

Copied

Hello,

I've applied some default materials, as well as Earthenware Wall Tiles which is one of my resources. It works fine.

I've followed the video to generate an icon, and checked with Substance Painter that the icon was well generated.

I've tried to import the material again in Photoshop, but the icon remains grey, and Photoshop crashes when I select it.

 

I've tried to delete the bad materials, to test a new import, but I've found no way to delete the materials. A single click applies it on the document, right click does nothing, and the trash icon on the bottom right of the window is always inactive. I haven't found where the materials are saved on my hard drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2022 Jun 01, 2022

Copy link to clipboard

Copied

I agree, the delete button isn't easy to use and we are currently working on it. You can highlight a collection of material by using MAJ+Left click or CTRL+Left click. This manipulation will select a material without apply it and the delete button will be accessible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2022 Jun 01, 2022

Copy link to clipboard

Copied

I've deleted the materials with MAJ+Left click. CTRL+Left click doesn't work on Mac. I've imported a new material with an icon, but the icon remains grey in Photoshop, and when I left click on it to apply it on the document, Photoshop crashes.

 

https://www.dropbox.com/s/7gis7cu0b68or6d/UXPLogs_2022-06-01_16-17-16_627600.log.zip?dl=0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

Hi again and sorry for the late response.
We try to reproduce your bug but on our M1 it's ok. I guess the model is different. Is it an issue for you to share the model/characteristics (number of GPUs, memory size) of your M1?
In the meantime can you check if your sbsar and its preview is well copied here:

/Users/$YOUR_NAME$/Library/Application Support/Adobe/UXP/PluginsStorage/PHSPBETA/23/Internal/com.adobe.photoshop-material-filters/PluginData/parametric_assets/custom_parametric_assets/user ?
If not can you try to do it manually (add the sbsar and an image as preview) and restart Photoshop?
Best regards.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

Hello

Here are some informations on my Mac :

Nom du modèle : Mac Studio
  Identifiant du modèle : Mac13,1
  Puce : Apple M1 Max
  Nombre total de cœurs : 10 (8 performance et 2 efficacité)
  Mémoire : 32 Go
  Version du programme interne du système : 7459.121.3
  Version du chargeur de système d’exploitation : 7459.121.3
Jeu de composants : Apple M1 Max
  Type : Processeur graphique
  Bus : Intégré
  Nombre total de cœurs : 24
  Fournisseur : Apple (0x106b)
  Metal Family : Pris en charge, Metal GPUFamily Apple 7
 
I've looked in the folder you mention. All the working materials are there as well as the broken ones. The working materials have their preview files, the broken one sizes are 0.
I've tried to delete all the materials from within Photoshop to do a new import. It doesn't work anymore. All I get are empty files, as you can see on the screenshot :
I've added manually some materials and their preview files. This way it works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

I've just tried to uninstall/reinstall Photoshop; and the problem remains. When I try to import a material, all I get is an empty file in the folder you mention.

https://www.dropbox.com/s/vhltnwkdhnnxulm/UXPLogs_2022-06-03_00-20-35_286480.log.zip?dl=0 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

@LaurentR2D2 , this could also happen if the material isn't completely uploaded. Could you check to see whether the material is loaded? It won't be grey if it's loaded.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2022 Jun 08, 2022

Copy link to clipboard

Copied

I don't understand exactly what you mean, but the problem seems to have disapeared today. I've imported without problem several sbsar files into Photoshop. Since you have no problem with your M1 machine, it was perhaps a problem related to my Mac during the copy of the sbsar files between my download folder and the user custom_parametric_assets folder of Photoshop. If I have this problem again, I'll ask in a Mac forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 08, 2022 Jun 08, 2022

Copy link to clipboard

Copied

LATEST

I'm very happy to see you do not have the issue now. Yesterday I try on a similar computer and I do not reproduce. Thanks for the testing, it's very useful, we are currently adding more check on the file size to avoid future crashes. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines