• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

*weird/unusable* selection behavior (marching ants waaaay offset) | 25.2.0 m.2388 | Win10

Participant ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Hello all.  Some weird and totally unusable selection behavior with the latest beta:

True for lasso, marquis, quick selection tools: making a selection is impossible.  Where I draw (mouse or pen+tablet), the marching ants are significantly offset (e.g. 1/3 of the image away).  Prior versions of the beta worked as expected.

If I use "select subject", that works correctly.  It appears to be related to drawing the selection.

Also when the image first opens, it's also offset to the left and upper quadrant (see attached screenshot).  All things work fine in prior beta versions.
All things work fine in the most up to date version of PS (released)
I uninstalled and reinstalled the beta, weird behavior persists (although I did not remove prefs).

Windows 10 is current.

Attached screenshot of newly opened image, and sys info txt file.

TOPICS
Desktop-Windows

Views

183

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Nov 07, 2023 Nov 07, 2023

I had the same problem. I fix it by Going to Preferences > Technology Previews... and check "Deactivate Native Canvas" - then restart Photoshop.

Votes

Translate

Translate
Participant ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Not sure if my attachments actually got included, so trying again.  Screen shot of how a newly opened file looks relative to the frame for the file.

Adobe PS, Beta bug 01.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Jerry, I can't duplicate this here, and I am also using Windows.  The beta version definitely seems to get its knickers in a twist way more often than the full release version, so I suspect you are going to need to reset Preferences.  The Development Team member who has been working this forum is generally suggesting a manual reset, so I guess it must be more reliable,.

https://helpx.adobe.com/ie/photoshop/using/preferences.html#Manually

 

Good luck, and please let us know if it worked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

Hi Trevor.

I've isolated the bug. I spent some time carefully making prefs changes, one at a time, closing and relaunching PS with each iteration.

After removing the settings folder, launch PS.  Problem does not show up.  Then, in prefs, make the changes corresponding to the attached screen shot.  Close and relaunch PS Beta.  Boom.

And no need to even zap the settings folder.  In Prefs/General, just reset the prefs when quitting is sufficient to get back to the pristine state.  Relaunch PS, behavior is fine until the changes below are made.

PS Beta prefs, causing offset bug.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

More isolation:

1. Pristine prefs (default settings).

2. Open an existing file (it will be a tabbed document in PS)

3. Drag on the tab handle, and all is kerflukt.

Screen shots:
Tabbed doc:
PS Beta bug, tabbed file 01.JPG

2. After dragging on the tab handle just a little:
PS Beta bug, tabbed file 02 (BUG).JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

I had the same problem. I fix it by Going to Preferences > Technology Previews... and check "Deactivate Native Canvas" - then restart Photoshop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

LATEST

Confirming ekisky's solution works!!!!

From ekisky's post:
"Preferences > Technology Previews... and check "Deactivate Native Canvas" - then restart Photoshop."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines