• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

P: Action stops when trying to apply layer effect

3 Votes
LEGEND ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

I've created an action in Photoshop CS5 which should apply a layer effect (inner shadow) to a textlayer. But every time i run this action it stops at the point the layer effect should be applied and I have to select the shape (I hope, this is the correct description, as I only have the german version of Photoshop. There it's called "Kontur") and click "OK" to let the action finish. Is there a solution to this problem?

Bug Fixed
TOPICS
macOS , Windows

Views

199

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 01, 2012 Nov 01, 2012
This has been fixed in CS6.

The workaround for CS5 and earlier is to save a custom style, and then apply that style (via the Styles panel) when recording the action.

Votes

Translate

Translate
13 Comments
Adobe Employee ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

Do you have the show dialogs toggle turned on?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

Hello Jeffrey

Thank you for your reply.
No, this toggle is not turned on. The problem also seems to be reproducable, as it won't work on another PC neither.

Kind regards
Urs

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

Can you post the action or a screen shot of the actions steps (similar to mine) so we can take a closer look?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

You can download the action from http://www.uhphoto.ch/files/forum.atn...

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

Interesting. If you play step 12, a dialog pops open when it shouldn't. Seems tied to the fact that the Global Light checkbox is off, because if I double click that step to update it's settings so Global Light is checked/enabled, and rerun the action it runs correctly.

I'll have someone look into it.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

This is actually a known issue that happens when you change the contour setting on a layer style to something other than the default.

For now, the workaround is to save a custom style, and then apply that style (via the Styles panel) when recording the action.

Let me know if this doesn't work for you, or if you need more information.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2011 Oct 20, 2011

Copy link to clipboard

Copied

Hello Jeanne

Thank you for your reply. When using a custom style it works now (tried it before already, but it seems, that the Global Light checkbox has to be checked in order to work).

Kind regards
Urs

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 01, 2012 Nov 01, 2012

Copy link to clipboard

Copied

This has been fixed in CS6.

The workaround for CS5 and earlier is to save a custom style, and then apply that style (via the Styles panel) when recording the action.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 01, 2012 Nov 01, 2012

Copy link to clipboard

Copied

I have an action set up to lower resolution and place a copyright on the photos.
It works sometimes. Sometimes it hangs up, most often on first "Set Layer Styles of Current Layer", Sometimes on second "Set current layer". sometimes it won't hang up at all 🙂 All I have to do is hit enter, but it gets annoying when I'm doing 30 or more photos at once.

Thanks,
bndphoto

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 16, 2013 Jul 16, 2013

Copy link to clipboard

Copied

I was using Photoshop CC and encounter a similar issue: For actions having steps with custom layer style, some of those set layer style steps will always pop up dialog, even the show dialog switch is off.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 17, 2013 Jul 17, 2013

Copy link to clipboard

Copied

Those actions may not have all the settings, which will force the dialog to show. This could happen for actions recorded on older versions of Photoshop (which didn't have all the same options for styles).

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 17, 2013 Jul 17, 2013

Copy link to clipboard

Copied

Thanks! That make sense... do you have any idea how can I migrate them?

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 17, 2013 Jul 17, 2013

Copy link to clipboard

Copied

LATEST
Updating the steps in the current version should work just fine.

Votes

Translate

Translate

Report

Report