P: Contextual (right click) brush menu fails to load pressure sensitive preview

1 Vote
Participant ,
Dec 09, 2014 Dec 09, 2014

Copy link to clipboard

Copied

This bug is 100% replicable across several versions of Photoshop. including cs5, cs6, and the latest CC (on PC though I haven't tested on Mac).

Steps to reproduce:
- Open Photoshop
- Open or create a document
- Select brush tool
- Right click within the document with a mouse (specifically a non-pressure sensitive input device), bringing up the brushes panel
- Click gear icon at upper right
- In the pull-down menu, select "Stroke Thumbnail" (if it isn't already)
- Observe that stroke thumbnail ignores pressure settings and renders brush previews as 100% for all pressure sensitive values (image 1)

If you repeat the exact same steps, but with a pressure sensitive stylus instead of a mouse, the brushes panel will display correctly (image 2)

Image 1 (my brushes displaying incorrectly)
pressure1_inline-ba6d02fc-9b36-4cf6-9c80-72a0339cf0d0-1453249517.jpgpressure1_inline-ba6d02fc-9b36-4cf6-9c80-72a0339cf0d0-1453249517.jpg

Image 2 (my brushes displaying correctly)
pressure2_inline-2cbe1e23-fa94-425a-80a6-aa8ce0033071-803661549.jpgpressure2_inline-2cbe1e23-fa94-425a-80a6-aa8ce0033071-803661549.jpg

The frustration comes from the fact that whichever you use to display the brushes panel first will lock it in until you restart Photoshop. That is to say, if you right click with the mouse first, the brush stroke preview will display incorrectly and subsequent right clicks with the pressure sensitive stylus will also display incorrectly.

Likewise, if the right click context menu is initiated with the stylus when you first open Photoshop, the mouse button will also display the correct, pressure sensitive preview.

Bug Acknowledged
TOPICS
macOS , Windows

Views

16

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Employee , Jun 15, 2015 Jun 15, 2015
This should be fixed in the Photoshop CC (2015) update.

Votes

Translate

Translate
Adobe Employee , Dec 10, 2014 Dec 10, 2014
Should be fixed in the 2014.2.2 update. Choose Help>Updates... to install.

Votes

Translate

Translate
Adobe Employee , Dec 10, 2014 Dec 10, 2014
Eng team is looking into this.

Votes

Translate

Translate
16 Comments
Adobe Employee ,
Dec 10, 2014 Dec 10, 2014

Copy link to clipboard

Copied

Eng team is looking into this.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 10, 2014 Dec 10, 2014

Copy link to clipboard

Copied

Should be fixed in the 2014.2.2 update. Choose Help>Updates... to install.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Participant ,
Jan 13, 2015 Jan 13, 2015

Copy link to clipboard

Copied

Unfortunately the problem persists exactly as before in 2014.2.2

Votes

Translate

Translate

Report

Report
Participant ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

As in this isn't actually resolved...

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Using 2014.2.2, running on Win 8
For me I get no pressure preview when initially invoked with a mouse (which is expected on Windows), but after using stylus it gets the pressure preview and stays that way through the session. Initial invocation with stylus has pressure preview and stays that way when invoking with a mouse.

Votes

Translate

Translate

Report

Report
Participant ,
Feb 05, 2015 Feb 05, 2015

Copy link to clipboard

Copied

Hmmm, Not so with mine. Pressure sensitivity works within a document when I apply a stroke with my stylus, but the preview in the brush palette is still the non pressure version.

I deleted my preferences and the same behavior occurs.

For what it's worth I'm on fully updated Win 7 machine with an Nvidia graphics card, latest drivers, a Microsoft mouse, and a Cintiq 21UX with latest drivers.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 15, 2015 Jun 15, 2015

Copy link to clipboard

Copied

This should be fixed in the Photoshop CC (2015) update.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Participant ,
Sep 25, 2015 Sep 25, 2015

Copy link to clipboard

Copied

This is still not solved - I am now in a different office, on a new computer, running a different OS, on CC 15

Votes

Translate

Translate

Report

Report
Participant ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

Hey guys, remember when you said this annoying bug was fixed...lol

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

> Hey guys, remember when you said this annoying bug was fixed...lol>

Are you talking about the simple brushes that ship with CC 2018, or custom brushes that are pressure sensitive, but set to sensitivity in different categories, depending upon the brush? In the first case, Adobe spells out that it's a pressure sensitive brush, and the bug you displayed is fixed on my Mac, mouse or stylus. If it doesn't look like this on your machine, perhaps you could again provide a screenshot?

RackMultipart20180207458521l6m-4f5e5247-bbd3-466b-9826-31223fdb6137-1967678022.jpg

In the latter case, I'm not sure how PS would know that Pressure sensitivity was involved with the brush:

RackMultipart20180207129380mnw-4e841221-06dc-439d-95ac-aef041b090df-306845437.jpg

In these, tapering tends to show that Pen Pressure has been applied with Shape Dynamics. Anywhere else, it doesn't show up. If you add Shape Dynamics to a brush that doesn't have it, and use Pen Pressure and save it as a a new Preset, it will also show in the c-s menu, but not if the brush you're using hasn't been saved with that setting. Here I resaved a brush with new settings (including Color to make it obvious).

RackMultipart201802071501618bb-c0c0d4d1-9bf8-44dd-a274-743a2a43f0ce-2035557647.jpg

Again, if you don't get the same results with 2018, please come back and show us what you do see.

Votes

Translate

Translate

Report

Report
Participant ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

Thank you for the reply, Cristen.

I'm talking about any brush that has pressure sensitive settings enabled (opacity, flow, size, etc.), whether default or custom, on a completely clean install or an install with imported preferences, across 3 versions of Windows, on nVidia and ATI cards, with latest drivers, for the past decade. Stroke previews, if invoked first with the mouse right click, is rendered ignoring all pressure sensitive settings until I restart PS.

So here's a fun lil' thing Photoshop CC does related to this bug: it straight up doesn't recognize Wacom pressure sensitivity in Win 10, unless you add a nifty little file to your PS prefs (see the solution that not-an-adobe-dev came up with here:https://forums.adobe.com/thread/2398372, after an adobe dev gave the ever-so-helpful "check you drivers" speech)

Anyway, this is still happening in  PS cc 2018 (19.1.0), running on up-to-date everything running  Win 10, gtx 970 video card. Adobe, can you and Wacom just be cool with each other and make sure your products work together?

The screenshots below are from cc2017, but the behavior persists in 2018 as well.

How it should appear:
RackMultipart201802125650e3bfx-32058445-c77d-4cd6-9706-9b7b2586a4f1-1179154813.jpg

How it actually appears:
RackMultipart20180212526011olz-a8268643-87ca-4c11-9660-b75db2f1abf7-2102545560.jpg

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

The solution posted by the user on the forum is taken directly from our documentation: https://helpx.adobe.com/photoshop/kb/enable-optional-extensions-photoshop-cc.html#turn_off_system_st...

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

So on Windows there's that conflict with Windows Ink I see mentioned often? Sounds like a Microsoft issue, since it doesn't appear to affect us Mac-ers. I always see the tapered stroke if it was saved with Pressure sensitivity. Definitely a lot more helpful to see than what he's showing in his screenshot, though that still leaves room for a ton of gotchas when working with them.  '-}

Votes

Translate

Translate

Report

Report
Participant ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

Jeffrey Tranberry,  Thank you for the clarification, I wasn't aware of this page... Unfortunately it doesn't fix this particular bug, it's just confirmation of an unfortunate workaround that exists that for a different Wacom bug, and as I correctly (albeit snarkily) stated, was offered by forum member after a characteristic runaround comment was offered by an Adobe employee. It is an unfortunate pattern of evasion and deflection and my snark is the result of bug like this lingering for years.

As is the case with this issue: it is still a bug (it may even be several bugs) on the Windows platform with a really popular piece of peripheral hardware. Maybe it's a Wacom thing, maybe it's a Windows bug - it really doesn't matter to me as a user. I just want to not have to restart PS every time I accidentally right click with my mouse and you said this was fixed when it wasn't. So please, proactively coordinate with Wacom and MS to solve this and other bugs whose culprit is difficult to pinpoint. If not you then who?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

I've asked our Wacom tester/expert to look into this.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Participant ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

LATEST
I really appreciate it, Jeffrey.

Votes

Translate

Translate

Report

Report