P: "Save for Web" error when "My Documents" network path is disconnected

4 Votes
Explorer ,
Jun 24, 2011 Jun 24, 2011

Copy link to clipboard

Copied

On my PC, "My Documents" is mapped to a network drive. Whenever the network drive is disconnected, Photoshop throws an error when trying to bring up the "Save for web" dialog box. The error is: "The operation could not be completed. The system cannot find the path specified." When I click OK on this error message popup, the popup goes away and nothing else happens. The "Save for web" dialog is not accessible.

This is especially a problem when I travel with my PC and need to use Photoshop on the road, since I cannot connect to my network drive for My Documents. I understand that the system cannot find the path specified, but it shouldn't bail on the "Save for web" dialog because of it. Use a different default path. I'm not sure why it's looking for that path anyway, since it happens even when my last saved file isn't in "My Documents".

Bug Fixed
TOPICS
Windows

Views

296

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Dec 16, 2016 Dec 16, 2016
Had same problem and found the foolowing solution. All you need to edit registry entry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders The entry for "Personal" was set to an external that was not connected so you can set it to a location on HD (e.g. %USERPROFILE%\Documents or any other) This worked for me

Votes

Translate

Translate
25 Comments
Guest
Jun 27, 2011 Jun 27, 2011

Copy link to clipboard

Copied

Could you please provide your OS, Server type? I try to map my document to network drive on XP and S4W pop up error message after I click Save button.

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 27, 2011 Jun 27, 2011

Copy link to clipboard

Copied

Vista. I don't think Server type applies. It's just a drive mapping to a network share on another PC.

Votes

Translate

Translate

Report

Report
Explorer ,
Jun 27, 2011 Jun 27, 2011

Copy link to clipboard

Copied

Maybe I should mention, the PC with the network share is Windows 7.

Votes

Translate

Translate

Report

Report
Guest
Jun 28, 2011 Jun 28, 2011

Copy link to clipboard

Copied

Hi I can reproduce this problem on Vista, you are right, it is have no relationship with server type. It is a vista only bug. Will report a bug, thanks for your report.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 07, 2011 Dec 07, 2011

Copy link to clipboard

Copied

I am having the same issue and cannot complete an assignment for school. Ping, have you identified the steps to correct this? I am running Windows XP and am on a network as well.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 16, 2012 Jan 16, 2012

Copy link to clipboard

Copied

Had same problem and found the foolowing solution. All you need to edit registry entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

The entry for "Personal" was set to an external that was not connected so you can set it to a location on HD (e.g. %USERPROFILE%\Documents or any other)

Votes

Translate

Translate

Report

Report
New Here ,
Aug 28, 2013 Aug 28, 2013

Copy link to clipboard

Copied

I am having the same issue in adobe CC

Votes

Translate

Translate

Report

Report
New Here ,
Aug 28, 2013 Aug 28, 2013

Copy link to clipboard

Copied

My registery does say %USERPROFILE%

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 17, 2013 Oct 17, 2013

Copy link to clipboard

Copied

This works for me, The registry entry was pointing to the old profile path. Put in the new profile path and is works fine.

Thanks.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 24, 2013 Oct 24, 2013

Copy link to clipboard

Copied

or just go to documents right click properties > Location > Restore Default...

Apply it to any folder that needs to.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 19, 2014 Jun 19, 2014

Copy link to clipboard

Copied

Is there no solution for this problem at this point? I am running Vista for my OS. Any help on this matter would be appreciated, thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 29, 2014 Jul 29, 2014

Copy link to clipboard

Copied

I recently opened an old user account on my machine; began having problems with Photoshop CC 2014 and Premiere CC 2014 not being able to find system folders (e.g., My Documents). The registry edit solution by Sergei still works on my Windows 7 machine. Thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 20, 2015 Feb 20, 2015

Copy link to clipboard

Copied

I was having the same trouble and ended up discovering that my file name was too long to save to the server I'm using.

If you're trying to save remotely, try saving locally and see if that works. If so, it may be due to the file name length.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

Had same problem and found the foolowing solution. All you need to edit registry entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

The entry for "Personal" was set to an external that was not connected so you can set it to a location on HD (e.g. %USERPROFILE%\Documents or any other)


This worked for me

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 28, 2016 Dec 28, 2016

Copy link to clipboard

Copied

This worked for me too. Thanks so much. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 04, 2017 Jan 04, 2017

Copy link to clipboard

Copied

This solution worked for me, as well. I had re-located the My Documents folder while setting up a new computer, and the "Personal" registry entry did not get updated. I was having problems when launching Photoshop CC 2017 as well as when using the Export As and Generator functions. All three resolved with this fix. Thank you, Sergei, for posting this solution!

Votes

Translate

Translate

Report

Report
LEGEND ,
May 11, 2018 May 11, 2018

Copy link to clipboard

Copied

This solved my problem. Thanks! 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jul 23, 2018 Jul 23, 2018

Copy link to clipboard

Copied

Thanks Sergei Chepa,

This helps a lot. and is works. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 01, 2018 Oct 01, 2018

Copy link to clipboard

Copied

Great it works Thankyou!

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 17, 2019 Mar 17, 2019

Copy link to clipboard

Copied

Thank you

Votes

Translate

Translate

Report

Report
Participant ,
Jul 12, 2019 Jul 12, 2019

Copy link to clipboard

Copied

In my case the data drive was with changed drive letter ergo my absolute paths were different. Thanks to the registry tip I saw what was the problem. Just reassigned the correct letter to the correct driver instead of editing the registry.

Thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 06, 2019 Sep 06, 2019

Copy link to clipboard

Copied

this seems permission issue follow easy step : https://www.youtube.com/watch?v=l6bnyxhXjuQ

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 08, 2019 Dec 08, 2019

Copy link to clipboard

Copied

great  %USERPROFILE%\Documents  open Permission every one thank...

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 08, 2019 Dec 08, 2019

Copy link to clipboard

Copied

Windows Bitdefence close restart photoshop 

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 04, 2020 Mar 04, 2020

Copy link to clipboard

Copied

LATEST
I had the same problem and it was a consequence of how I'd written the path to my Windows Documents folder, which I keep on a NAS/network drive. I didn't have to change the location of the Documents folder, just the way I wrote the path.

In Windows, I had designated the location of Documents using the drive letter for a mapped network drive—on my machine, it was R:\[etc.], but it could have been any network drive letter.

I fixed the issue by editing the way I was pointing to the location for my documents folder. I didn't change where the folder was, just the way I wrote the path.

Simplest way is to re-write the path is to right-click the Documents folder in Windows file explorer, select Properties, and select the Location tab, where you can edit the path. In my case, I changed it to:

\\myNAS\home\...[etc.]...\documents

[Substitute the actual path to your documents, but avoid using a mapped drive letter like the "R:\" in my initial example.]



Votes

Translate

Translate

Report

Report