Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


3d workspace not working

New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

Hi! I am having trouble getting my workspace to properly display in 3D. It was working fine yesteray. I tried resetting my workspace and even reinstalling photoshop, but when it still won't display the way it should. And if I click any of the camera controls or light controls or material controls, it splits the object into 4 fragments. 

The attached image is supposed to be a pyramid. All the 3d view options are checked to show in the view menu. what happened??

tearing my hair out over here.

Views

3.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 21, 2021 May 21, 2021
If you are using Photoshop v 22.4 or 22.4.1 can you go to Preferences >Technology Previews and check "Deactivate Native Canvas" then close and restart Photoshop Dave

Likes

Translate

Translate
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

If you are using Photoshop v 22.4 or 22.4.1 can you go to Preferences >Technology Previews and check "Deactivate Native Canvas" then close and restart Photoshop

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

that did it! thanks so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

You're welcome

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Hi Dave

I had both [View] [Show] ...

  • [3D Ground Plane]
  • [3D Lights]

both selected and could not understand why I could not see either when in 3D workspace!

Have spent absolutely ages trying to fathom out why this was happening.

Thanks for your solution. I presume accepting the latest updates has caused this to occur?

Adobe does have that ability to provoke oneself to question our senility!

Kind regards

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Hi

Yes it was in the last update.

A bit of background on the video card :
Adobe are updating the core graphics functions in Photoshop. This is driven by the operating systems of Apple and Microsoft in which the old Open GL functions are being removed in the case of Apple, or deprecated in the case of Microsoft. This means that the graphics functions that have worked for years must be rewritten to use Metal and Direct X. At the same time, Adobe are sensibly updating those core functions to deliver the additional speed we require to handle the very large files of today.

Some functionality in Photoshop, such as 3D and Lighting effects, still relies on the older Open GL graphics functions. To make these work, an additional preference Preferences>Technology previews>Deactivate Native Canvas has been added in v22.4. This can be checked and Photoshop restarted to restore 3D functions to where they were in 22.3

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2021 Jul 25, 2021

Copy link to clipboard

Copied

"New Mesh from Layer" is grayed out.  Can't rotate or do anything after making a 3d object.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

What kind of layer?

What image mode?

What have you done to troubleshoot so far, have you carried out the steps in this thread and restarted Photoshop?

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Hi Dave.. thanks for reaching out!
I tried everything mentioned on the threads etc.  I taught photoshop in Atlanta at three schools and had no trouble in the past creating the 3d shapes, etc.  I went to Performance and made sure Graphics processor was activated and deactivated Native Canvas.
"3D New Mesh From Layer" is grayed out so I can't make a cylinder?  
Not sure what's going on?
Thanks,Don

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Can you show a sceenshot, including your layers panel just before you use 3D New Mesh from Layer

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Hi Dave... this is as far as I can get...   used to be able to create dozens of these 3d images when I was teaching at The Creative Circus Communications Art school in Atlanta.  The "New Mountains" file is an example of the finished project.  If I can't figure this out I'l have to unsubscribe.  I have 5 days left on the trial version.  Thanks for any help.

-Don

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Hi

The GTX775M is an old GPU and it may be failing the tests for using teh newer graphics functions. A bit of background and something you could try (3 and 4 below):


1. Adobe are updating the core graphics functions in Photoshop. This is driven by the operating systems of Apple and Microsoft in which the old Open GL/OpenCL functions are being removed in the case of Apple, or deprecated in the case of Microsoft. This means that the graphics functions that have worked for years must be rewritten to use Metal and Direct X. At the same time, Adobe are sensibly updating those core functions to deliver the additional speed we require to handle the very large files of today.
2. Led by the changes being made above, Adobe introduced new GPU checks in 23.3.1. Unfortunately, these caused issues and have therefore been revised for v22.4. That means that many GPUs that incorrectly did not work in 22.3.1 will now be seen in 22.4 and will function.
3. Some functionality in Photoshop, such as 3D, still relies on the older Open GL graphics functions. To make these work, an additional preference Preferences>Technology previews>Deactivate Native Canvas has been added. This can be checked and Photoshop restarted to restore 3D functions to where they were in 22.3
4. Unfortunately, the move to update the core graphics functions will mean that some older GPUs will no longer be suitable. If you are using 22.4 and your GPU is still not recognised or being used, first make sure the driver is up to date. If it is and you only have a single GPU enabled ( conflicting GPUs remain an issue) then you could try and force Photoshop to use your older GPU by creating a file PSUserConfig.txt containing the lines:
# Force GPU On
GPUForce 1
Save that text file to :
Windows: [InstallationDrive]:\Users \ [UserName]\ AppData\ Roaming\ Adobe\ [Photoshop_version]\[Photoshop_version]Settings\
macOS: //Users/[UserName]/Library/Preferences/[Photoshop_version]Settings/
Note though that this requires 22.4 or later and is not officially supported by Adobe, so may cause other issues – so you do it at your own risk

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

LATEST

Ok thanks.. I'll probably stick to my old cs6!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines