• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Arabic text direction is default, and it drives me crazy.

Community Beginner ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

This is driving me crazy.

Every time I draw a new text box and type something, the paragraph direction switches to Arabic right-to-left. I want latin left-to-right as a default, always.
The language is set to Dutch or English, so this is not the problem.

How do I make latin left-to-right the default, and make it never switch to Arabic right-to-left again?
Thanks!!

Schermafbeelding 2021-11-22 om 15.10.30.png

 

TOPICS
macOS

Views

755

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 07, 2022 Jan 07, 2022

Please go the the preference dialog and select interface. The UI language should be English, if it is not English please reinstall/add an English version of the product.

Screen Shot 2022-01-07 at 11.07.10 AM.png

Likes

Translate

Translate
Community Expert ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

I belive you need to change the default Paragraph Style named "Basic Paragraph" found in Paragraph Style panel which is dictating text attributes to your new text including Text Direction and few other formatting settings. Sadly, I couldn't find a way yet to delete the "Basic Pargraph" and replace it with my own settings.

 

Here is a link to how to add your own "Default Type Style", you can see it is not as easy as InDesign where we can change default text and frame defaults once and it will stick for good.

Note. Following the instructions found at the bottom of the page I linked up here, I created my own "Default Type Style", I had to load this default style each time I create a new document, yet I still have to clear overrides each time I create a new text frame, so I believe having Default Type Style didn't reduce the effort of changing direction each time !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Thank you!

The problem isn't solved yet: the default paragraph setting 'Latin and East Asian Layout' (Latin left-to-right) keeps jumping to 'World ready Layout' (Arabic right to left) when I click in the canvas with the type tool.

Extremely annoying 🙂

Any other tip to solve this is greatly appreciated!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Hi, which version is it?

I would reset the text tool, and both text and character panels, the text tool by a right-click on its icon in the option bar, and the panels, by a click on their top right hamburger menus, then the reset at the bottom of the drop down list.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Photoshop CC 23.0.2.

  • I changed the type tool preset (but when I click to make a textbox it jumps back to 'Right-to-left Paragraph direction').
  • I resetted the Paragraph Panel (also jumps back to 'Right-to-left Paragraph direction, it seems a default on a very deep level!)
  • I resetted the Character Panel (jumps from the font I choose, back to Myriad Arabic).

AAAAARRGG 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

What is the install language in Creative Cloud?

Did you reset the type tool, instead of selecting another preset.

 

I would then try to recreate the preferences, using the manual system, to keep the faulty ones on the desktop, in case the team needs them: 
See: https://helpx.adobe.com/photoshop/using/preferences.html#Manually

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

About the language in CC it says under info: "English and 23 other languages".

I deleted the old type tool, made a new one with the correct left-to-right settings, saved it, loaded it.

When I select the type tool, all settings are okay. But at the moment I click to make a textbox, everything jumps to Arabic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

In the Paragraph Panel's local (hamburger) menu, select "Default Features" rather than "Middle Eastern Features"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Thank you!

It is set to 'Default features'. But it jumps to 'Middle Eastern Features' at the moment I make a new textbox.

I recorded it, so you can see the settings of the Type tool, and the moment it changes.

Video (can't embed) https://i.imgur.com/SDZvSiT.mp4

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

I believe that the world ready layout is normal, the new default, but not the switching to RtL, or arabic settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

I also deleted the Photoshop 22 presets in the library. The default is still Arabic...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

The machine I'm on is 23.0.0 but I noticed something odd: when I select, in the Character Panel's local menu, the Middle Eastern Features/Left to Right direction, I get a load ACO window!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

Hi Stweart, I tried to provide a solution but I couldn't, the same problem you're facing is happening with me. So the suggestions I placed up here were not a solution, but thinking loudly rather.

Knowing how to change Defaults in Illustrator and InDesign, I thought I can do the same in Photoshop, but couldn't. I still believe we needs to change the "Basic Paragraph" style, but so far the changes I made to this default style doesn't stick for good.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

You have exactly the same issue? Wasn't that a problem you noticed before?

Thanks a lot for thinking along!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 03, 2021 Dec 03, 2021

Copy link to clipboard

Copied

I don't type much in Photoshop, I simply prepare the images in Ps, then place them into InDesign or Illustrator, and place the text in Id and Ai.

 

Having said that, I don't recall this issue in previous Photoshop versions. Remember, current Photoshop has an all new Unified Text Engine that supports Middle Eastern languages among many other oriental languages. So this issue you and I are facing could be a bug associated with this new text engine, but I could be wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Looks like customer has installed Middle Eastern or North African version of Photoshop. If you install standard European SKU the problem won't happen. We will investigate any behavioral change introduced with latest release too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Thank you. That IS possible, yes. What would be the way to check that?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Please go the the preference dialog and select interface. The UI language should be English, if it is not English please reinstall/add an English version of the product.

Screen Shot 2022-01-07 at 11.07.10 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Indeed! It says "English: Arabic enabled". I think I did that a long time ago, because I had to design with Arabic texts... I'm going to reinstall it right away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

You don't need to install a special version of Photoshop to have Arabic or any script as of version 23.0 released in 2021 Nov. Latest version of Photoshop has an all new Unified Text Engine that supports most of the scripts ranging from Arabic to Japanese and Indic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

I deleted my Photoshop and settings, and reinstalled it. But the problem isn't solved.

I don't see where to choose 'English' only, it still says "English: Arabic enabled" when I check the preferences...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 09, 2022 Jan 09, 2022

Copy link to clipboard

Copied

Hello, you need to change the install language setting in the preferences of the creative cloud application: https://helpx.adobe.com/creative-cloud/help/change-install-language.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2022 Jan 09, 2022

Copy link to clipboard

Copied

LATEST

Thank you so much!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines