Can't open PNG in Photoshop

New Here ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

I updated my Photoshop file from the Adobe CC to the latest version, which is version 19.0.1. Anyways, now whenever I try to open a PNG file to edit in Photoshop or place both an embeded and linked image in a Photoshop file, I get an error message that pops up and says that it cannot open it, saying that it's not a PNG file. I checked the properties to the image I want to edit, it is a PNG. I can manage to save out as a PNG file, I just can't open or place an image. I'm not sure if it is a server error because I did save it online and the image I am sharing is a screenshot I took and it is originally a PNG file, or maybe it is a glitch with Mac users because my operating system is Windows 10.

Views

56.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Deleted User
Mar 13, 2018 Mar 13, 2018
The issue has been fixed in the latest updateMore infoFixed issues in Adobe Photoshop CC

Likes

Translate

Translate
Adobe Community Professional ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Hi. Has the file the correct extension (.png)? Sometimes that is a problem in Windows with Mac files. Have you tried to open other png files? Also, Have you tried to place that file in other apps like InDesign or Illustrator?

Marlon Ceballos.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

I have tried to open it in Illustrator and it still would not work, so it might be an issue with the extensions. I actually meant to say PC instead of Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Will your web browser display the png you can not open in Photoshop?

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Yes the web browser can view the image, as well as opening it up in the photos app.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

Post the png in here we should the be able to see it and download it to our machine. I will test it on my windows 10 system.  I have CS6, CC 2014 and CC 2018 installed.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

_commish__forrest_s_special_feh_style_by_glassesgator-dbtr4am.png

I downloaded this from DeviantArt so it might just be a problem with the website

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

HELP!  My business logos are all transparent png files and I can't get them to show up properly in Photoshop anymore.
They have the correct extension, and I can open them in Preview on my iMac with no problems. These are the same files I've been using for years.  When I open these png files in Photoshop now, I don't get an error, but the logo shows up as blocks/lines of color.
Doesn't matter if I open them on their own, or drag them on top of another open image.

png file of logo in Preview:

Screen Shot 2018-02-06 at 12.00.43 PM.png

same png file alone in Photoshop:

Screen Shot 2018-02-06 at 11.57.08 AM.png

green box is the same png file dropped over another photo in Photoshop:

Screen Shot 2018-02-06 at 11.57.35 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

In all version of Photoshop or just CC 2018 19.1?   The png posted above I could not open in any version of Photoshop but I could open it in Windows Photo and Paint and Save a png I could open in Photoshop.  So do you have a file problem of a CC 2018 19.1 problem. If you do not have other version of Photoshop post one of your png files here.  You may have a Device driver problem try editing your Photoshop Preference Performance section and uncheck Use Graphic Processor. If that works check with apple see if they have a newer driver for you mac...

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

Hi! I'm just using CC 2018 19.1.0 on my brand new iMac.  I don't think I've tried to open any png files in PS since I got this new iMac a couple weeks ago, honestly.  Thanks for the advice!
Here's an upload directly from the original file. The one above was an iMac screen shot (which is also a png) to show that the png logo file opens correctly in Preview.

Logo_Full_2.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

THANK YOU, @JJMack!!! You're my hero!
I unchecked "Use Graphic Processor" and that did the trick!
Should I just leave that unchecked all the time?  Will that cause any other issues?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

Check with Apple they seem to control what drivers are used on Mac machine. Windows users get the latest device driver from the maker of the Display Adapter.  I would think Apple might not allow that with machine they control. My GPU is enabled feature like 3D and Liquify require the.  If you uncheck use graphic processor you loose some of Photoshop features....

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

Just a note when you have a large transparent border  like you have around your logo you may have problem Placing you logo on image if you try to automate the process  Photoshop may trim the border. Pasting or placing that png.  When I want to keep the border  I put a 1% opacity pixel in the top left and bottom right corners

For a logo I would just trim it to begin with.

Capture.jpg

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

I'm having the same issue when I try to open PNGs in the latest Photoshop CC on the Mac - getting rainbow-colored garbage instead of the image. The images look fine in Preview.  I tried unchecking the box you suggested, but it didn't help.

Any other ideas, anyone?  I need this basic function to work.

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2018 Feb 21, 2018

Copy link to clipboard

Copied

I'm having the same problem with Photoshop - which just suddenly started acting up. If I turn off my MAC and reboot, the image will open fine. (By the way, If I open it on PS CS6 on a PC, it opens fine.) I will try turning off the Graphics Processor but I don't really want to lose functionality that comes with that...I too, would like a solution to this. Anybody?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2018 Feb 21, 2018

Copy link to clipboard

Copied

I'm using Suite CC 2018 on a Mac and have suddenly had this problem.

Enter JJMac to save the day!  I turned off the Graphics Processor and "Boom" problem solved!  Now, what am I trading in performance by turning off said preference, I wonder?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2018 Feb 21, 2018

Copy link to clipboard

Copied

This is not up to date,, but you do lose a lot. That's why shutting it off is a "sledgehammer approach".

GPU and OpenGL features and preferences | Photoshop and Bridge | CS5, CS4

If your Mac happens to have two GPUs, deselect "Automatic Graphics Switching" and restart your Mac.

Set graphics performance on MacBook Pro - Apple Support

Disabling Adobe Camera Raw's GPU has been known to help:

Disable Camera Raw GPU.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2018 Mar 06, 2018

Copy link to clipboard

Copied

I had this same issue, which just suddenly started. Our logos are png and I just saw rainbow threads as well. The fix was unchecking the graphic processor on my computer, which is years old. There must have been an update that created the problem. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

In an other thread a mac user stated they resolved their by editing  their Photoshop Preferences Plug-in section  uncheck Allow extensions to connect to the Internet and unchecked Load Extension Panels.    

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

I just reinstalled Photoshop and told it not to save the preferences this time. I rebooted. Now the PNGs are coming in fine.

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2018 Feb 20, 2018

Copy link to clipboard

Copied

I think I solved this, at least the problem I was having.  So i was having this issue on two different PC I just got at work.  We mostly use Macs, but I asked to go with a PC.  Anyway, I kept getting the "not a png file" error message.  I tried many many solutions, that got into the weeds pretty quick.  Adobe's line on this was that it either had the wrong file extension, or the file is corrupted.  They were actually right.  The file has most likely been corrupted, however not in a way that makes it completely useless, only mostly useless to photopshop.  The files became corrupted when they were sent over skype.  I would guess that many messenger type services that people transfer small files with, like Skype, have a similar effect on images.  Sometimes its scaling, or other problems that corrupt the file.  Try this, if someone is sending you the file... Skype, email etc... have them send you the .png file directly.  It wont open.  Then have them send it after it has been put in a .zip file.  Unzip and try it out, if it opens, the method they sent the file is the problem, and use .zip from now on .  Hope that helps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Same problem with "rainbow" or wrong colors. Can open png in Preview or PSD 2017 and resave, still opens wromg in PSD 2018. Saving as jpg will read correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Many times it's the problem of having two GPUs on automatic switching with Photoshop getting the low performance energy saving one over the  high performance GPU.

If that's what you have on your Mac, go into Energy Saveing Preferences, uncheck that function and reboot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

Gener7,

Thanks for your response!  I only have one GPU at the moment and am

checking with my Mac guys about a possible upgrade.

Regards,

Steve

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

Try going to Preferences > Plug-ins and uncheck these

Allow Extensions to Connect to the Internet

Load Extension Panel

Restart Photoshop

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines