Canvas Freezing after Pan v23.5

New Here ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

Help!

I've been having an issue with the main canvas window completely freezing. I'm currently using Photoshop v23.5, and while panning/zooming in rapid succession the canvas will completely freeze and nothing I can do seems to fix it. Photoshop doesn't crash, and I can still do actions outside the canvas, but anything that would appear inside the actual canvas is frozen. I can even save the project at that time, then re-open photoshop and it's fine. The problem has gotten worse now, and it sometimes happens every 5-10 minutes. It's been happening for the last few updates, so either there's something wrong on my end, or it's an issue that's not been fixed yet.

My graphics drivers are up to date, and my hardware should be plenty sufficient for running photoshop. Also when it happens I'm not working with a large project, and my memory/cpu are nowhere near 100% usage. So I'm clueless as to what causes this aggravating issue. I've attached a video of what it looks like.

 

Any help would be greatly appreciated!

 

Specs:

Windows 11 - Version: 21H2 64-Bit

Photoshop - Version 23.5

NVIDIA 2080 - Driver: 516.94

32GB Ram

1TB NVME SSD

(No Tablets/Drawing Devices)

TOPICS
Windows

Views

38

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 29, 2022 Aug 29, 2022

Go to Preferences > Performance... and uncheck Multithreaded Compositing - and restart Photoshop. 
Still crashing? 
Go to Preferences > Performance... click Advanced Settings... and uncheck "GPU Compositing" - then restart Photoshop. Still crashing?  

You can try this too: in Preferences>Technology Previews, check the box 'Deactivate Native Canvas' and uncheck 'Enable Native Canvas Rulers' options, then restart Photoshop. Does this work?

Likes

Translate

Translate
Community Expert ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

LATEST

Go to Preferences > Performance... and uncheck Multithreaded Compositing - and restart Photoshop. 
Still crashing? 
Go to Preferences > Performance... click Advanced Settings... and uncheck "GPU Compositing" - then restart Photoshop. Still crashing?  

You can try this too: in Preferences>Technology Previews, check the box 'Deactivate Native Canvas' and uncheck 'Enable Native Canvas Rulers' options, then restart Photoshop. Does this work?

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines