Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Could you point me to workaround for catastrophics Photoshop performance?

Explorer ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

Many, many months passed and the problem is still not resolved. I heard it is well known, I often google for any help and I see lots of people reporting same issue.

My question - is there any known workaround?

 

Currently I use Photoshop 22.2.0 but it was same in previous versions.

I think there was no issue in Photoshop 2019. Should I back to 2019 somehow?

 

The problem: Photoshop UI works very very very slow. Much slower than even before.

 

My system: Windows 10 with RTX 2090, 16GB RAM. I usually work on on 6000x4000 image with many layers (photo retouching).

Tested with Wacom Intuos and with mouse.

GPU acceleration in PS is enabled, memory for PS is set for 8000MB, tried to experiment with history/buffer without luck

 

Examples:

- create curves layer, move point on curve, after a while image is updating smoothly, but usualy it starts without updating for about 0.5 second

- create same curves layer but UNDER other layers, so Photoshop needs more calculations, now when you move your point - nothing is updating smoothly, image changes very slowly - this is typical case for dodge/burn and it was working before!

- change opacity for layer being UNDER another layers - image updates slowly, sometimes the point on opacity is going back to previous position

 

What exactly Photoshop is currently doing when you change something on bottom of the layer stack? Why it was working fast before? Is there a way to reset some settings to check? Or disable some new feature which takes all the time?

 

 

 

TOPICS
Performance

Views

423

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue? 

What have you done for all-purpose trouble-shooting and about Photoshop-performance so far?

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

https://helpx.adobe.com/photoshop/kb/optimize-photoshop-cc-performance.html

https://helpx.adobe.com/photoshop/using/scratch-disks-preferences.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

Thank you for the links, I see lots of content there, some things I tried but for example restoring configuration is something I need, so I have something to explore soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I was trying many different things, I even removed all configurations for all Photoshop versions from AppData.

Today I just tried to open same file first in Photoshop CC 2021 then in older Photoshop CC, the second one has following info:

 

Wersja programu Adobe Photoshop: 20.0.10 20200706.r.120 2020/07/06: 1208496 x64

 

Then I opened curves layer under other layers.

In Photoshop CC 2021 it works extremely slow just like I described.

In older Photoshop it works very smoothly.

 

So there is same operating system, same drivers, same hardware, only different versions of PS CC.

 

I am not sure how should I proceed. Maybe I should use older version, but don't know how long it will be supported.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

I just tested more disabling Use Graphics Processor and looks like it helps a little, I mean there is no "stuttering".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

more testing: even when I turn on Use Graphics Processor and disable all checkboxes inside it still affects the performance, so maybe this option is just evil, any ideas where to search more? maybe my GPU should be configured correctly for newer PS, but why it works with older one?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

updated Geforce drivers to version from March 2021 - no change

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

hello, I was browsing all these documents, not sure what else can I do, I have RTX 2070 with 8GB I think it meets minimum requirements, what are your recommendations to follow? I can only disable it, but with disabled GPU PS works differently, for example zoom works different way, anyway at least curves work faster

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

For now the only valid solution I have found is to uninstall Photoshop 2021 from my computer.

Photoshop 2020 works correctly with GPU enabled.

Probably Photoshop 2021 is very unstable version yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Just to give you update, I reinstalled my Windows 10 today, installed newest drivers and newest Photoshop 2021 - problem still exists, performance is very bad. So after 7 months there is no progress with this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 16, 2021 Oct 16, 2021

Copy link to clipboard

Copied

Can you go to Photoshop's Help - System Info and click on copy. Then paste the info here.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2021 Oct 16, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Mr Poplawski,

 

You have been heard.

 

Please install 23.0.2.

I had the same issue with 23.0.1, from last week as started working on 32 bit exr files , at 4k resolution.

Very slow response from a ryzen9, 3950x, 64gb ram and 3060 12gb graphic card.

 

But now after updating to 23.0.2, things are much better.

 

Cheers!!

Fellow user.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

LATEST

Looks like there are no performance fixes in 23.0.2 changelog, they fixed only two crashes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines