• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Deep knockout cannot knock out to the Background layer when using a clipping mask

Explorer ,
May 28, 2024 May 28, 2024

Copy link to clipboard

Copied

I have read the document. Here is what it stated:

  • Select Shallow to knock out to the first possible stopping point, such as the first layer after the layer group or the base layer of the clipping mask.

  • Select Deep to knock out to the Background layer. If there is no Background, Deep knocks out to transparency.

  • Note: 

    When not using a layer group or clipping mask, both Shallow and Deep will create a knockout that reveals the background layer (or transparency, if the bottom layer isn't a Background layer).

 

Based on the document, I believe the normal behavior is to knock out to the Background layer when using a layer group or clipping mask. However, in my test, the deep knockout only works when using a layer group. It does not work with a clipping mask.

 

Reference:

https://helpx.adobe.com/photoshop/using/knockout-reveal-content-layers.html

TOPICS
Windows

Views

210

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 30, 2024 May 30, 2024

Thanks, I can get it to work now. I found that in your picture, "Blend Clipped Layers as Group" was unchecked. That's it! Problem solved. It's not a bug. The Photoshop website's help doesn't provide that information.

 

Snipaste_2024-05-31_14-44-21.png

Votes

Translate

Translate
Adobe
Community Expert ,
May 28, 2024 May 28, 2024

Copy link to clipboard

Copied

What version of Photoshop and Windows are you using?

 

Can you post a screenshot including the layers and image specifying which layer your applying the Knockout to?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Does your Photoshop have this bug?

Here is the image. As you can see, the deep knockout works fine with a layer group but doesn't work with a clipping mask.

 

Snipaste_2024-05-30_17-20-46.png

Snipaste_2024-05-30_17-20-23.png

 

Because I selected the deep option, it should knock out to the Background layer. So, I imagine the result will be like the picture I made manually below.

 

test.png

 

I am using Windows 10 and Photoshop 25.9.0

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Could you please post meaningful screenshots that include the Blending Options-window? 

Why the Blend Mode »Difference«? 

 

I don’t understand your problem, though; the intended results does not seem to involve any knock out-effect but just a Clipping Mask-arrangement. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Snipaste_2024-05-31_14-22-34.png

Snipaste_2024-05-31_14-23-07.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

In the Photoshop 6 help it clearly shows a picture of what your talking about and even seems to state same in the text, but i can't get it to work in any Photoshop version i've tried.

 

In the example, the Dandelion layer should punch through to the white Background layer according to the directions, however it does not.

 

ps6a.png

 

 

Edit

After unchecking Blend Clipped Layers as a Group for both layers in the Clipping Group it works a descriped in the ps6 help.

 

ps6b.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Thanks, I can get it to work now. I found that in your picture, "Blend Clipped Layers as Group" was unchecked. That's it! Problem solved. It's not a bug. The Photoshop website's help doesn't provide that information.

 

Snipaste_2024-05-31_14-44-21.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

Yes i had also looked at several books and none of them mentioned that either.

 

So it seems all the layers in the clipping group need to have "Blend Clipped Layers as Group" unchecked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2024 May 30, 2024

Copy link to clipboard

Copied

LATEST

Hi there! If you can't knock out the background layer using a clipping mask, here's a simple solution:

  1. Unlock the Background Layer: Double-click on the background layer in the Layers panel and click "OK" to unlock it. This will turn it into a regular layer.

  2. Create a New Layer: Make a new layer below your artwork. You can do this by clicking the "New Layer" button at the bottom of the Layers panel or by pressing Shift + Ctrl + N (Shift + Command + N on Mac).

  3. Move the Artwork: Drag your artwork layer above the new layer.

  4. Apply the Clipping Mask: Right-click on your artwork layer and select "Create Clipping Mask" or press Alt + Ctrl + G (Option + Command + G on Mac).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines