• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
8

ESC, Delete/ Backspace no longer working with the Polygonal Lasso

Community Beginner ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

When creating a selection with the polygonal lasso I used to be able to use the ESC key to exit out of the selection. Also, using the delete or backspace key used to allow me to go pack to a previous point in my selection. Neither of these functions are working for me anymore on Windows 10 Pro 64bit and Photoshop 23.4.2

TOPICS
Windows

Views

3.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

Hi @GoodBullyLLC sorry to hear you are seeing this. Testing here shows the tool to be working as expected.

 

Let's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Thank you,

Thank you,
Cory

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

I can confirm these bugs since the latest Photoshop updates. Not everytime, but very (!) often ESC and Del are not working. This sucks!

 

Unfortunately the bug report page of Adobe has become an external "suggestion board". This sucks too.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

I would like to add:

Numpad + and - are not working neither, for zooming while doing the selection.

 

Only "solution" for now is closing the selection by double-click, then minimizing Photoshop and maximizing again. Then it seems to work for some time again.

 

By the way @Adobe: That sucks. YOU are the ones who know what you change with the tools in every update. Do your testing before releasing!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

This helps, thank you mate

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

I too am having issues with this, so annoying!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 09, 2022 Oct 09, 2022

Copy link to clipboard

Copied

I experience these bugs on two different systems at work. One with Windows 10, one with Windows 11. I cannot say, why it is working sometimes and then not working again for 3-4 selections.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Can confirm this bug is present

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

I just tested on macOS 11.7 Big Sur, 2017 iMac. Both Escape and Delete (Backspace) work for me with the Polygonal Lasso tool. I'll check again when I get to my Windows laptop.

 

Sometimes other applications can take over your shortcuts. Sometimes it's a browser. For testing purposes, can you try rebooting in Safe Mode with no other applications open?

 

Jane

Forum volunteer

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Thank you. Please do some testing. Yesterday it worked for some minutes in a row and I thought that the latest update fixed the problem. But the bugs were still there, after some selections the keys did not work.
Interesting hint: I used to activate the option to scroll with the mouse wheel in Photoshop (preferences -> use mouse wheel to zoom). When the bug occurs and the keys don't work... the mouse wheel works then to zoom.
I think it is normal that you cannot zoom with the mouse wheel when using the lasso tools. Thatswhy I normally have to use the Numpad Plus and Minus keys to zoom.

Do all the others here have this option activated too? Maybe this has to do something with this bug. Or maybe not...
@Adobe: I am proud to do the debugging for you...
@

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Glad to hear it's not just me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Hi, long time ago, we did not have internet on our machines, or not with many tabs open, did not have many apps such as slack, messenger open, the OS was not intercepting and autocorrecting what we type, we had way less stuff and routines going on...

coukd you try running Ps alone, and see if you encounter the problem? Add one program at a time...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2022 Nov 08, 2022

Copy link to clipboard

Copied

...update...

After a reboot it started working. BTW, it's a Windows 10 machine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Hi, were there other programs running when you shut down the machine, and not now? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2022 Nov 16, 2022

Copy link to clipboard

Copied

@adams30640988: Are you sure? Today I worked on 3 pictures and the lasso tools (polygonal and magnetic) worked fine. Now I am at the 4th picture and the bugs orrur again. I don't know what has caused this. I opened the picture the same way like the others. The only thing different from the others: I duplicated some layers from one tab into another. Now the bugs occur again and again.

Version 2022 (23.5.2)
And no... I will not update the Photoshop to 2023 as long as Adobe Bridge 2023 is that crappy.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 16, 2022 Nov 16, 2022

Copy link to clipboard

Copied

Hi, @christians71793745 can you set the status bar at the bottom left to GPU information?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2023 Jan 06, 2023

Copy link to clipboard

Copied

No. Can you talk to Adobe to release a fix for this?

Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

I'm getting the exact same issue. Very annoying. I have been using Photoshop since version one! It has never been so buggy. The problems started when they moved over to the cloud. I teach Photoshop and use to boast on how reliable it was. I can't anymore.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

I got the bug too. Very very dissapointing to upgrade and get this. It really disrupts you masking workflow.

In the old days we didn't get so many features and changes all the time. But then... things never just stopped working like this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

Hi @Tzaar can you check the status of your GPU acceleration ? You can set the status bar to display it.

also, are you on 24.1?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2022 Dec 16, 2022

Copy link to clipboard

Copied

I'm on 24.1.0 20221206.r.166 be4691b x64

 

I changed the status bar and it acctually doesn't change. It always shows document size no matter what I choose. But if I hover over to get the yellow tooltop/box thing. It's says GPU D3D12

 

I got the lasso bug on two different computers with completely different GFX-cards, both Nvidia though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2023 Jan 06, 2023

Copy link to clipboard

Copied

The same here. Don't know, what the Status Bar should do in this case.

@PECourtejoie: Do you want to tell me that you cannot confirm this bug on any of Adobe's test systems?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 07, 2023 Jan 07, 2023

Copy link to clipboard

Copied

Hi, FYI, Experts are not Adobe employees... and I'm a Mac user. Will try to get access to a windows machine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2023 Jan 07, 2023

Copy link to clipboard

Copied

Thanks and sorry, I was a little angry because of the last months/years of Microsoft's and Adobe's software releases. And yes, I would not be surprised if this problem occured just because of parallel updates of Windows and Photoshop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 05, 2023 Jan 05, 2023

Copy link to clipboard

Copied

I have this problem too. Sometimes it works just fine and sometimes the shortcuts don't work at all. It's super annoying.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines