• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Eyedropper tool is picking up a lighter color.

Community Beginner ,
Apr 09, 2017 Apr 09, 2017

Copy link to clipboard

Copied

The eyedropper tool keeps picking up a much lighter color than what I selected and the sample size is set to point sample and it is still not working. I reset Photoshop and that didn't work either. I posted this to the adobe Photoshop sketch forum cause that's the closest forum i could find that relates to Photoshop. Never used these forums before, hopefully someone can answer my question cause apparently I can't contact adobe personnel directly. Incredibly frustrating for such an expensive software!

eyedropper tool not working.jpg

Views

8.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 10, 2017 Apr 10, 2017

One possibility - you do not show all of your layers.

Your eye dropper  tool is set to "All Layers" which means, even though you highlighted a single layer,  it will pick up the colour made from the combined layer stack at that point - including any adjustment layers and layers above with blending modes. If you then paint with that colour onto the single layer those adjustments / blending modes will be applied again and the effect will look different.

This can be avoided by using sample current an

...

Likes

Translate

Translate
Engaged ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

Is your brush set to Normal blend mode? I just duplicated that color disparity by setting mine to Screen.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

Thanks for the response. Yes, my brush is set to normal blend mode and  the eye dropper tool is still not working. However, I opened a new document and it works so I've narrowed it down to I must have accidently changed a setting in that document specifically. Still new to digital art, so trying to figure it all out. I'm happy to know it's just a specific document though and not the software itself. I'm sure with some fiddling I'll figure it out now, again thanks for your help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

Capture.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

One possibility - you do not show all of your layers.

Your eye dropper  tool is set to "All Layers" which means, even though you highlighted a single layer,  it will pick up the colour made from the combined layer stack at that point - including any adjustment layers and layers above with blending modes. If you then paint with that colour onto the single layer those adjustments / blending modes will be applied again and the effect will look different.

This can be avoided by using sample current and below

See example:

A single filled layer with a curves adjustment layer above to lighten it

Brown patch sampled using "all layers" and painted back onto same layer:

Same brown patch sampled using Current & Below and painted back onto the same layer :

I hope that helps

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

Thank you, I saw your post just after I discovered that it was my curves adjustment layers that was causing the issue. I've since turned them off and it fixed the issue. Thanks for the helpful explanation!:)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

You're welcome

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

LATEST

OMG thank you !! 
This worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

You helped me by pointing me into the right direction, thanks. However in my case it was selecting a lighter colour because I had the Sample Size turned to "5 by 5 average". Changing it back to "Point Sample" did the trick. To anybody having the same problem: An indicator for this is when you move around your canvas using the eyedropper tool (alt), you would expect the selected colour in the colour navigator to jump around quite a bit. Instead, it will do a very smooth transition between colours. If that is the case your problem lies with the Sample Size setting under the Eyedropper Menu like Davescm showed in his Screenshot above ↑

 

Hope this helps a bit too

 

Thanks for your help 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines