• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Getting error 150:30 opening Photoshop cs4 on Macbook Pro

Community Beginner ,
Feb 23, 2015 Feb 23, 2015

Copy link to clipboard

Copied

I've bought a new Macbook Pro with Yosemite 10.10.2. Installed old favorite programs from my old compute with time capsule. Sadly though I can´t start Indesign and photoshop, both bought in the CS4 versions. Bridge works though.

When Indesign or Photoshop starts, I get a note saying: The licenses for the product doesn't works, try to restart your computer. If the message appear again, contact Adobes technical support and quote the error code 150:30.

Ive tried to delete the FlexNet Publisher according to information given on the adobe site  [hard drive]/Library/Application Support/FlexNet Publisher/

But  the problem is I don't have a folder named FlexNet Publisher.

Help please?

Views

61.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 16, 2015 Mar 16, 2015

Update: I'm glad this procedure has helped many Mac owners of CS4 over the years.

Apple has announced that Mojave (10.14) will be the last MacOS to support 32 bit apps such as Photoshop CS4.

Do not upgrade to 10.15 if you intend to stay with CS4.

Now on to the License Repair procedure:

This can be avoided with the Terminal python script fix that will eliminate the 150:30 error, fix your install with out harming anything.

I can step you through with screenshots if you want to try it.

You account mus

...

Votes

Translate

Translate
replies 174 Replies 174
Community Expert ,
Aug 19, 2016 Aug 19, 2016

Copy link to clipboard

Copied

No, I'm not experienced reading these logs. I might wisely refer you to Tech Support. since you have a Suite, It might be a central suite uninstaller found in /Applications/Utilities. I've always dealt with standalone products. If you installed in US English then play it safe and uninstall in US English.

I basically was able to help on 150:30 errors because I had been there myself. It usually happens when Adobe products are migrated from Time Machine or another Hard drive.

I don't have experience with Suites and my ideas are not getting results.

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

I've opened the Terminal and typed as requested.  It now tells me to enter password.  Do I do this before I download the licensing dmg?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

Sound like you pressed Enter/Return after typing the command. Do not do that until you drag the LicenseRecover.py script into the Terminal window as shown.

Close Terminal and start again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

OK sorted Terminal correctly this time.  Do I need to re download the licensing dmg as nothing happens when I double-click it (except a quick zoomed-icon flash)?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

"DMG" is a Disk Image   After double-clicking it, you would see an disk icon, if not...see message 54 to set your Security settings so that you can open the DMG since it isn't "signed".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

Double-clicked after switching to 'download from anywhere' but I get the same icon-flash as if it's trying to open but nothing shows on the desktop.

Interestingly, however, I just tried to trash it to re-do the download but it won't delete, giving me the message that it can't because it's in use.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

Maybe a reinstall of Elements is the best bet. You are running into problems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

OK I'll try that.  Many thanks for your help, very much appreciated.

Not sure if you're an Adobe employee but, if so, you might want to pass on that the time-consuming nature of every comment having to be approved just adds salt to the wound after having to deal with problems like this - on days when I should be with my kids - on products that I've paid very good money for.

Not a reflection on you of course.  Your command of your subject matter is as impressive as your ability to communicate to us lesser mortals!  Enjoy the rest of today gener7.

All the very best

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 17, 2016 Sep 17, 2016

Copy link to clipboard

Copied

No, I'm not Adobe Staff. Just a fellow user-volunteer who has gotten the ACP badge and a few other perks for the years I've put in helping others as I'd like to be helped.

As for the Moderation queue, it's because we've had a storm of spam that once clogged the boards. The culprits crack open new accounts, so we have new accounts under probation as a precaution. Nothing personal.

Which also means I've been approving your posts as well as answering them.

Have a good evening,

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2016 Nov 25, 2016

Copy link to clipboard

Copied

This fix worked on my iMac running Mac OS 10.12.2 Betaalso. Thank you gener7!

Be sure to follow down the entire fix and follow the steps exactly

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 25, 2016 Nov 25, 2016

Copy link to clipboard

Copied

I would like to mark gener7 ’s post a “correct” but I can’t see anywhere to do that. Can someone tell me where to mark it ‘correct’ on a MacBok Pro using Sierra?

Jim and Tatiana Promessi

[Private info removed by moderator (B.R.)]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 25, 2016 Nov 25, 2016

Copy link to clipboard

Copied

Only the poster who started the thread can mark it as "Correct" and that has been done.

You can however mark it as "Helpful".

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2018 May 21, 2018

Copy link to clipboard

Copied

I'm here.  What now?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Adobe couldn't help - CS4 no longer supported. Shared screen, everything. Nothing worked. He referred me to this community. Thank you so much This worked on 2008 Mac with El Capitan 10.11.6. Brilliant!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Hi Gene.  I have following this thread and hoping it would help.  I am running a MBP and an iMac, both with HIgh Sierra (10.13.6).  I carefully folowed instructions and got up to:

 

Note: This may take a few moments.

 

and it seems to be stuck there!  How long is a 'few moments'?  I have waited quite a while, restarted, etc.  Is there an error message if it does not work?  I dont get that message.

 

Thanks so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 02, 2015 May 02, 2015

Copy link to clipboard

Copied

I have OS X 10.10.3 and had upgraded from 10.9 and migrated to a new SSD hard drive since using CS4. On opening PS I got error: 150:30. Just downloading & reinstalling CS4 worked for me. PS (what I use most) works fine. I didn't even have to uninstall the old, migrated CS4 program files.

Thanks for the help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

Worked like a charm. Thank you so much. I just had a new hard drive installed on my macbook pro and was not looking forward to reinstalling this software. It fixed my ID problem, too (Mac OS10.7.5, Adobe Creative Suite CS4)

Thank you!

Debbie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

I've had this happen to me more than a few times when I had CS4. It's usually caused by transferring from Backup or migrating CS4, both which breaks the license.

Using the Terminal fix is not what I want to ask Mac users who have no experience with it to do, but I did put together this visual guide for those who want to give it a try.

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

Gene, I would like to mark your answer as correct but, for the life of me, I cannot see where to do it!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

That's because only the original poster or a moderator can do this. I'll try and ask one.

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

I'll get that quick. I plan to mark post #11 (the first of the series) correct and the rest as helpful. Speak now or forever hold your peace

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

Thanks a great deal for getting this, Ben. I'm reluctant to lobby for marking my answers, but this has helped out so many, it should be designated correct.

Gene

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

I agree...Definitely one which needed to be marked. And you very much deserve recognition for the time put into this discussion.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2015 Oct 18, 2015

Copy link to clipboard

Copied

Just one more thing I want to add:

The Helpdoc Error "Licensing has stopped working" | Mac OS has a section for this Terminal fix (5), but an error as to which file to drag to the Terminal window in Step 5 g. I have reported it, but doesn't seem like anyone has got to it yet.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2016 Feb 02, 2016

Copy link to clipboard

Copied

HELP Terminal is not working for me in El Capitan 10.11.3  I get a "SyntaxError: invalid syntax " every time.   This is after a time machine migration pain.  I want to warn people of letting someone use a different Apple ID to upgrade from Mavericks to El Capitan.  It will need the new Apple ID to upgrade forever.  Apple didn't answer why my son could upgrade a computer which used my Apple ID and yet not let me update back into my Apple ID.  In any case, CS4 was working in El Capitan before  reinstalling from a back up.  Guess I will have to try from my disks. Which worries me because it's just getting to old.  Which is why I was staying in Mavericks and will not upgrade the OS again until i am forced one day to upgrade from a perfectly good CS4 I spent $1600 on. 

Any help would be appreciated.  There are no flexnet files on my computer. 

Thanks in advance. Brian

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines