How do I turn off the option click zoom in Photoshop 22.5.0

Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

I use an Apple Magic Mouse and every-time I use option click to take a sample for the Clone Tool or Healing Brush, Photoshop zooms in or out.  In the words of the late great William S. Burroughs .... "It's driving me crazy, it's driving me nuts!"  Please help me keep my sanity and keep me on schedule.  If there's a solution, it's hiding from me.

TOPICS
macOS

Views

468

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Its not the option click - its a magic mouse gesture.

Go to Photoshop/Preferences/Tools and disable gestures.

 

 

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Kevin, thanks for the reply but nope, disabling gestures doesn't work.  In fact disabling any tool* preference related to window navigation doesn't solve the .... dare I say .... "bug"?  

 

Ok wait, wait.  (while writing this I've been trying different things) I just experienced the "bug" switching between the command key and option key depending on wether or not "Zoom with Scroll Wheel" is selected.  If "Zoom with Scroll Wheel" is selected, then holding down the option key enables panning while gesturing on the mouse.  I typically keep "Zoom with Scroll Wheel" unselected.  As you can tell, I don't like zooming or panning going on as I'm randomly gesturing on my mouse while thinking about what I want to do next. 

 

I've looked for a keyboard shortcut to at least try and move the behavior to another key but that doesn't seem to exist.  Or at the very least, I can't seem to find it.

 

*includes Enable Gestures, Overscroll, Enable Flick Panning, Zoom with Scroll Wheel, Animate Zoom, Zoom Resizes Windows, and Zoom Clicked Point to Center.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Have you checked your Mac Mouse settings in System Prefs? These are all gesture related with the magic mouse.

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Yes, I checked them and they seemed normal to me.  I went ahead and unchecked everything related to any scrolling and the problem still exists.

 

I can't imagine that this has always been this way, but perhaps it always has and I never noticed before.  That would blow my mind.  I've owned and used every version of Photoshop for a Mac since version 3.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Have you figured this out yet? This has "bugged" me for the longest time, it seems. I'll be moving along spot healing a dusty scan and when I press the option key to select a target for the heal tool, and click the mouse button, it zooms. I'm assuming that when I'm clicking the mouse, I'm ever so slightly sliding my finger which activates the zoom, but sometimes I try hard to only press and it still does it. Drives me bonkers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

Nope.  It's still there and it still drives me nuts.

 

My exerience is the same as yours .... the issue is most annoying while using the healing brush tool. The very first thing I do with an image is to clean it up. That could be sensor spots, dirt on the set, stray hairs, blemishes on skin, any imperfection that needs to removed. This is typically the most time consuming and methodical thing I do while working on an image. It invlolves no artistic decision making. I zoom to the level best suited to the task at hand and work my way around the canvas one block at a time until I get to the end. To have the image radomly zoom in and out just because I slightly flicked the surface of my mouse is ridiculous. 

 

I can change key commands for many things in Photoshop, I don't understand why I can't reassign that particular one.

 

FYI ... Years ago I used to use a custom mouse and/or a Wacom tablet and about 10 years ago, I quit using them. I find the simplicity of Apple's Magic Mouse to be something to appreciate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

LATEST

We have the same method and I'm half way through retouching over 200 images for a book right now. Yesterday I tried something different to see if I could get used to it, and that was to swap zooming and scrolling by turing on "Zoom with Scroll Wheel" in the PS Tools preferences, and just go back to the old school way of moving around the image by holding the space bar and click dragging around. That lasted about five minutes, but give it a try... Maybe it won't bug you as much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Save time with Adobe Express quick actions