• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
29

How to fix small menus and icons on 4k display in Photoshop? [2015]

Community Beginner ,
Jan 28, 2015 Jan 28, 2015

Copy link to clipboard

Copied

 

[This 7-year-old question from 2015 about CS6 and Windows 8.1 is now locked.

Please start a new thread about the current version if you have a similar question]

 

Hello,

 

So I have seen that I am not the first one to ask this question, but I have yet to find any true resolutions.  I recently bought anew laptop, a Lenovo with a 4K UHD display which I already love for so many things.  But, like a few other programs, the high resolution means the icons and menu text of PS CS6 are incredibly small, which may be alright on a TV, but on a laptop screen, it make it incredibly difficult to work.  I have tried all sorts of different approaches in Windows, such as changing the OS font sizes and icon sizes, which do indeed change everything else on the computer, but PS is still the same tiny size.  I have also increased the text size under the interface preferences to large, but with little real change.  I understand why this is happening, but I am hoping that there is some sort of workaround, beyond just bumping down my screen resolution, which defeats the whole purpose of using UHD to edit photos.  I have heard rumors of being able to code in some UI changes manually, but have found no concrete examples of how to actually do that. 

I am sure that it would not take Adobe too much time and effort to create an update to help with scaling, but they are very set on pushing forward with Creative Clound, leaving the rest of us loyal customers to the dust until we pay up.  If anyone has found any resolutions or workarounds, I'd really appreciate it.  Thank you. 

TOPICS
Windows

Views

354.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Feb 25, 2018 Feb 25, 2018

If you have Windows 10, simply go into Program Files\Adobe\Adobe CS6 folder and left-click on the Photoshop CS6.exe file. From the Context menu that opens, go down to the bottom, choose "Properties" and the Properties dialog opens.

Click on the Compatibility tab there and you should see the scaling options you see in the screenshot, but for Photoshop.

Gene

Votes

Translate

Translate
New Here , Nov 02, 2019 Nov 02, 2019

This is a little late,

but for windows, I found that if you navigate to where the actual application file(.exe) is,

right-click it and select properties,

choose the compatibility tab and select "Change high dpi settings" under the settings section,

in the next window, select the checkbox that says "High DPI scaling override",

and choose "System" from the drop down.

-Hit ok to save the changes, and then re-open Photoshop(i've only tested it with photoshop and illustrator).

That fixed it for me.

 

 

 

Votes

Translate

Translate
Adobe
replies 118 Replies 118
LEGEND ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

Bear in mind that all solutions EXCEPT UI scaling inside recent versions of Photoshop mean you get no benefit from the expensive high detail screen: Photoshop just shows up with much less detail. If you want the benefit of the screen you paid for with detailed photo editing you must also pay for updated Photoshop.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Just stumbled upon this thread and big thanks to whoever advised going to the properties of the .exe file. I was trying to do some work last night and it was sooooo hard to do anything.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

its_waseem, did you have to re-install after doing that?  Like uninstall it and then re-install after changing the properties in the .exe file??

ugg frustrating

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 05, 2018 Sep 05, 2018

Copy link to clipboard

Copied

All this is much simpler in Illustrator, which is a vector-based application that doesn't care about screen resolution one way or the other. It just translates everything to physical print dimensions, based on whatever resolution the display reports to the app.

Photoshop is different, and a special case, because it can't scale the image with the UI. It has to leave the image 1:1, one screen pixel for one image pixel - but then scale the UI independently from that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

You need to get up to date with Photoshop. CS6 is many years and versions behind your hardware.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

I OWN CS6

Dont want to RENT something else

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

Sorry I'm not as rich as you, paid a lot of money for CS6.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

I still use CS6 for some things that CC 2018 can no longer do, so I use both. Using PS CS6 on a 12.5" HD (1920x1080) resolution Lenovo x270 laptop is really difficult without using workarounds that have not worked very well. The Dan Antonielli 'photoshop.exe.manifest' solution is the first I've come across that does what I need. For serious image editing I have a proper desktop system. But at last I can now use CS6 comfortably on the high-res laptop when needed. Thank you Dan Antonielli and those who posted the info here.

Russell

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2018 Apr 12, 2018

Copy link to clipboard

Copied

HERE IS THE FIX. Credit to davidw83878403

1) For the desktop "Adobe Photoshop" shortcut:

-right click on the shortcut icon

-left click on Properties

-open the Compatibility tab

-in the Settings area on the compatibility tab, ensure the box beside the "Override high DPI scaling behaviour." box is checked, and in the drop-down box directly below "Scaling performed By:", set to System.

Doing the above WILL NOT CHANGE the way PS opens if you ask it to open via a right click on the photo in question (that is, right click on photo > Open With > Photoshop (Editor)).

You therefore also have to perform the above steps for the PhotoShop .EXE file.  On my computer, this is located at: C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)

Locate the Photoshop.exe file, right click on it and:

-left click on Properties

-open the Compatibility tab

-in the Settings area on the compatibility tab, ensure the box beside the "Override high DPI scaling behaviour." box is checked, and in the drop-down box directly below "Scaling Performed By:" set to System. [or Try System (Enhanced)]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2018 Jun 25, 2018

Copy link to clipboard

Copied

All you have to do to fix this problem is, right click on your adobe software that you are trying to fix and click on properties.

Next go to the compatibility tab and click, CHANGE HIGH DPI SETTINGS, then just set your settings to what i have them in the picture

I hope this helps and works for you because it worked wonders for me.premiere pro link for forums.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2018 Jun 28, 2018

Copy link to clipboard

Copied

I second Compatibility tab on the Windows. Worked for me!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2018 Jul 24, 2018

Copy link to clipboard

Copied

Hi.

I have soltion for this as i had same problem.

You just go to image size and make it in pixels and adjust the resolution of document.

Its will get u back on regular tx size.

Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Ugg I hate this bug.    Here are (hopefully complete and easy to follow) step by step instructions to fix the teeny tiny menus in Photoshop issue.  Cheers.

Step 1:   Backup the registry

A. From the Start menu, type regedit.exe in the search box, and then press Enter.

B. In Registry Editor, locate and click the HKEY_LOCAL_MACHINE (which is what you want to back up).

C. Click File > Export.

D. In the Export Registry File dialog box, select C:/ as the location to which you want to save the backup copy, and then type the name HKEY_LOCAL_MACHINE_BACKUP for the backup file in the File name field.

E. Click Save.

Step 2: Tell windows to prefer an external manifest file

A. From the Start menu, type regedit.exe in the search box, and then press Enter.

B. In Registry Editor, Navigate to the following registry subkey: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > SideBySide

C. Right-click, select NEW > DWORD (32 bit) Value

D. Type PreferExternalManifest, and then press ENTER.

E. Right-click PreferExternalManifest, and then click Modify.

F. Enter Value Data 1 and select Decimal.

G. Click OK,

I. then exit the Registry Editor.

Step 3: Create and place the external manifest files

A. Create a text file called “photoshop.exe.manifest.txt” in the directory where your photoshop.exe is located.  An example is C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)

B. Edit the text file with Notepad and put the following text in the file and save it.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

<dependency>

  <dependentAssembly>

    <assemblyIdentity

      type="win32"

      name="Microsoft.Windows.Common-Controls"

      version="6.0.0.0" processorArchitecture="*"

      publicKeyToken="6595b64144ccf1df"

      language="*">

    </assemblyIdentity>

  </dependentAssembly>

</dependency>

<dependency>

  <dependentAssembly>

    <assemblyIdentity

      type="win32"

      name="Microsoft.VC90.CRT"

      version="9.0.21022.8"

      processorArchitecture="amd64"

      publicKeyToken="1fc8b3b9a1e18e3b">

    </assemblyIdentity>

  </dependentAssembly>

</dependency>

<trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">

  <security>

    <requestedPrivileges>

      <requestedExecutionLevel

        level="asInvoker"

        uiAccess="false"/>

    </requestedPrivileges>

  </security>

</trustInfo>

<asmv3:application>

  <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">

    <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>

  </asmv3:windowsSettings>

</asmv3:application>

</assembly>

Step 4: Reboot your computer  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

OK, that's fine - but please stop calling it a bug, because it isn't. These displays weren't invented when CS6 was made.

It's your decision to stay with a long outdated and obsolete Photoshop version. Support was added for these new displays as they came on the market. Photoshop stayed on top of it the whole time - but you missed the train.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2018 Aug 14, 2018

Copy link to clipboard

Copied

You are absolutely correct for calling me out.  It is not a bug.   I was simply attempting to provide help to faithful but occasional users of the fine Adobe products to whom it is important to preserve the value of their investment in these valuable and expensive assets. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2020 Nov 07, 2020

Copy link to clipboard

Copied

You say decision like everyone is made of money. These programs are expensive and not everyone can afford to upgrade, so maybe chill a bit with that stuff.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Not everyone is born with a silver spoon stuckup their royal Behind!! we all can not afford $100 a month for one of many tools needed to do graphics these days. 

Adobe won the graphics war (up until now, landscape is changiing fast) but Adobe is overcharging it's users every month for the privilage. 

Shame on them for making the software only for the elites among us, that's not me, and if it was I wouldn't be on here rubbing salt into others wounds who didn't get the same benifits.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Where do you get $100 from? The photography plan is $10 a month.

 

So you can't afford $10 a month, but you think $700 is fine, with an additional $250 to upgrade every 18 months? The math doesn't add up. A subscription will never catch up with the price of a perpetual license.

 

The major benefit of the subscription model is that it's no longer for the "elite" only, as it was. The threshold has been dramatically lowered.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

I'm talking about the whole suite, then there is the 3D tools I use, it's $20 right now for just photoshop, I saw some deals somewhere I think is some backdoor into getting PS and Lightroom for 10 but the last time I looked it was not on their main page.

With all the tools I use I would be spending hundreds a month, I'm basically not earning right now! so nope, I gotta look for free tools or use old versions of PS.

I get your point about paying monthly, but what these companies don't realize is they are not the only sub service, everything is like that now with the old guard, people are spending hundreds a month to use these tools/services, "life but as a service" - would be their ideal, it sucks, but if you buy it once, yeah it may go out of date but you can use for years until your ready to upgrade, we don't need software that is upgraded every month, maybe every 3-4 years but not every month.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2018 Sep 05, 2018

Copy link to clipboard

Copied

I had the the same problem in Adobe Illustrator and I fixed it by going to

Edit, then Preferences, then User Interface, and chose "Scale to Higher Supported Scale Factor", and clicked OK, then restart the program.
Hope this can help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2018 Nov 03, 2018

Copy link to clipboard

Copied

Try the experimental features, if your version offers it!

Edit --> Preferences --> Experimental Features (it's on the bottom for me!) --> Scale UI to 200% for High Density Displays --> click OK --> Restart Photoshop

This is NOT helpful for computers with small screens like Surface Pros (I have one) as the menus just get TOO big and there's hardly any drawing room. In my opinion, at least. I prefer to maximize my drawing space since I have a small screen.

Hope this helps!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2018 Nov 17, 2018

Copy link to clipboard

Copied

I have a HP Envy 4k laptop and I faced the exact same issue.

Solution is just to override high DPI scaling behavior.

Steps to get this done:

Note: You need to configure the setting on a shortcut for the Photoshop CS6, either on the default shortcuts on your start menu or on your desktop or anywhere.

1. Right-click the shortcut for Photoshop and click Properties.

2. Click on Compatibility Tab.

3. Click on Change high DPI settings.

4. Make sure Override high DPI scaling behaviour is enabled.

5. Select System or System (Enhanced) option from the drop down menu for Scaling performed by:

6. Click OK for current window and then for the main Properties window.

7. Start Photoshop application using the shortcut you just configured using the above steps.

8. You are good now.

If this helped you to resolve your issue, please mark this as a solution.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Hi All

This is a nasty problem on new laptops with high resolution screens.

This solution is based on  a cs5 work around,

Just find the executable, right click select compatibility tab, drop to 2nd bottom button [ Change high DPI settings] in the new window click [ High DPI scaling  override ] important select system in drop down.

Don't forget to apply.

Hooray AE of old.

Bob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2019 Feb 09, 2019

Copy link to clipboard

Copied

On YouTube, user by the name 'Mario Uranjek' suggested to do the following which offers the same intended end result:

Just go to Properties > Compatibility and check the "Override high DPI scaling behavior" And select "System (Enhanced)"

Much easier solution that anyone can do, and works like a charm for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines