Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lasso Tool Lines not showing as I'm selecting

Community Beginner ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

I recently updated Photoshop CC to the newest version (20.0) on Friday and now every time I try to use my lasso tools the lines do not appear as I'm drawing to see what I'm about to select. It's acting the same for the lasso, polygonal lasso, and magnetic lasso tool. I've reset the tools, reset all Photoshop settings in my performance tabs and all. What am I missing? Help?

Views

33.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Deleted User
Nov 05, 2018 Nov 05, 2018
HiIf you uncheck "Use Graphics Processor" you will lose some functionality in Photoshop that requires a GPUMore infoPhotoshop graphics processor (GPU) card FAQHave you tried updating your GPU driver from the manufacturers website, you could also try setting the Drawing Mode to Basic

Likes

Translate

Translate
New Here ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Yes! I am having this problem too! So frustrating. The lines only appear after I have closed the selection.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

I was on live chat with them for a few hours and they solved it!

If you update and you have the same problem it’s a setting in Photoshop.

Photoshop - Preferences - Performance

Uncheck ‘Use Graphics Processor’ in the upper right and check ‘Legacy Compositing’ under the options section in the same window.

Then restart Photoshop and it should be working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Hi

If you uncheck "Use Graphics Processor" you will lose some functionality in Photoshop that requires a GPU

More info

Photoshop graphics processor (GPU) card FAQ

Have you tried updating your GPU driver from the manufacturers website, you could also try setting the Drawing Mode to Basic

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

Of course they don't tell you that and I had no idea why it was acting weird after it was unchecked. I'll look for an update and see if that resolves it!

Update: there is no update for my GPU—but switching it to 'basic' has restored all the functions and the selection tool works now. Thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 05, 2018 Nov 05, 2018

Copy link to clipboard

Copied

You're welcome

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 14, 2018 Nov 14, 2018

Copy link to clipboard

Copied

So the solution is to have reduced Photoshop functionality? That is not really very wonderful. Turning off GPU means no canvas rotation, among other things.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2018 Nov 14, 2018

Copy link to clipboard

Copied

No, the solution is what Ged Traynor stated in changing it from Advanced to Basic and leaving the GPU on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Both solutions submitted worked. I went with the advanced to basic...worked like a charm. Thank you Photoshop Gurus, your problem solving abilities save artists hours of slamming our heads on our desks.

Another life saved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2019 Feb 15, 2019

Copy link to clipboard

Copied

I just wasted hours of my life trying to figure out how to fix this problem with the selection tools. Setting drawing mode to basic works for me. THANK YOU!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

Ged Traynor, Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

This did NOT work for me. Nicholas's suggestion of opening an RGB file first worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2019 Nov 20, 2019

Copy link to clipboard

Copied

Yep. Grey scale to RGB - now all good - then back to grey scale - still all good

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2019 Apr 26, 2019

Copy link to clipboard

Copied

>>

Uncheck ‘Use Graphics Processor’ in the upper right and check ‘Legacy Compositing’ under the options section in the same window.

Then restart Photoshop and it should be working.

This worked for me. Lasso Tool and Text Select were invisible. Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2019 Aug 07, 2019

Copy link to clipboard

Copied

THANK YOU!!!! I was about to go crazy!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2019 Oct 08, 2019

Copy link to clipboard

Copied

THANK YOU VERY MUCH! 😄

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2019 Feb 12, 2019

Copy link to clipboard

Copied

Basically their solutions to every bug they have in the whole CC suite are to not use any of the new features.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2019 Mar 01, 2019

Copy link to clipboard

Copied

I was having the same problem with the lasso tool and no marching ants, and i went through the steps you guys have outlined. then i went backward until i got to the point that with advanced on, i could untick "anti-alias guides and paths" and it showed the selection. it may or may not work for you, but if you're looking to preserve some of the GPU power in the PS you might give it a shot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

This also fixed it for me. I'd suggest the as a better "Correct" answer than switching all GPU down to basic. It fixes the issue with the least impact. Now if they would just fix the stupid perspective crop grid and it's ridiculous edges.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2019 May 02, 2019

Copy link to clipboard

Copied

THANK YOU! - Just disable "Anti-Alias Guides and Paths" -- this is the fix. You don't need to change the mode to Basic, from Advanced at all. This solution worked without disabling any imperative graphics features.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

Unticking the "anti-alias guides and paths" in the advanced section showed the selection for me. Thanks, mojo_afmc!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

I may have found a simpler solution.

If the first file type you open after loading Photoshop is CMYK, the marching ants and transform boundaries don't display.

But if you open up an RGB file, then any CMYK files you open after that will display ants & transform properly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

That didn't work for me. I switching anti-aliased guides and paths back on. I opened an RGB JPG to test with. No marching ants. Turned it back off and marching ants are once again marching like good little soldiers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Perhaps try opening an RGB FILE rather a Jpeg cause opening a file definitely worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Hey Nicholas, Thanks very much...Yes it worked I switched to an RGB file then back to CMYK and the Lasso and select type tool woRJED perfect ....so happy rather than dumb down photoshop BY switching off graphics card this is a perfect WORKAROUND....You are a genius!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2