Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


my text won't show along a path I created

Community Beginner ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

I have created a path and typed text into it. Along the path is a little circle with an x in it. This little x appears to be hiding my text and i can not move it. How do I get my text to show up???

Views

28.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Sep 19, 2012 Sep 19, 2012
Pen tool. I am know using a shape and that is working. Thanks!

Likes

Translate

Translate
New Here , Dec 11, 2018 Dec 11, 2018
Just had this problem myself!Try changing your paragraph alignment.It’s easy to forget the alignment you selected last time you used the text tool, and instinctively click at the beginning of the path expecting your text to type from that point forward, but that requires left-alignment.I now know to remember to check paragraph alignment before adding text to a path!If you *want* to centre text on a path, make sure you click on the path where you want the midpoint of your text to be. If using rig...

Likes

Translate

Translate
LEGEND ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

Can you post a screenshot?

Generally, if your path is open, you will have trouble with type on path tool due to the contour of the shape itself.

Try having a closed path - such as ellipse. Try the type on path here and see if that works.

For open paths, with your text layer selected and active, click on 'Path selection Tool' from tools panel. This is clubbed with 'Direct selection tool' option.

Hover and click on your text layer. You will have 3 markers appear. The left most marker is the start of your type path. Right most is the end of your type path. Middle is the positioning/ centering of your text path. You can adjust these with 'Path selection tool'.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

I tried moving the points around and some of the letters show after doing that but still not the shape i want to hold the text on.screen print.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

How have you drawn your shape? Pen tool? Because I dont see a 'shape' layer in your layers panel.

I recreated the same thing on my system. Here's how it looks like.

Screen Shot 2012-09-20 at 1.03.42 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

Pen tool. I am know using a shape and that is working. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

The end-text marker needs dragged much further to the right for more than the initial 'C' to be displayed. Use the Path Selection Tool to drag the black dot seen in screenshot:

textonpath.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

There is no black dot..there is an open dot and a dot with an x in it. When I drag the dot with the x it makes it hard to keep the shape i would like to have.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2012 Sep 19, 2012

Copy link to clipboard

Copied

Maybe the dot with x doesn't turn solid black when not being moved in your version of Ps.

Anyway, if the path changes shape then you are not using the Path Selection Tool which I indicated. You must be using the Direct Selection Tool which is a white arrow in the same flyout as the black arrow. Use the black arrow to only drag the end-text marker.

Edit: You can use either of these selection tools, but you have to be very careful with the Direct Selection Tool (white arrow) because it's easy to accidentally manipulate the shape of the path instead of the text-end marker. Easiest to use Path Selection Tool (black arrow). You can toggle between black and white arrow by Cmd/Ctrl-clicking.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2012 Sep 21, 2012

Copy link to clipboard

Copied

Thanks this was helpful. Once I started pulling and playing around with the dots I was able to make it work as well as use a shape that worked too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2016 Dec 07, 2016

Copy link to clipboard

Copied

I have zero luck geting any text to show.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2016 Dec 27, 2016

Copy link to clipboard

Copied

I had the same thing. Reset all your tools to default from the drop-down box to the far right of the tool options box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Just had this problem myself!

Try changing your paragraph alignment.

It’s easy to forget the alignment you selected last time you used the text tool, and instinctively click at the beginning of the path expecting your text to type from that point forward, but that requires left-alignment.

I now know to remember to check paragraph alignment before adding text to a path!

If you *want* to centre text on a path, make sure you click on the path where you want the midpoint of your text to be. If using right-alignment, click to the right of the path. Etc etc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2019 Sep 20, 2019

Copy link to clipboard

Copied

This worked for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Yes! This worked, thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

This was the right answer! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

LATEST

This worked! thank you!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines