• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

OpenGL problem persisting (Photoshop 2022)

New Here ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Hello, I'm having a small issue. When I save my preferences, openGL functions (such as canvas rotation) no longer work. Simply deleting the preferences file (or resetting preferences when photoshop closes) resolves the issue when I next open photoshop. However, if I do not do either of those (if I attempt to save my preferences), openGL functions don't work again when I next open photoshop. It's not a major issue as I have a workaround in place, but it would be nice to be able to not have to re-customize my workspace every time. Here is a list of troubleshooting steps I've taken:

- Ensured openCL is checked on in preferences.
- Ensured I have a photoshop-compatible graphics card (RTX 2080).

- Disabled onboard Intel graphics card

- Settings for photoshop and sniffer.exe have been changed in the nvidia control panel to specifically use the nvidia GPU for openGL rendering.

- Ensured I have the latest drivers for the GPU. Ensured I have the latest version of photoshop.

- Tried running photoshop on other monitors (some are plugged into the GPU directly, others into the mother board).
- Set the cintiq (the monitor I use photoshop on) to run photoshop on 'high performance' mode

- Saved many different options in preferences separately (to rule out any possibility that specific preferences are causing the issue). It turns out that if I set photoshop to open on my cintiq (which is not my main monitor), openGL functions will stop working. However, deleting the preferences file, then opening photoshop, then moving it to the cintiq again seems to work fine. If I then close photoshop (saving the preferences), and re-open it (and now it opens on the cintiq by default), openGL no longer works.

I've searched high and low for a permanent fix. Everything I've tried has been a result of my searching, including deleting the preferences file, which KINDA worked. But not having to re-do my workspace customizations etc would be very nice 🙂

(I neglected to post the photoshop system info because it's very long and do not know if it would be relevant. Will be happy to post it if it's necessary).

TOPICS
Windows

Views

3.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Expert ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Hi @coryr82266433 ,

 

Some users have posted that they have had success using Photoshop as an Admin. Try setting up a new user profile on your OS, with Admin rights and see if that works.

 

Re your workspace customization, here is a link to Photoshop resource locations including custom workspaces.

 

https://helpx.adobe.com/photoshop/kb/preference-file-names-locations-photoshop.html

 

Copy your custom workspaces to a different location. Then if you reset prefs or reinstall you can simply copy them back to the location listed in the link.

 

Les us know how you go.

mj

 

mj_0-1640934114138.png

 

mj_1-1640934113647.png

 

 

Mohammed Jogie | iMSD.co.za |
Adobe Certified Associate |  Expert | Instructor |
Adobe Community Professional | Creative Ambassador | User Group Manager |
Member International Society of Typographic Designers | Lifetime Friend International Council of Design | Interaction Design Association Local Leader |
Member Pan Afrikan Design Institute | Ambassador Visual Arts Network South Africa | Central Executive Committee Member Printing SA |

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2021 Dec 31, 2021

Copy link to clipboard

Copied

Hey, thanks for the response!

I've installed GeForce studio drivers, which automatically uninstalls the game ready drivers. I'm currently only running studio.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2021 Dec 31, 2021

Copy link to clipboard

Copied

The default user is an admin. Forcing photoshop to run as admin doesn't seem to help

 

I'll look into the workspaces, though. If nothing else it'll be a less annoying work around, so thanks! 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Dang, that's so frustrating.

 

You may want to connect with Adobe suppport. https://helpx.adobe.com/support/photoshop.html

 

You'll need to wrestle with the Chatbot, then hopefully get through to a warm body.

 

Keep us posted ok @coryr82266433 .

 

Best

mj

 

mj_0-1643352420767.png

mj_1-1643352420766.png

Mohammed Jogie |
Adobe Certified Associate |  Expert | Instructor |
Adobe Community Professional | Creative Ambassador | User Group Manager |
Member International Society of Typographic Designers | Lifetime Friend International Council of Design | Interaction Design Association Local Leader |
Member Pan Afrikan Design Institute | Ambassador Visual Arts Network South Africa | Central Executive Committee Member Printing SA |

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2022 Oct 07, 2022

Copy link to clipboard

Copied

I also have Nvidia, after the 2022 update I staryted having this problem, after much time spent searching, this worked for me: 

Preferences>Technology previews>Deactivate Native Canvas

https://community.adobe.com/t5/photoshop-ecosystem-discussions/opengl-not-working/m-p/12076421

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2022 Oct 08, 2022

Copy link to clipboard

Copied

Finally fixed my girlfriends problem:) was about to reinstall windows.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2022 Nov 30, 2022

Copy link to clipboard

Copied

Worked for me!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Having just had the rotate tool fail on 3 different versions of photoshop, and not having the option to 'enable GPU' (greyed out) or disable native canvas (missing altogether) I unistalled my video driver (in my case Nvidia Geforce 840M and did a fresh install. So far seems to have fixed it.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

@Shayde48 Your GeForce 840M does not meet minimum requirements for current Photoshop builds.

The minimum ops/sec is 2000 and your card clocks in at 840.

You also need DirectX12 support and this card only supports 11.

You will not be able to run Photoshop without major issues using this graphics card.

Your choices are to either upgrade your card, or find a previous verison that supports the card, but I'm not sure how far back you need to go.

https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

LATEST

Only had the issue in the last 6 months though and on an older version of photoshop as I didn't like the 'improvements' they did. unchecking 'Deactivate Native Canvas usually fixes it but that's not helping today either, but only in PS22. As far as I know 19 and 23 work fine

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines