Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Loading stuck at adding extension Halide Bottlenecks

New Here ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Since migrating to new Macbook with Apple silicon, I have had the frustrating issue of getting stuck at loading.  Specifically it gets stuck on "Adding extensions...Halide Bottlenecks".

 

I have read through numerous community support threads and none of the proposed solutions have worked.  
1. No files of any kind, large or small, in the settings folder.  In fact my settings folder is not where this thread, https://helpx.adobe.com/photoshop/kb/freeze-on-launch.html, mentions.  Maybe that info is old.
2. No font cache files at the location specified in this thread: https://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop.html

 

I have done my best to remove PS and reinstall it.  I have used CC to remove and install multiple versions of the app, including the latest beta version.  Same problem everytime.

 

Again this is one the kinda new Macbook Pro 13" which has an Apple chip (non-intel).

I have been told by other designers to get off of Photoshop and move onto something like Figma and other tools.  I have resisted but I am now more tempted than ever.  I could have learned a new tool in the time I have spent trying to fix this issue.

 

{Thread title modified by a moderator, ACPLSUP-4204482)

TOPICS
Crash or freeze

Views

18.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 19, 2021 Feb 19, 2021
Hi All, This has been identified as a known issue by our product team, you may try the resolution steps mentioned here: https://helpx.adobe.com/photoshop/kb/known-issues.html#PhotoshopfreezesonlaunchmacOS Let us know how it goes. Regards, Sahil

Likes

Translate

Translate
Community Beginner ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

After a frustrating day of my own, I'm hoping I have a solution for you, my friend. I had the same issue after I transitioned to the new M1 Mac Mini. Went through the same troubleshooting steps you mentioned and spent some time with Adobe support to no avail. Rather than wait for them to get back to me, I kept researching on my own and I found a fix that worked. 

I had two separate issues - Photoshop was freezing on the Halide Bottlenecks (or one of the other extensions) and Creative Cloud was not retrieving storage information from the cloud. They seemed like separate issues, but I fixed both with the same solution.

 

I have a separate admin account on my machine and I read a post about using that account to install the applications instead of the primary user profile. I tried using the admin account earlier and had the same problem, but I did not try uninstalling everything and reinstalling. Here are the steps I used:

 

1. Use the CC cleaner tool to remove everything from the account it was installed on

 

2. Log off and sign into the admin account (if you don’t have two separate accounts, you can try creating a separate admin account)

 

3. Reinstall CC and any other Adobe applications

 

4. Test to make sure Photoshop loads

 

That's it! When you switch back to your primary account, everything should be working again. 

I migrated my data from my old Mac to my new Mac, so I'm not sure if there was a permission issue, but this worked for me. Best of luck and hopefully I saved you some trouble! 

-Ed

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

At least for me, this was the magic sauce.  I created a seperate admin account, even though I am the only user on my Mac and have the Admin role.  Did an uninstall and clean using the Creative Cloud Cleaner Tool.  Rebooted my mac and reinstalled Creative Cloud and then Photoshop.  Everything works now.

 

I still have my doubts about the admin step, but it worked.  

 

Thanks for the help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

Glad it worked! I was skeptical about the admin step too, but nothing else worked for me so I figured it was worth trying.

 

Out of curiosity, how did you setup your new Mac? Did you use the migration assistant to transfer the data from your previous machine? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

I have the same issue. used Migration assistent to setup my mac... I am not yet a happy 13" mbp m1 camper I have to say

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

I did the same. For those of us who used the migration assistant, the admin profile might be a key step in the process. The M1 expereince will get better in time as applications and plugins are optimized for the new chipset. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

Perfect! Thank You so much! Same problem and now seems it work...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

Perfect! Thank You so much! Same problem and now seems it work...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

It is great to hear this solution is working!

 

I'm adding two support articles I found while working through another Big Sur / M1 related issue with my Western Digital NAS drive. It seems there were some security changes in the new OS that require administrator privelages to update. 

 

There is a process of shutting down the computer, holding the power button, and then enabling extensions in the Startup Security Utility. This seems to be circumvented by installing the software under the admin profile. I'm curious to know if that would be the "correct" process. If anyone is having the issue and reads this post, try it out and let us know the result. 

 

https://support.apple.com/en-us/HT211860

 

https://support-en.wd.com/app/answers/detail/a_id/30307

 

-Ed

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

After trying most of the other methods discussed elsewhere, I tried this 4 step method and it worked for me as well.  Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

Omg... THANK YOU SO MUCH YOU SAVED ME! 
have no idea how much time i lost struggling bc of this issue ..... thank you so much for sharing your solution, it worked! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

Dear Ed,

 

you are the very best!!! After spending the whole morning with this Photoshop issue on my new Macbook, I finally found your advice and followed your instructions and now IT WORKS!!! Just wanted to hand over a very big THANK YOU SO MUCH! It's amazing you shared this process with us.

 

Wish you the best.

 

Gertrud 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

Thanks! Worked for me! And yes, I used migration assistant. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

THANK YOU!     I too used the Applu migration assistant and was having no joy even with Rosetta installed.     And nothing would work.

 

I followed your steps above making a new admin account, etc and I have everything back up and working.

 

Long-time Apple fan, but this release of the M1s seems a bit disjointed.   First, a lack of multiple display support in the silicon and now poor support by Adobe.   I would have thought Apple would continue to play to its loyal base of users for whom both of these are critical features.   I've discovered work-arounds for both, and am optimistic the M1 will deliver, but not exactly the "out of the box" experience I've come to expect and love from Apple.

 

Thanks for documenting this here and providing this guidance.   It just saved me a TON of headaches today.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

Hi. I'm trying your solution. Since moving to Catalina I've had nothing but trouble with Adobe products.

 

Please tell me: how do you create a second admin account? Could you please go into more detail about this? Thanks.

 

Dan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 07, 2021 Oct 07, 2021

Copy link to clipboard

Copied

LATEST

Hi Dan,

 

Sorry I wasn't able to reply sooner. Here is an article from Apple that explains how to create a new user account. Make sure you select "Administrator" as the user type. https://support.apple.com/guide/mac-help/set-up-other-users-on-your-mac-mtusr001/mac

 

After you create the new account, follow the steps I posted. Keep in mind, this worked for several people moving over to M1 Macs, but I am not sure if this will resolve the issues you're having with Catalina. Worth a try though! I'll keep my fingers crossed for you. 

-Ed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

If your Photoshop get stuck or the application was not responding and it stated “Adding extension.. Halide Bottlenecks”, “Adding extension….MMXCore Routines”, “Adding extension… FastCore Routines” and “Adding extension…Multiprocessor Support”. Please follow the steps listed below. 

1. Download the AdobeCreativeCloudCleanerTool (I have attached SS of it below). 

2. Select > Clear all (It will delete all the adobe files, you have to make sure you have a backup of imp files).

3. Restart Macbook once it successfully clears all the data.

4. Reinstall Creative Cloud.

5. Reinstall Photoshop beta (Latest version).

6. Select the intel version of Photoshop(check the SS) because the other version still gives me the same issue but the Intel version works fine for now.  

I hope this information will save a lot of your time and wish everyone in need get to see my post.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Hi

Bug reports/issues for beta versions should be reported here

https://feedback.photoshop.com/topics/photoshop-beta/5fb2d2db8eb4db34ff8f67b7

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Thanks for sharing this, worked like a charm! Since upgrading to a mac with an M1 chip it seems only the beta version of photoshop works without crashing during launch. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Okay, I will post it over there as well! Thank you. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

Chiming in here to say that this WORKED for me!! I am on a M1 Macbook Pro. I had the issue of the Halide Bottleneck extention hanging at startup and Anurag Gaonkar's steps worked.

 

I followed exactly until step 6, where I didn't see the option to open the Intel version. I just made sure that my Macbook was completely updated to the latest version as well as Photoshop Beta. After a restart I opened Photoshop Beta and the Halide Bottleneck issue was solved! Everything is running properly and smoothly.

 

Thank you Anurag! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

I have attached a screenshot, you can check that. In the latest update, that option is not visible I guess, but I am glad that I was helpful. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

omg thank you so much I've been on adobe customer support for 3 hrs with no avail, only to have the support guy blame Apple in the end. Only thing I did differently here I guess is instead of installing the v22.2 (which didn't work) I went with v22.1.1 and it WORKED. Bless you!!!!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

Hi, I've tried v22.1.1 and 22.1 on my new mac using the m1 chip. It freezes on load screen. Specifically the 'Adding Extension... Halide Bottlenecks". Can anyone assist me on how to fix this? I have projects due and I need to get photoshop up and running. Thanks in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

I'm trying the beta as well and it also freezes on 'Adding Extension... Halide Bottlenecks'

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines