• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
39

P: Pen Tool Not Working as it should

Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

I have just updated Photoshop to v22.3 (10 March 2021). When I try to use the Pen Tool it puts the nodes in but doesn't create a linking line. I have closed everything and re-started my PC but the error still there. I've been trying to find a way to report this to Adobe but this is the only feedback area I can find. I have been using Photoshop for over 20 years and using the Pen Tool all that time. I need to complete a job but I'm now stuck as I need this tool.

 

Can I uninstall this update?

 

Anyone else having this problem?

 

Do Adobe monitor this feed?

TOPICS
macOS , Windows

Views

16.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
replies 370 Replies 370
Community Beginner ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

Anyone out there tried to update with success as of late? Just curious since Adobe thinks the problem is "solved" in spite of all the users saying it isn't, and last iteration of 22.4.x I tried it was still happening...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Okay this is super frustrating. I can't work like this. Is Adobe working on a fix for this?? I am working on a PC laptop, using CC and everything is up-to-date. Can anyone confirm that there was a version with a working pen tool I could go back to?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

My pen tool is working now but I can not add a color to my path. v22.4.2 Any fix for this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

The recent 22.4.1 update has fixed the problem for me. The pen tool now works perfectly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Here is an update on my status. I uninstalled Photoshop and reinstalled it. No change.  I reset preferences on quit and it made no difference.

I did find a work around however.  In my case, this seems to be a video issue.  I discovered the path is there. If I click a point, click another point and so on, say around a square shape, when I come all the way around and join the beginning point the full path is there. Curves work, everything works but one cannot see the path. What I discovered however is that if I click on the sliding bar below or beside the image to move left/right, up/down, the video resets and the full path shows.

In a more complex test. I started a path, did several curves and between each one clicked on the positioning bar and the path displayed. Total hassle but it works.

I've also noticed that the boundary boxes are not visible when I zoom out but if I click out of the frame, they display. I'm beginning to wonder if there is something going on with the way Photoshop is refreshing the video.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Michael Bullo posted this in a different thread:

"Have you tried resetting the Photoshop Preferences? Look for the Reset Preferences On Quit button within the General tab of the Preferences."

I clicked on that button and restarted PS and the pen performance returned to normal.

This worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Hello there

I am having issues with pen, see email below.

I have  installed the older version, and try the new version of Adobe Photoshop and still have not fix this bug.  what should I do?

PSissues-dc59d73c-7da9-46ab-ab9e-b7b00e4c9528-78359792.jpg
Thank you 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Pen tool is a mess!  Completely unusable.  Photoshop CC updated May 25, 2021.

Tried resetting tool, no good.  Suggested work arounds with named/ renamed paths or whatever... no good.  Some thief came and took a tool out of my box.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Yes the pen tool isn't working as it should and Photoshop lags terribly. Same issues with the lag in Illustrator.

All the latest versions installed on a brand new Mac Pro 2019, 3.3 GHz 12-Core Intel Xeon W, 160 GB Ram, AMD Radeon Pro 580X 8 GB. So I can't believe it's the hardware.

When drawing a new path with the pen tool and click away to deselect the path but leave it visible - all the nodes stay selected until I zoom in or out, and even then the path intermittently becomes invisible. Similarly click to deselect the path in the paths panel and it's still showing on the file until zooming in or out. And simply moving the image around with the hand tool... the lag is like wading through mud!

I've been using Photoshop for over 30 years and this is the worst it's ever been. It's costing me time and money... simple hand-drawn masking is near impossible. Please Adobe fix these issues - basic functions professionals need to work efficiently.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

22.4.1 Still acting bizarre on my system.  Win 10.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Just updated to 22.4.1 and pen doesn't work right. When I use the pen and keep clicking away, the nodes or lines don't show. When I close the selection, turn the layer off and back on, the nodes and lines are there. If I click and drag, everything shows but not with straight clicking alone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Just updated to 22.4.1 and still doesn't work right. Bring in, let's say jpg, duplicate the layer and start clicking straight lines. No nodes or lines show up until I close the selection, hide the layer and bring it back. Then the nodes and lines shows as they should. If I drag the point while clicking, they show but not with straight clicking.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Thank you Adobe for the latest update - the pen tool works again as it should.

This is no longer an issue on Mac/Big Sur.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Hi,

 

We're happy to announce the release of Photoshop 22.4 which should include the fix for this issue. To update Photoshop to the latest version, you can check: https://helpx.adobe.com/creative-cloud/help/creative-cloud-updates.html

 

For information on other issues fixed with this update, please check: https://helpx.adobe.com/photoshop/kb/fixed-issues.html

 

Regards,

Nikunj

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Upgrading to 22.3.1 didn't fix the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

same here, only works if you deselect all paths and let the PS automatically create a new path by starting a new draw with pen tool

----------------
First Photoshop 2.5 (1994)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Somehow I am not surprised 2 months later and this is still an issue.

I rolled back to 22.2.0 and things are back to "normal" with a functioning pen tool and the other issues I was previously suffering with. I don't know why we pay Adobe monthly for constant beta like "updates." I update in hopes of old issues being resolved, to only be met with new ones.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Staying with a problematic pen tool - this is a different problem (but still the pen tool), has anyone else noticed this? I used to be able to make several paths on a single path layer in the path tab. Click off the layer. Then click on the layer again with out having to activate any of the paths on that layer with a path selector - just click the layer - THEN click the marquee outline button and all the paths would be made a selection from that single path layer. When I do that now, I get an error that says: "Warning No pixels selected." I click ok on the dialog window and the path layer deselects. If I activate all the paths I drew on that layer with teh path selection tool, and click the marque button, I get the same warning that no pixels were selected.  If I want all the paths on that single layer to select when I click the selection button, I can't do it, I have to select one path at a time on that layer with the path selection tool and activate that path with the selection button - then do that again with each path on that layer. BUT - if I click on the path layer that has multiple pen paths and then click the line button, all the paths on that layer get outlined (just as I am used to with the marque button). Hope my description is making sense here. Anyone? An example would be I would make a path say a circle, and make a smaller path inside that path. Then click off the path layer. Click it again so the layer was active. Then click the marquee  selection button and what I would get is a selection of the circle with the smaller path inside punched out... so it would be a donut or ring. I did this for years for product packaging that had these  shrink wrapped donut handles... but now this function isn't working in the pen tool. Does something need to be set in preferences? or for the pent tool panel in PS 21? It isn't working in PS 20 anymore either. All with latest updates (and on latest version of Apple Big Sur).  I have tried selecting each of the path rules in the tool behavior dropdown before selecting the layer but always get the same result. Only the inner path gets the marquee selection - however - both paths will get lined if I click the line button in the path panel. Very strange. Yes I can work around it - but this used to be a simple workflow and now there are extra steps. And as all the professionals in this form know, extra steps to our workflow slows us down: little here, little there. So please, if anyone has noticed this change or knows a solution, please write in?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Still a bug.  Let me say that again... STILL a bug.  Here's hoping they don't break every single tool in Photoshop as they improve things.  Adobe... some of us actually feed our families using your software and would be very grateful if you'd beta test your updates appropriately before sending out the door. This would have been caught right away.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Hey there!

I have the same issue. I am working on the latest edition of Photoshop and on a Windows 10 computer. The issue that we have (just to see if I understood correct) is that when we try to continue any path that we left, photoshop just creates points without actually linking those points together. I contacted Adobe Support and the person the Adobe representative insisted that they all work fine....he connected to my computer and he started creating points insisting that everything works fine and I can not see the linking line because of the document colours!!?? (even though I was seeing the path that I created earlier..😂😂)! What I tried myself is to create a vector mask with that path and then continue the path....that might be a solution until Adobe fixes the problem.

Am I missing something? Let me know if I did not understand correctly.

Thank you

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

I'm having this problem too

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Still not working
Shame on you Adobe!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Same here to all the above.  This may be the worst and most problematic release of photoshop ever. No matter the fixes, there is always more misbehavior. I realize how difficult programing this software can be for so many operating systems, video cards etc., but why release such a problematic version? Honestly, I am sure most of us would be fine with the same version for two years or more before a new and stable release would come along (mark the word stable - stable is FAR more important to me than anything newly added)...Running a Mac with Big Sur using PS 22.3.1 and yet one more disappointment. (from saving error, to lagging radial tools in ACR to lagging brushes and now non-connecting path nodes - never mind the poor memory management aka leaks). Please fix ASAP please? And yes - I have moved back to the previous Photoshop (and Bridge) release to work on my projects. I am happy to get back with the Beta team to help this get worked out- just let me know). 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Just upgraded to 22.3.1 and this issue persists. Points are visible; paths are not visible.

Looks like this has been going on for a while now, and the latest version does not fix it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines