• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Photoshop layer via cut removes the pixels

Community Beginner ,
Feb 07, 2023 Feb 07, 2023

Copy link to clipboard

Copied

  • When I do a layer via cut for a selection by magic wand tool, it removes/deletes the pixels at the edge/boundry of my selection. I dont want it to do that. It doesnt do it with any of the other selection tools but only for the magic wand tool. How can I prevent it to do that?
TOPICS
Windows

Views

897

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Feb 08, 2023 Feb 08, 2023
And this one is the case of applying Threshold in Quick Mask Mode.

You seem to have created a Threshold Adjustment Layer – naturally that has no effect on the Quickmask. 

 

Edit: To apply Threshold to a Channel use  Image > Adjustments > Threshold 

Votes

Translate

Translate
Community Expert , Feb 08, 2023 Feb 08, 2023

Checking or unchecking anti-allias doesnt make any difference as shown. And the view was already > 100% but this is the exact view > 200% as an alternative.

No, it was not. 

Anti-alias needs to be unchecked before creating the Selection. 

Votes

Translate

Translate
Community Expert , Feb 08, 2023 Feb 08, 2023

Actually I was mistaken, it seems; the Tolerance should not matter as long as »Anti-alias« is off before creating the Selection. 

Votes

Translate

Translate
Community Expert ,
Feb 07, 2023 Feb 07, 2023

Copy link to clipboard

Copied

Hi, could you share an example? I do not see a difference when I do a Ctrl+Shift+J after a rectangle or a magic wand selection.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2023 Feb 07, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_3-1675806528955.pngAytllge266218927ub0_4-1675806548906.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2023 Feb 07, 2023

Copy link to clipboard

Copied

It was deleting the pixels at first, I dont knıow what is changed but now I doesnt. It changes the colors instead. Ive tried to uncheck anti-alias.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

I dont want it to change the colors neither. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Could you please post screenshots taken at View > 100% with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_0-1675854695489.png

Aytllge266218927ub0_1-1675854716184.png

P.S: Checking or unchecking the anti-allias button doesnt make any difference.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

That seems to be the expected behaviour for that Tool and those Settings (Tolerance greater than 0). 

You could amend the Selection before Cutting (enter to Quick Mask Mode, apply Threshold, exit Quick Mask Mode). 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Unfortunately, neither switching the tolerance to 0 nor applying Threshold in Quick Mask Mode doesnt make any difference. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Hi, @Aytül İlge266218927ub0 @did you change the gamma blending in Color Settings?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_0-1675866463928.png

What should the values be?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied


@Aytül İlge266218927ub0 wrote:

Unfortunately, neither switching the tolerance to 0 nor applying Threshold in Quick Mask Mode doesnt make any difference. 


Please post screenshots taken at View > 100% to illustrate that. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_0-1675866649994.pngAytllge266218927ub0_1-1675866685605.png

  • This one is for the case of tolerance=0 (Using tolerance=0 for each cases is sth reallly annoying anyway, it necessitates so much effort to select pixels.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

You activated »Anti-alias« again and I asked for screenshots taken at View > 100%. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_0-1675867422996.png

Aytllge266218927ub0_1-1675867439202.png

Checking or unchecking anti-allias doesnt make any difference as shown. And the view was already > 100% but this is the exact view > 200% as an alternative.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied


Checking or unchecking anti-allias doesnt make any difference as shown. And the view was already > 100% but this is the exact view > 200% as an alternative.

No, it was not. 

Anti-alias needs to be unchecked before creating the Selection. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

I thought I did it "before selecting" but I was confused I guess. Thanks for the answer, this time it worked. 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Aytllge266218927ub0_2-1675867085462.pngAytllge266218927ub0_3-1675867110196.pngAytllge266218927ub0_4-1675867175581.pngAytllge266218927ub0_5-1675867232107.png

  • And this one is the case of applying Threshold in Quick Mask Mode.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

And this one is the case of applying Threshold in Quick Mask Mode.

You seem to have created a Threshold Adjustment Layer – naturally that has no effect on the Quickmask. 

 

Edit: To apply Threshold to a Channel use  Image > Adjustments > Threshold 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Thanks a lot, it worked right now. But it wasnt needed to be done before. This problem has just emerged. So I believe its a problem related to a setting that I dont know about. Having to do this process everytime I use the magic wand tool is a bit annoying, so it would be great to learn to change the related setting if any.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

Actually I was mistaken, it seems; the Tolerance should not matter as long as »Anti-alias« is off before creating the Selection. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

LATEST

I thought I did it "before selecting" but I was confused I guess. Thanks for the answer, this time it worked. 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines