• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Photoshop (Windows) locks focus on blending mode/dropdown menus

Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

On a Mac, if you select a blending mode in your layers pallete you can carry on working as normal and keyboard shortcuts function as expected.

 

In Windows, if you change the blending mode (or anything that uses a dropdown window), focus is then locked dropdown, essentially disabling your keyboard shortcuts until you either hit escape or click away. Please can this be fixed?

 

I was hoping this would be resolved by now but it's still a huge annoyance for those who have had the misfortune of switching to Windows from MacOS. I know it's just one additional click/keypress but it adds up over time and ultimately just slows you down/drives me insane.

TOPICS
Windows

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Adobe Employee ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Hi @Nick2049 

 

Let's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Hi @CoryShubert 

I don't need to reset my preferences because this is a new install of the latest PS release, on a clean install of Windows 11. This issue has existed for years and was also present in Windows 10. I tried it on a third workstation (also Win 10) just to be sure and I can confirm it was the same.

 

If you just try what I have described on any windows machine you will see what I mean. It's not specific to mine.

 

thanks 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Here's an example:

Example.jpgI simply created a new layer, changed the blending mode to lighten, and now you can see focus is locked on the blending mode dropdown (blue outline) and thus prevents you from using any keyboard shortcuts. You have to first click away, or hit escape to release focus from that dropdown. You do not have to do this in PS on a Mac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Thank you for the update @Nick2049 

This appears to work as designed on WinOS. 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

So you're saying its a limitation of the OS and it can't be resolved, basically?

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

I would be interested in hearing why this is as designed, too as @Nick2049 mentioned earlier, this is not the design on MacOS. Failing that, I'll put a +1 in for this to be altered.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 18, 2023 May 18, 2023

Copy link to clipboard

Copied

Any update on this @CoryShubert ?

I understand the issue is caused by Windows, but others applications seem to get around this.

Would it be possible to build in the equivalent of hitting the escape key when a selection is made from a dropdown? I'm no coder, so I appreciate that might be an oversimplification, but this.. feature.. is infuriating when trying to work efficiently in Windows, especially as a user who has to work across both platforms.

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

Hi Cory,

I have lived my life for 20 years in the software industry and know exactly where your answer is coming from. Please find someone who can own the problem and provode a proper answer. There is no such design as to "disable all windows shortcut, for windows users, if they set the layer blending mode". Photoshop user community is not stupid. This bug must be fixed by Adobe. Adobe has been punting this down for years now and I'm sure it's somewhere sitting in the backlogs.  


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 12, 2023 Sep 12, 2023

Copy link to clipboard

Copied

Yeah, I would also add that there is clearly a way around this because so many other applications do not behave this way in Windows. 3ds Max for example does not lock focus on drop down menus like PS does.. and autodesk havent updated that UI in 800 years so.. Who can we reach out to @CoryShubert ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

Hello everyone

Please Adobe, fix this issue.
That problem drives me crazy for years now.

I had a similar issue with the ALT key in Premiere Pro...  solution was a script/program (outside of Adobe).
I think the program was AutoHotKey. 
Several months later I found all my windows systems corrupted with viruses, trojans and malware.
I don't know what software (maybe AutoHotKey) or something else was the cause.
Learning from that, I definitely use no more programs or scripts that can easily corrupt my pc.

By all respects, but I can not accept the same (for years now) simple answer from Adobe... "it is a Windows problem".

So please please address this issue seriously and fix it.

I`m not switching back to OSX, only for this simple but incredibly annoying problem.

Thank you for your support.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 26, 2023 Nov 26, 2023

Copy link to clipboard

Copied

According to Deke McClelland, an author and expert in Adobe products, this bug has been affecting Windows users for at least a decade. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2024 Apr 02, 2024

Copy link to clipboard

Copied

LATEST
Hi Everyone

First, thanks Bojan for the information.
It helps a bit that some "pro" people know about this.

So, sorry ..or not sorry for Adobe :P, that i bring this post up again.
But I am frustrated with this issue and have decided to do something about it.
 
Maybe someone at Adobe has a heart for us Win11 users and has a serious focus on this issue.
 
Second, I decided to try to find a solution with AutoHotKey. 

 

I`m not a fan of these AutoHotKey-key-scrips, but unfortunately I think there is no other way until something happens from the Adobe/Microsoft side.
 
So, is there someone here with experience or a solution to solve this with AutoHotKey?
I searched for 4 hours and the only script that I found is this "alt key" issue that I mentioned.
 
I`m a total newbee for scripts, so I think the "power of community" is a good way for a specific interface problem like this.
 
Thanks for any help! 

 


Cheers from Switzerland
Chris

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines