Polygon Lasso Tool Closes Selection at Random

Explorer ,
Nov 05, 2013 Nov 05, 2013

Copy link to clipboard

Copied

I am experiencing the same Polygon Lasso glitch that has been brought up by several others; however, I haven't seen a solution.  I'm posting again JUST IN CASE someone new sees this and can share how they may have overcome this frustrating issue.

Here’s the problem: Polygon Lasso decides to close the selection FOR NO REASON AT RANDOM.

Let me clarify that I am an advanced Photoshop user (certified expert by Adobe).  I know all Photoshop tools inside and out and this is DEFINITELY not user error. Photoshop CC is glitching and it needs to be fixed.  Thing is, this only started for me very recently; within the last few weeks.  (Kinda close to when I updated to Mavericks on my mac but I’m not sure that has anything to do with it)  

To re-iterate, this is NOT a double-clicking issue or anything done wrong by me. Making lots of small lassos joined by the shift key is also NOT a solution.  Switching to the pen tool is also NOT a solution because my workflow depends on the speed of the lasso tool.

The real reason why I’m bringing this up is mostly because, like I said, this is only a recent problem.  Was there just an update to Photoshop CC that would have caused this? It’s driving me crazy and putting a serious hiccup in my workday since the polygon lasso is such a key tool. 

Views

26.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Oct 26, 2014 Oct 26, 2014

Likes

Translate

Translate
Participant ,
May 15, 2014 May 15, 2014

Copy link to clipboard

Copied

Hate to be a buzz killer here, but the "White Window" work-around plugin will only worked for a while. I installed it when it was first available, it fixed everything, but now not so much. The blanked out popups is still fixed, but over the last couple of weeks anything that involves a selection (lasso, polygon etc) is locking up; then the Patch and Content-Aware selection stopped working. I suspect Apple cares but can't fix it, Adobe could fix it but doesn't care, and Wacom is just flying blind and blaming everybody else. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 11, 2014 Nov 11, 2014

Copy link to clipboard

Copied

wow.  that's it.   THANK YOU.

reposting on other thread on the subject.   This issue should be listed as ANSWERED.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2015 Mar 03, 2015

Copy link to clipboard

Copied

YOU HERO!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2014 May 28, 2014

Copy link to clipboard

Copied

Same problem here. Plugin worked for a while now the lasso is unusable again. Works fine with a mouse but craps itself on my Wacom Pro.

Unbelievable that Adobe or Wacom or whoever the f%^$ is responsible for this mess have done nothing about it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

Same problem here, bought a new tablet thinking that would fix it.  It didn't.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

This is a complete joke, do any Adobe staff read these forums. Using my Wacom pro with CC on Mavericks is unusable. Polygon lasso, painting with brushes hangs photoshop until I click to another application and then back again. I've been putting up with all of this for over six months now, am i entitled to a refund because the software isn't fit for purpose? Laughable situation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

This plugin worked for me:

Menus, shortcuts, Lasso tool, and/or Photoshop stop working when using a Wacom tablet | Mac OS

Well, it works until you update anything on your computer, then even thought the plugin is still in the folder it no longer appears under Help/System Info so you're back to an unusable Photoshop. So you have to remove the plugin, download it again, and put it back in there. I've wasted so much time with this stupid bug and I find it incredible that Adobe hasn't fixed this. I think I'll be looking for another program for my colouring needs...

ADOBE PLEASE FIX THIS WELL KNOWN BUG IN YOUR SOFTWARE!!!!!!!!!!!!!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

Adobe Sux wrote:

ADOBE PLEASE FIX THIS WELL KNOWN BUG IN YOUR SOFTWARE!!!!!!!!!!!!!!!!!!

Could the problem be in Mac OS or Wacom Driver where it it documented that its an adobe Bug?  Has Adobe acknowledged it to be a Photoshop Mac bug. There does not seen to be a problem on Windows systems. In Windows, Wacom driver or Photoshop. The Adobe link you provided look to be a work around for Mac OS  with Wacom tablets and Photoshop no where did I see any indication there that it a bug in the different version  of MAC Photoshop,   Since Adobe know about the problem and is providing a work around.  Why would Adobe not fix a known problem and provide a work around if the problem is in Adobe code wouldn't Adobe just fix its bug.

Perhaps Adobe Apple and Wacom are working together to fix the problem the best way possible.

You write that the Plug-in workaround no longer loads after the last Photoshop update. Perhaps the plug-in file is corrupt did you try refreshing the plug-in file?  Are you using CC for CS6 has not changed lately.  Only ACR is updated for New Camera support in CS6. CS6 bugs are not being fixed.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

The plugin still works for me. I haven´t had any problems after that. I have the latest update of Mavericks and the latest Wacom Driver. So currently Im a happy customer..

But I agree, a plugin fix isn´t a permanent solution, and when the polygonal lasso tool doesnt work it´s extremely frustrating for a professional artist. And if it in in fact doesn´t help for everyone with the plugin, Adobe should drive apple hard to fix their problem, if it is in fact OSX Mavericks that has the problem. But, for what I know, the polygon lasso tool could be made up of old code and Mavericks will never support it. It´s Adobes responsible to make it work for their customers. Polygonal lasso tool is a common tool, in many applications...Only Photoshop from what I know of doesn´t work with it in Mavericks, maybe the tool needs a bit of redesigned code then?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2014 May 30, 2014

Copy link to clipboard

Copied

Instead of supplying a plugin which has to be reinstalled after every update, why isn't the fix written into the update itself?  I'm sure there are thousands of people out there experiencing these issues that weren't lucky enough to stumble across the link to the plugin...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 30, 2014 May 30, 2014

Copy link to clipboard

Copied

I have the same issue using a Wacom Intuos 3 on Mavericks, but not when running on a Windows 8 machine. I would be more inclined to point blame at OSX rather than adobe on this one. I would recommend raising topics on the mac os/wacoms forums as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 30, 2014 May 30, 2014

Copy link to clipboard

Copied

In this case I agree it could well not be an Adobe Problem. Still Photoshop does have quite a few bugs Adobe has acknowledged as bugs that Adobe does not care to fix Adobe just write they may fix these in the future. Will that future ever come or will Adobe's demise come first. Time will tell however I suspect my demise will precede either.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
May 30, 2014 May 30, 2014

Copy link to clipboard

Copied

The plugin was written to work around MacOS bugs - that are being fixed by Apple (one was already fixed in MacOS 10.9.3).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2014 Jun 15, 2014

Copy link to clipboard

Copied

I updated the drive - didnt seem to fix the issue.  By accident I found if i touch the pad then drag the tip into position the lasso works perfectly and doesn't close until i reach the end!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2014 Oct 26, 2014

Copy link to clipboard

Copied

I have a wacom tablet and am facing the same lasso problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2014 Oct 26, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2014 Nov 16, 2014

Copy link to clipboard

Copied

I use a PC and this is happening to me, as well, so the Mac OS fix isn't going to work for me.  Any other PC users experiencing this? I am using a Wacom tablet Intuos3 and have had to resort to using the pen tool for selections.  This started with the newest upgrade of CC2014.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 17, 2014 Nov 17, 2014

Copy link to clipboard

Copied

I'm using an Intuos3 @ home on windows8.1 without any problems. Windows 7/8/8.1(maybe even vista) all have a build in tablet/pen touch services which run in the background. They can cause conflicts with the wacom services.

Have you tried to manually stopping/disabling them from services.msc/msconfig.msc or by going to the control panel and turning off pen&touch?

Have you also updated your Wacom drivers?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2014 Nov 22, 2014

Copy link to clipboard

Copied

This is not only a wacom issue. I only use a PC with a regular mouse and have been experiencing this issue for at least a year.  Was using CS4 on laptop, CS5 on desktop and recently bought a new laptop and am trying CC.....all programs give me the same issue when using the polygonal lasso.  Thought I would fix problem by switching to CC, but no such luck.  Will not be extending CC after trial since that was the only reason I tried it. If anyone knows of a fix for this issue on a Windows 8 PC, please let me know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2016 Jan 19, 2016

Copy link to clipboard

Copied

Started having this same trouble today after upgrading to Windows 10.  The problem persists after updating all my Wacom drivers, video drivers, etc.  To make matters worse, I updated my Photoshop from CC 2014 to CC 2015.  Not only did the polygon lasso problem stay, but new bugs reared their ugly heads.  This is extremely frustrating, because I have lots of serious client work to do, and I feel like I'm going to have to downgrade my system back to previous versions just to get any work done.

This is happening on an early 2013 MacBook Pro with all the trimmings, running Bootcamp.  When it was running Windows 7 and Photoshop CC 2014, everything worked flawlessly.  Now I'm ready to throw it out the window.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 26, 2016 Jan 26, 2016

Copy link to clipboard

Copied

I just upgraded to the latest version of PS v16. I cannot even access the Polygonal Lasso Tool. When I used the radio button to see the options, the magnetic lasso is there but no polygonal. Tried resetting the tools, and quitting and restarting the app with no success. Anybody have a solution?

Apple iMac

Mac OS Yosemite

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 20, 2020 May 20, 2020

Copy link to clipboard

Copied

This only works for MAC. I am on PC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2015 Mar 22, 2015

Copy link to clipboard

Copied

I have searched in forum for corrections or a work around to this issue.  I am running a new Lenovo PC and tracing the complex image of a baseball player with the field, fence, etc in the background.  I am using a mouse to select the trace points on the image.  I have tried both the magnetic and polygonal lasso tool and in the last 6 attempts the tool auto-closes the lasso.  It is very frustrating to invest the time into accurately tracing the image then have it auto close randomly with no way to unlatch the lasso and continue.  I am not double clicking or clicking too fast.  The program chooses a new random location to close each time.  I have tried to enhance the contrast as someone suggested yesterday and it made no difference.

I would like to make some nice Game Day posters for the local teams with the players in color and the background in B&W but can't make this work because of this issue.

Has anyone figured out a solution or work around?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 17, 2015 Apr 17, 2015

Copy link to clipboard

Copied

This is also occurring on my CS4 and CS6 versions, without tablet, using only a wired or wireless mouse. Adobe, PLEASE FIX THIS!!!!!! As well stated by other users, this is a critical bug in the functionality of a major capability in the program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2015 Apr 19, 2015

Copy link to clipboard

Copied

I am also having this problem on my home PC. I have CC installed at work and it has no issues. I got a new computer at home and now I can't use the selection tools. After a random number of clicks it just auto completes and ruins the selection. I am about ready to rip my hair out. I am using Windows 8, a wired mouse, ( I have a tablet but I guess people are having issues with those too.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines